Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1292105

    Bestfortmyersrealestate.com
    Main menu>lehigh acres. submenu Alva has grey background. All other submenus correct.

    Burger menu

    Main menu background clear so difficult to read. should be #315d28
    Sub menu is grey instead of #315d28

    Tried various css I found on enfold but none worked

    Tks
    Dave

    • This topic was modified 1 week, 6 days ago by  daves1997.
    #1292136

    Hey daves1997,

    For the first issue, Can you search and comment this:

     background: #7d7d7d!important;

    from the css.

    For the second add this to quick css:

    .av-width-submenu.av-active-burger-items{
        background: #315d28!important;
    }

    Best regards,
    Jordan Shannon

    #1292147

    Do not know how to search and comment first code.

    #1292523

    Hi daves1997,

    Jordan just meant you need to go to Enfold > General Styling > Quick CSS, then find this code:

    background: #7d7d7d!important;

    then to comment it out, just add /* in the beginning of the code and */ at the end, so it would look like this:

    /* background: #7d7d7d!important; */

    Best regards,
    Nikko

    #1292547

    Thats what I thought. However there is no 7d7d7d7 in quick css

    #1292571

    Hi Dave,

    I see, it seems the reason why it’s showing is because Lehigh Acres has mega-menu enabled.
    I have disabled it, please check.

    Best regards,
    Nikko

    #1292575

    That helped. Burger menu still difficult to read. either transparent background or grey.
    Thanks

    #1292578

    Hi Dave,

    I have added this CSS code in Quick CSS:

    .html_av-overlay-side #top .av-burger-overlay-scroll,
    .html_av-overlay-side #top .av-burger-overlay-scroll .sub-menu {
        background-color: rgba(0,0,0,0.9) !important; 
    }

    Please review your site.

    Best regards,
    Nikko

    #1292610

    when I looked on my phone, same issue. restarted phone and still have the issue

    #1292829

    Hi Dave,

    Here’s a screenshot from my android phone using Google Chrome. (link in private content)

    Best regards,
    Nikko

    #1292890

    Mine looks entirely different. see link

    #1293195

    Hi,

    Thank you for the update.

    Do you remember adding this css code somewhere?

    .header_color .header_bg, .header_color .main_menu ul ul, .header_color .main_menu .menu ul li a, .header_color .pointer_arrow_wrap .pointer_arrow, .header_color .avia_mega_div, .header_color .av-subnav-menu>li ul, .header_color .av-subnav-menu a {
        background: #7d7d7d!important;
    }
    

    It applies the background #7d7d7d to the second level menu items. Also, you may have to disable the mega menu option for the “Lehigh” menu item.

    Best regards,
    Ismael

    #1293256

    no. didn’t you check? tks

    #1293536

    Hi Dave,

    It seems the issue is caching.
    The results are different when you’re logged in and not (this can be reproduced by using chrome in incognito mode and toggle device to a phone).
    I have posted the CSS fetched when logged in and not and based on the URL it points to WP Optimize.
    Here are the things I’ve tried (and combination of these things):
    – reset minified files
    – disable minify (enabled back)
    – purge cache
    – disable page caching (enabled back)
    – changed define(‘WP_CACHE’, true); in wp-config.php to false
    – deactivated WP Optimize (enabled back with original settings)
    – renamed wpo-minify folder to wpo_remove
    The result is the logged-in css fetches new css but for visitors (logged-out) it’s always the same.
    At the moment, I’m out of ideas on how this can be cleared, maybe try contacting the support for WP Optimize.

    Best regards,
    Nikko

    #1293556

    Works fine on every page except the home page. Weird. Thanks for your help

    #1293600

    Hi Dave,

    I agree, sometimes caching produces weird issues.
    The workaround I could think for this is to duplicate the homepage and set the new one as the homepage.

    Best regards,
    Nikko

    #1293635

    That did it. Tks Nikko

    You can close

    #1293637

    Hi Dave,

    We’re happy to hear that :)
    Thanks for using Enfold and have a great day!

    Best regards,
    Nikko

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘sub menu and burger menu issues’ is closed to new replies.