Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #688417

    I just set up my blog page and noticed that the title has a “strong” tag instead of a h1 heading.

    This happens only when I use my child theme, with the parent theme it is ok. It is also ok on your blog demos. In my child theme I just have a style.css and functions.php. No templates have been changed.

    This results in a different styling of the title. Of course I could adjust it with css but I would prefer a clean solution.

    I have attached a copy of my functions.php file and an admin access.

    Thanks for your help


    Hey caudebert,

    Thank you for the credentials the default login url is showing a 404 error we need the login URL for WordPress backend.

    Also the blog page has nothing in it please provide a precise link where we can see the issue.

    Best regards,


    Oh sorry there is a “move login” plugin on this site, you will find the admin url in the private area.
    There are no blog posts for the moment but you can see the issue on title of the blog page :, the word “blog” has a strong tag instead of a h1 tag.

    Let me know if you need more information,



    Thanks for the link, I can’t see any posts on your blog page though so we can’t check the error?



    Hi Rikard,
    as I said above, you can see the error on the title of the page even if there are no posts.
    The word “blog” has a strong tag and not a h1 tag.


    Hello again,
    I have made some additional testing.

    As the issue happens only with the child theme, I have removed the content of my child theme’s functions.php and style.css. The issue is still there.

    So it seems that the tag of the blog page title is not the same when you use a child theme or not.

    Hope this helps.





    That was intentional and it is based on the yoast heading structure for blog page.

    If you want to have an h1 tag there, please add this in the functions.php file:

    add_filter('avf_title_args', 'avf_title_args_mod', 10, 2);
    function avf_title_args_mod($args,$id)
    	$blogpage_id = avia_get_option('blogpage');
    	if(!empty($blogpage_id) && get_post_meta($blogpage_id, 'header', true) != 'no')
    		$args['heading'] = 'h1';
        return $args;



    Hello Ismael,

    Sorry but I don’t catch your answer. If your intention is to follow Yoast’s guidelines, then the theme should place a h1 tag on the title of the blog page and not a “strong” tag.

    Yoast’s guidelines are exactly what I am trying to achieve, it works when using just the parent theme, but not when using a child theme, even an empty one.




    I added the code Ismael posted above into functions.php file of your child theme and it is working fine now. Please review your website.

    Best regards,


    Hi Yigit,

    Yes it works, I had already tested, But I still don’t understand the logic behind this.

    Why have an h1 for all page titles and NOT on the blog page, especially if your intention is to follow Yoast’s SEO guidelines ?

    I have implemented a workaround. In the theme settings I have left “blog page” blank. And then created a normal page with a “blog posts” block in it. Doing this, my blog page has a standard h1 page title with the relevant styling.

    I’m not so happy, but don’t feel like fussing further for that. It’s up to,you to decide whether you wish to improve this or not.

    I love Enfold, one the best themes in my opinion, but I find the blog not the best part of it….


    • This reply was modified 7 years, 8 months ago by caudebert.


    Thank you for your input. Could you please post your concerns about blog and things you would want to improve here –



    Done, please close !

Viewing 12 posts - 1 through 12 (of 12 total)
  • The topic ‘Strong tag instead of h1 for blog title’ is closed to new replies.