Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #263641

    Hi,

    I finished and uploaded the new website to the excisting .nl domain. All is working just fine.
    The website also has a additional .com (sub)domain hosted by the same hosting provider.
    Normally (or at least as I’m used to) if you type in the .com address, you’re redirected to the .nl website.

    But this hosting company does it a bit differently, and will show the site when typing the .com web address. No redirect.
    But for some oddball reason I cannot understand yet, the custom icon font that is used by the social media links in the header top bar, and the “to top’ button icon don’t work on the .com website.

    Any menu link will end up on the .nl domain, and all will work again as expected/tested . The only thing I can come up with is some odd path reference somewhere for the font not to be found….

    Website: http://www.cavador.com > non working icon font. Click on logo or any menu (=redirect to .cavador.nl) gets a working icon font again.
    Other problem is that the .com menu will open a new tab for the .nl domain. Not exactly what I want.

    The client just made new business cards with the .com address, besides the fact the website ran for years on the .nl domain ;-)
    So this has to work properly.

    I also did the whole saving settings and permalinks in WordPress, but so far nothing.

    cheers for any tips,

    rob

    #263857

    Bump.

    I just finished a long session with the hosting provider, and we’re all stumped atm.

    Stranger thing, with Chrome and Opera the icons show up on the .com domain.
    Firefox and IE will not show the icons with the .com domain.
    Oh… the opening in a new tab is only happening on (my) Firefox.

    So can it be code inside the theme that is causing this?? Odd thing is, when inspecting elements/code all HTML/PHP is exactly the same. And on the .nl domain it all works in every browser……

    I hope someone can help me out here, because this is getting annoying ;-)

    rob

    #264517

    Hi!

    Probably you just need to Access-Control-Allow-Origin header – then the fonts should work just fine. See http://davidwalsh.name/cdn-fonts

    Best regards,
    Peter

    #264535

    Wow, nice find!

    I searched all over, but would have NEVER thought of this ;-)
    I’ll have a go and see if this will work.

    Thanks a ton!!

    rob

    • This reply was modified 5 years, 5 months ago by  RobWu.
    #264559

    Edit #1:

    Your tip got me on the right track, and it seems to work for Firefox, but not for IE yet….

    What I did was I added a .htaccess file to the ..\avia-template-builder\assets\fonts\ folder with the following code:
    <FilesMatch “\.(ttf|otf|svg|eot|woff)$”>
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin “*” <–the * can be changed to the .nl domain as well….
    </IfModule>
    </FilesMatch>

    IE is ignoring this.

    Looking into some other options like scripting or PHP header additions.

    rob

    P.S. IE seems to be CORS compliant, but doing something different as FF.

    • This reply was modified 5 years, 5 months ago by  RobWu.
    #264654

    Edit #2:

    After hours of fiddling I gave up for IE.
    It seems the Apache server of the hosting company is blocking certain solutions, so I gave up and requested a ‘hard forward’ to the .nl domain.
    This will solve the problem for now.

    cheers,

    rob

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Strange icon font behavior on .com /.nl website redirect….’ is closed to new replies.