Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1059997

    When I go to the Theme update page inside Enfold I keep on seeing the message:

    Attention: The old Envato API is deprecated and will be shut down soon. In order to be able to use automated theme updates please generate a new valid API token and enter it above. Your themeforest username and your old API key will then be removed from your installation since they are no longer required.

    Even though I have been updating the theme and is now at version 4.5.2.
    I feel a but uneasy about uploading a theme via FTP as I don’t want to find my site broken.

    #1061016

    Hey Martin,

    You can also do the following steps:

    1. Backup your site and put it in maintenance mode
    2. Switch to a default wordpress theme like twentynineteen
    3. Delete the outdated Enfold theme
    4. Upload the latest version of Enfold then set it as the active theme

    Hope this helps.

    Best regards,
    Nikko

    #1064916

    Hi Nikko
    I am really not happy to do something this drastic for something that is in fact a bug in your system. How about you fix the bug and sort it out for your customers.
    This sounds like I am asking for trouble and I can guarantee you something will go wrong.
    Similar thing happened when I used the script to transfer settings to use child theme and that didn’t work either even though the site should have remained the same.

    Best regards
    Martin

    #1065073

    Hi Martin,

    We haven’t had any other users report this so it might be something local on your site, could you post login details to your site in private so that we can have a closer look please? Also, how is this a “bug” in the theme? We have to adapt to the new system which Envato/Themeforest is using.

    Best regards,
    Rikard

    #1065231

    Hi Rikard

    I don’t really care what is the reason for the error but the fact is I am getting this message even though I shouldn’t and that I regularly update both WordPress and the Enfold theme but well done on arguing with one of your customers. Please feel free to pass the case along to someone else in the customer support chain.
    Regards

    • This reply was modified 2 months, 1 week ago by  mcdragon.
    #1065332

    Hi,

    Could you post login details in private so that we can have a look at the problem you are having?

    Best regards,
    Rikard

    #1065630

    attached in private content
    i do not authorise making any changes without getting my explicit consent, please

    #1065840

    Hi,

    Thanks for that, you are seeing that message since you haven’t added a token in the Enter a valid Envato private token field. Please refer to this on how to register the theme and how to generate a token for your installation: https://kriesi.at/documentation/enfold/theme-registration/

    Best regards,
    Rikard

    #1066340

    Probably unlike others I thought it a bit weird I had to register MY theme as I don’t consider to have MY own theme. Its YOUR therme and thought this has to be done by you.
    Anyway, updated to 4.5.3 and now got this message to update again. Has appeared twice already
    screenshot

    #1066743

    Hi mcdragon,

    The new update on Enfold version 4.5.4 includes a fix to this bug: https://kriesi.at/documentation/enfold/changelog/

    - fixed: an issue with updates not being recognized due to a caching bug

    Best regards,
    Nikko

    #1067415

    Yes, just updated Enfold to 4.5.4. Seems to be working ok now.

    • This reply was modified 2 months, 1 week ago by  mcdragon.
    #1067546

    Hi,

    I’m glad this is working for you. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Still seeing "The old Envato API is deprecated…" in Enfold 4.5.2’ is closed to new replies.