Viewing 30 posts - 1 through 30 (of 33 total)
  • Author
    Posts
  • #910029

    The only file that is not being loaded over HTTPS is the styles.css file ?

    Trying to do everything to fix this warning. Please help.

    Please go to link below and “inspect” in your css debuger and you will see the error.

    Thank you!

    Also – every plugin, theme file and wordpress core is UP TO DATE as of today!

    #910124

    Hey eberswine,

    I can’t see any warnings on the page you linked to and the https is green on Chrome, I’m guessing you got it working?

    Best regards,
    Rikard

    #910308

    Must have been cache.. thanks

    #910342

    Hi,

    Let us know if you need further assistance or if we can close this thread.

    Best regards,
    Nikko

    #934849

    Hi,
    I have the same issue as seen in developer mode.

    #935103

    Hi gianmarizzi,

    Your post contains no information at all for us to be able to help you.

    Best regards,
    Rikard

    #935152

    You’re rigt, my apologies.
    The issue happens on the style.css of http://www.geoclima.com and on favicon of http://www.althermo.com which are uploaded from http and not https.

    • This reply was modified 1 month, 3 weeks ago by  gianmarizzi.
    #935218

    Hi gianmarizzi,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #935240

    Sure. You can find both.

    #935607

    Hi,
    Your site seems to be down right now, please check.

    Best regards,
    Mike

    #935623

    I can see it on three different browsers, actually.

    #935980

    Hi,

    I can see it fixed on your one site, the other site stil has the mixed content but if I check on the style.css it’s already in https whether I check it via web inspector (screenshot in private content) or if I check page source.

    Best regards,
    Nikko

    #936356

    So how should I fix it?

    #936924

    Hi,

    Please enable the Appearance > Editor panel. Did you add any modifications in the functions.php file?

    Best regards,
    Ismael

    #937036

    I’ve just added this one:

    // Remove query string from static files
    function remove_cssjs_ver( $src ) {
    if( strpos( $src, '?ver=' ) )
    $src = remove_query_arg( 'ver', $src );
    return $src;
    }
    add_filter( 'style_loader_src', 'remove_cssjs_ver', 10, 2 );
    add_filter( 'script_loader_src', 'remove_cssjs_ver', 10, 2 );
    #937832

    Anyone?

    #937864

    i have only one image on a different site which seems to be loaded from a different site: disegno.jpg from http://www.gmrizzi.it
    but the rest seems to be o.k.

    you got it here : https://www.geoclima.com/wp-content/uploads/2013/05/disegno.jpg but sometimes it tries to load via an old site
    guess you have to look into the layerslider backgrounds

    #938105

    What about the https://www.althermo.com website? It happens a couple of images (e.g. favicon) are loaded from http?
    Can’t understand what I should do to fix it.

    #938117

    Google Chrome says:
    Mixed Content: The page at ‘https://www.geoclima.com/’ was loaded over HTTPS, but requested an insecure stylesheet ‘http://www.geoclima.com/wp-content/themes/enfold/style.css’. This request has been blocked; the content must be served over HTTPS.

    #938129

    i see you are using on that site wp-super cache – did you empty your cache on that – because i havn’t that error message on my end here.

    by the way – on DSGVO is comming soon – a lot of my customers switched to https (TLS) too.

    On all those sites i do control / manage it the normal way – but after switching i use the plugin : search & replace.
    it is a mighty tool to search and replace things in the database.
    so you can have a search for example:
    http://www.geoclima and replace it with
    https://www.geoclima

    by the way – they have a testrun on that to see how many entries are to be replaced.
    (be carefull – a search for http and replace with https is not a good advice)

    #938150

    Hi,

    @gianmarizzi: Please disable the filters in the functions.php file temporarily and then try @guenni007‘s suggestions above.

    @guenni007: Thank you for the info. :)

    Best regards,
    Ismael

    #938226

    http://www.geoclima.com: after disabling the filters in the functions.php and emptying the cache I have green light on Firexfox and mixed content errors (style.css) on Chrome (browser caches are empty)

    http://www.althermo.com: after disabling the filters in the functions.php and emptying the cache I have green light on Chrome and mixed content erros (yellow warning for favicon and logo) on Firefox (browser caches are empty).

    I really can’t understand.

    @guenni007: thanks for suggestion but I don’t want to spoil database.

    #938276

    thats why i first give the advice:

    i see you are using on that site wp-super cache – did you empty your cache on that – because i havn’t that error message on my end here.

    so good that it has been solved without the db method – but if it stayes a problem on chrome this might be the only possibility to get rid of that troubles. ( on former times this had to be done via mysql – that was horrible – but with that plugin you can first save the db as sql file and thant run a test run to see if the database shows some http links)

    #938288

    Odd is I have different messages on Chrome and Firefox.

    geoclima.com gives an issue on style.css
    althermo.com gives issues on favicon and logo

    Btw, in the previous comment I wrote www(dot)geoclima(dot)com and this website showed the http url. How comes?

    #938543

    on althermo.com your favicon and logo are still on http link.
    how did you insert them – via Enfold Theme Options ? Look if there are still entries.
    Or have you inserted favicon and logo via functions.php of your child theme – these enties are often forgotton to change.

    Or
    wp supercache has a (supercache) Go to the Wp-Super Cache Content – regenerate Cache Stats and see if there are super-cached sites.
    if you press here empty cache the super cache will be erased too.
    After that empty cache of the browsers again !

    #938576

    I uploaded them via Enfold Theme Options and as you can see they’re both on https.

    http://i65.tinypic.com/2ustquv.png

    But Firefox and Chrome say they’re both on http.

    • This reply was modified 1 month, 2 weeks ago by  gianmarizzi.
    #938588

    there must be some caching reasons for it.
    maybe it is because of the new “minification” of the assets.
    But please wait till mods here guide you with :

    add_filter('avf_merge_assets', function() {
      return 'none';
    });
    #939009

    I’ve been waiting for days but there is no mods around… :-(

    #939117

    Hi,

    Did you use the Easy HTTPS Redirection plugin before? Please provide the FTP details in the private field so that we can access the .htaccess file.

    Best regards,
    Ismael

    #939254

    I used it but didn’t fix the issue.

    • This reply was modified 1 month, 1 week ago by  Basilis.
Viewing 30 posts - 1 through 30 (of 33 total)

The topic ‘SSL Mixed content for child theme .styles.css file ?’ is closed to new replies.