Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #1056537

    Hi, Enfold ist cool! Macht großen Spaß (danke dafür!)
    Allerdings habe ich momentan ein für mich nicht lösbares Problem mit dem Ansteuern einer Sprungmarke, wobei der Link auf einer Unterseite sitzt und die angesteuerte ID auf meiner Hauptseite. Nach Klick auf den Link und dem Laden der Hauptseite bleibt diese „irgendwo“ stehen, nicht aber wo sie soll. Der Fehler bleibt aber aus, wenn ich den Layer-Slider von der Hauptseite entferne (???)!

    Etwas genauer: meine Hauptseite hat verschiedene Color-Sections mit entsprechend unterschiedlichen IDs, die über das Menü korrekt angesteuert werden. In der Section „Produkte“ gelangt man über Produktfotos auf entsprechende Info-Seiten.
    Wenn man allerdings von dort aus zurück will und auf den Link „zurück zu Produkte“ klickt ( hauptseite/#produkte ) landet man irgendwo auf der Seite, nicht aber an der korrekte Position.

    Nach Neu-Installation von WP und Enfold und dem Abschalten aller Plugins blieb dieses Verhalten unverändert. Erst als ich aus der Seite das LayerSlider-Element rausgeschmissen hatte, funktionierte der Versuch, von der Unterseite aus die richtige Section anzusteuern.
    Natürlich ist es keine Option auf den LayerSlider zu verzichten.
    Könnt Ihr mir helfen? Was mache ich falsch?
    Grüße, Grobi

    Hi enfold-team,
    Enfold is a really great template, which I like very much. Though I have a problem which I can’t solve by myself.
    On my main-page are several color-sections with different IDs and the menue works fine with this. In the section „Produkte“ you can go to some info-pages. On the way back, after clicking on on a link that leads back to „mainpage/#produkte“, you are landing somewhere but not at the right position, not at the wright anchor/id.

    I re-installed wordpress and enfold, I deactivated all plug-ins sadly without success.
    But when I finally deleted the layer slider from the page – which of course is not really an option -, the link suddenly worked correct.

    Can you give me a hint what I did wrong and how I can solve this effect?

    #1058009

    Hey Grobi,
    Sorry for the late reply, but the password seems to not be correct.
    Please check.

    Best regards,
    Mike

    #1058094

    Hi Mike,
    you are right – sorry for that.
    Find the right login credentials in the private content.

    Best regards,
    Grobi

    #1058442

    Hi,

    Thanks for the login, I went to investigate your issue but I got the error:

    Grobi bearbeitet diesen Beitrag bereits. Möchtest du übernehmen?
    Grobi is already working on this post. Do you want to take over?

    I didn’t want to mess you up, is it ok to “take over” also I assume that you have tested deactivating your plugins, but can we also test this too?

    I also see that you are using Enfold v4.4.1, please update to v4.5.2, it would be good to rule out any version errors, Thanks.

    Best regards,
    Mike

    #1058838

    Hi Mike,
    thats a pity, I regret that I boycotted your efforts.

    Yes, I testet the behaviour with deactivated plugins – of course you can take over and you can test it too!

    I just saw, that I got an „normal“ API-Key to update Enfold which is obviously outdated, recently I need a „token key“.
    I just updated it. – and got two new problems immediately:
    – suddenly the fullwith submenue is not sticky anymore, even though I ticked it.
    – at once the two parts of my layer slider animation are now separated by a white line.

    I would be glad, if you could help me!
    Best regards
    Grobi

    #1059002

    Hi,
    I took another look at your page and first I found a jQuery error on your /baep/ in the “Hand” logo at the bottom of the page, the link in the “hand” had a “#” brfore the http like this:

    <a href="#http://your-site.com/#produkte">Produkte</a>

    so keep an eye out for this as I see you have these “hand” logo in many places.
    To solve the links going back to /produkte/ from /baep/ & /spy08/ I edited the likes going to /produkte/
    I added the class needed to use the “Page scroll to id” plugin and added an offset of -100px by simply adding this to the link:

    class="ps2id" data-ps2id-offset="-100"

    like this:

    <a class="ps2id" data-ps2id-offset="-100" href="http://your-site.com/#produkte">Produkte</a>

    clearing the browser cache helps.
    Please look at the two I did for you in the editor “text” mode so you can see the code, then give this a try for your other links. Also feel free to adjust the offset more if you like, I was not sure how high you wanted the page to land.

    For the sticky menu not sticky, please try replacing this “menu.js” at:
    /enfold/config-templatebuilder/avia-shortcodes/menu/menu.js
    see file in Private Content area.

    I don’t see that your layer slider has a white line, what OS & browser are you using, can you include a screenshot?

    Best regards,
    Mike

    #1059585

    Hi Mike,
    thanks a lot for investigating my page.
    The “#-mistake” I did in those back-links is pretty silly, thank you for finding that out. Thanks also for tuning the links with the ps2id-addition.

    But unfortunately, there still seems to be something wrong.
    At first the new menu.js file which I replaced had no noticeable effect, the sticky-submenu ist still not sticky.
    The white line between two layer slider-elements is not there anymore (so I can’t send a screenshot to you :-)

    Another effect I do not understand as well: the control of the header-behaviour does not work in the normal way. So it is not possible to set the header into transparent mode. Despite the setting on the page, this is ignored. Only in the absolute top position the header is shown as wanted. When the page begins to scroll down, the header “forgets” the setting and turns into the predefined colors.

    I really hope that you will solve this problem, because using the sticky submenu and a fullwith color-section with a transparent header is important to me.

    Best regards
    Grobi
    PS: My Browser is Firefox 64.0.2 and I use macOS 10.15.2

    #1059867

    Hi,
    When the header is set to transparent, it is suppose to be transparent when the page begins, and then on scroll have a background color, this way the menu could be seen, please see this example
    But I can see that on your site you want it to be transparent all of the time, which I think we can assist with.
    Do you want this for all of the pages?
    I tried testing some more and see that the sticky menu is still not sticky, I tried disabling your plugins, but that didn’t help, and I created a test page with only color sections, again with no success.
    I would like to replace the menu.js file again, and maybe re-upload the theme again to rule out any damaged files. On my install the sticky menu works correctly so your should too.
    Please include FTP access in the Private Content area.

    Best regards,
    Mike

    #1060093

    Hi Mike,
    thanks for your lines.

    Yes Mike, I want the header transparent for all of the pages.
    I know that I could set headers background color in enfold/general styling/logo area into transparency. But I want to use those defined colors otherwise.
    It would be great, iif you could make the header transparent on all pages.

    In the area for private content you will find the FTP credentials.

    Thanks again and best regards
    Grobi

    #1060331

    Hi,
    Thanks for the ftp access, I renamed your current theme folder “enfold-old” and uploaded “enfold” again, but that didn’t help, your page is not giving any errors, but the js script is not changing the full width sub-menu to “fixed” when it reaches the top. I also tried disabling all of your plugins. So I’m going to ask the rest of the team to take a look to help solve this.
    Thanks for your patience.

    Best regards,
    Mike

    #1061470

    Hi Mike,
    that does not sound too good.
    But because of the bundled expertise of your team, I stay optimistic!
    Of course!
    Totally! :-)

    Best regards,
    Grobi

    #1063124

    Dear Mike,
    It’s been almost a week since you wanted to involve the rest of the team in the annoying behavior of my site. I would be glad, if you would still investigating the problem and maybe have found a solution by now.

    Of course I still hope, that you can solve it, but in the meanwhile I am desperate enough to think about, if it could be useful, when I bulit the site completly again on a new subdomain. What do you think about? Would that make sense?

    And of course, the window of opportunity that I have left will be getting smaller and smaller and the thing will have to work very soon. Is there still a chance, to get help?

    Hopeful, best regards
    Grobi

    #1063885

    Hi,

    I would like to apologize for the late response. I tried to login to the site but I get a 503 ( Service Unavailable ) error. Could you check this with your hosting provider? Did you set a unique login url?

    Best regards,
    Ismael

    #1063991

    Hi Ismael,
    good to hear from you, thanks for taking care of it!

    If I’m honest, I do not know, what you mean. I have just tried to login and had no problems, with the credentials I gave to you as well.
    And yes, the credentials I put in the private content area are uniqe.

    Best regards
    Grobi

    #1064433

    Hi,

    I’m still getting the 503 Service Unavailable error when I try to login to the site. What is the login url? I tried “wp-admin” and “wp-login”, but they both lead to the same error. I’ll ask the rest of the team to check it.

    Best regards,
    Ismael

    #1065405

    Hey Ismael!

    What is the login url? I tried “wp-admin” and “wp-login”, but they both lead to the same error.

    I can not understand your problem, because all variants work for me. It works as well, when I just use “admin” or “login” without “wp-” and the php-ending.

    Dear Mike, Ismael and the rest of the team,
    thank you all for investigating my site.
    Now, after 4 weeks without the solution of my problem concerning the sticky submenu, the transparent header, the really strange behaviour jumping to an anchor from a sub-page or your problems logging in to my site, I’m really starting to panic – especially as I planed to launch the GoLive on February 15th at the latest.

    Can this issue be a result of incompatibility between the new WordPress and Enfold versions?
    Are you still convinced of being able to help me – or would you advise me to take a different path? Maybe without Enfold (which I would really like to prevent)?
    Is there anything else I can do to help you?

    Kind regards
    Grobi

    #1065428

    Hi,
    Sorry for the late reply, Ismael found that the code in the menu.js on line 57 was not allowing the sticky sub-menu when the mobile menu is present, I commented it out and it now works. Please clear your browser cache a couple of times to clear the .js file, and check.
    Theis was the code:

    if( burger_menu.is(":visible") )
    					{
    						this.css({top: 'auto', position: 'absolute'}); fixed = false;
    						return;
    					}

    Thank you for your patience.

    Best regards,
    Mike

    #1065474

    Oh, thats goid news.
    I will check it immediately when I am back at desk!
    Thank you very much for the moment!
    Grobi

    #1065790

    Hi,
    We look forward to your report.

    Best regards,
    Mike

    #1065894

    Hi,
    the sticky sub-menu actually works as it should, thats great! I’m really relieved, thanks!!!

    I made the header transparent and tuned the “scroll to id”-Plugin with an offset of 30 pixels to get my sections full screen.
    Unfortunately, one problem is still present or back: If you go to one of the product pages (portfolio items) and then jump back to main page, the page does not reach the right anchor. It comes about 200 pixels to far below to a stop.
    I tried to improve this with the ps2id-link-principle you gave me:

    a class=”ps2id” data-ps2id-offset=”-100″ href=”…

    This has no effect. It does not matter if I set an offset of 100 pixels or, for example, an offset of -200 pixels, the result remains the same.

    Would you look again here, if you get that solved?
    This strange behavior is not really nice for the future visitors of the website.
    For a hint, I would be very grateful!

    Best regards
    Grobi

    #1065948

    Hi,
    I took a look at your settings for the “scroll to id” plugin, and found that the ” Use element’s custom offset (if it exists) when scrolling from/to different pages.” option was unchecked, most likely from disabling it while testing the other issue.
    For the top two products I adjusted the “back to” link with “-200” and cleared my cache, and they seem to land in the right place now.

    <p style="text-align: right;">Zurück zu <a class="ps2id" href="http://4u.your_site.me/#produkte" data-ps2id-offset="-200">Produkte</a></p>

    I test by assuming that if the transpernt menu bar has the “#produkte” blue background color, then it is in the right section. Is this correct?
    Please clear your browser cache and check.

    Best regards,
    Mike

    #1065981

    Hi Mike, many thanks for your effort!

    I test by assuming that if the transpernt menu bar has the “#produkte” blue background color, then it is in the right section. Is this correct?

    You are right, exactly like that!

    I have the strong feeling that it is not working! Meanwhile I had

    • cleard and deleted caches
    • changed all links in the product portfolios regarding the offset (-200)
    • checked the behaviour with different browsers, 2 different macs, a smart phone and an iPad

    I observe the following: I take a “back to …” link and use it again and again, at least 10 times. Sometimes the landing position is correct, but mostly not. Once so, once so.
    I have pre-buttoned several “back to” links and often clicked one after the other, always with the same result: sometimes it works, sometimes not.
    I do not have any idea why this could be …

    Kind regards
    Grobi

    #1066167

    Hi,
    Odd I checked a few times this morning to ensure it was working.
    So I checked again and the check box was un-checked again?
    2019-02-12-180532
    So I checked it again, then cleared the cache on the homepage, went to #produkte, then /portfolio-item/baep/ then cleared the cache on that page, then I clicked “Zurück zu Produkte”, and it landed correctly on a desktop computer. I then did the same for /portfolio-item/burn/
    I then went back and forth 3 more times on each link without clearing the cache, each time it landed correctly.
    Did you disable the checkbox?
    Please check again.

    Best regards,
    Mike

    #1066554

    Hi Mike,
    I hope you are fine despite this annoying thing here.

    The check box of which you spoke yesterday was this one here:

    I took a look at your settings for the “scroll to id” plugin, and found that the ” Use element’s custom offset (if it exists) when scrolling from/to different pages.” option was unchecked,

    Of course I have NOT changed this setting!

    The Settings I focused on was the values in the offset setting area and it may be that I turned the checkbox „Enable different pages scrolling on all links (even the ones that are not handled by the plugin)“ on and off to see if anything improved. Sorry, when I left this in a wrong state.

    Unfortunately, I still notice the malfunction. I have emptied the cache on the pages and portfolio items, as you have recommended, and just checked my devices again. On two different Macs – with Firefox, Chrome, Safari – the page only sometimes jumps to the right position, then again many attempts in a row not.
    And on the smart phone, the position where the main page comes to a halt is completely off the mark.

    But – I get a positive “feedback” from my iPad (an older device). I’ve gone through the best known procedure at least 25 times (go to product – click “back-to-link”) and each time the main page ends up in the right place.
    On a Windows notebook which I used to test I have only a little offset, the page is about 30, 40 pixels too deep. BUT – in IE, the site at least always ends up in the same position.

    Thank you again for taking care of my problem so much!
    Kind regards
    Grobi

    #1066797

    Hi,
    Thank you, this is a tricky one. But I made another adjustment, Please clear your browser cache and check.
    You can add images via https://postimg.cc/

    Best regards,
    Mike

    #1066888

    Hi Mike, you are really tirelessly! And I would like to finally give you a “mission accomplished”.
    But I cannot.

    On the smart phone it seems to work now, I tried it often.
    On my two computers, using Firefox, I have the same good behaviour, the site lands on the right position. Thats nice – what did you change?

    But, unfortunately, using chrome and safari on the macs I do not have the right landing position, every time I tried that.
    Is it the same, when you check it with chrome?

    Best regards
    Grobi

    #1067241

    Hi,
    Thanks, I’m really trying :)
    So Mac is the only issue now? I use Chrome on Windows for my work here, and it’s working good.
    This might turn a little tricker because adjusting for Mac might throw Windows off, I’ll try. Please include a screenshot of what you are seeing on Mac.

    Best regards,
    Mike

    #1067380

    Hi Mike,
    yes please try it! For this endless story to have an end!

    Here some screenshots. First Chrome 71.0 on “Mac 01”
    And Safari 12.0.2 on “Mac 01” – far away from the goal!
    https://postimg.cc/gallery/ro4wl8mo/

    Exactly the same on the other mac. Firefox seems to work on both guys :-)

    Kind regards
    Grobi
    PS: Mike, for this odd site, I opened another thread that refers to the link styling of the sub menu bar. … so far without any reaction from your colleagues, do you think you could drop by and take a look???? -> https://kriesi.at/support/topic/ (Purchase code hidden if logged out) -with-visited/#post-1066934

    • This reply was modified 16 hours, 1 minute ago by  Grobi. Reason: Corrected the embedding of screenshots
    #1067450
    This reply has been marked as private.
Viewing 29 posts - 1 through 29 (of 29 total)

You must be logged in to reply to this topic.