Viewing 30 posts - 1 through 30 (of 33 total)
  • Author
    Posts
  • #1436099

    I fixed the regular Pages (vs posts) by re-saving, but there are a hundred blog posts that are like this. Here is just one: https://gatehealing.com/how-to-have-a-healthy-relationship/

    What is wrong here and is there a way to fix all posts at the same time?

    Jon

    #1436100

    I don’t know what the heck happened, but I tried going to the published Blog pages tab in the Dashboard and bulk selecting all posts, then did nothing and just hit Update . . . .when I realized no categories were selected I got concerned that this was going to remove all category selections from all posts and I hit Cancel.

    When I rechecked the posts in a different browser again, the problem was fixed on the posts too.

    This was an issue that did not show up if I was logged in to the WP dashboard in the browser I was going to my site in. So I had to goto Chrome to check (I cleared all history and caches every time I checked).

    #1436109

    Hi,

    Thanks for the update. Is the problem you were having before fixed now then?

    Best regards,
    Rikard

    #1436995

    Apologies for not getting back . . .no, it turns out that it is worse now. Now is all pages and all blog posts except my homepage.

    This is a critical problem since I am already trying to deal with ranking issues . . .and actually, I am wondering if this has been an issue for quite some time on various pages, and now on all. It is not seen if you are logged in to wp dashboard and you goto the site in the same browser, so when I have been viewing pages after updates, I have not seen it.

    I am not going to use the step that I stumbled on above to try and fix this until y’all see it yourselves. . . Need to figure out the cause so i can fix it at the root.

    Here’s the other post that I just created (I wasn’t thinking of just coming back here): https://kriesi.at/support/topic/all-subpages-are-just-a-white-page-and-text-blue-links/

    Thanks y’all
    Jon

    #1436999

    First, please let me know whether to continue here (old thread about this issue), or the new one.

    Update: I went in an filtered posts by category. When I selected all Anxiety posts in list of posts, then bulk selected Edit, then just clicked Update, then quickly cancelled it, that seemed to fix the problem. Some of the category pages are messed up, while others are not. Blog posts in the categories I fixed (just anxiety and couples) are fixed as well. All other blog posts, except for those that have a category page that is already working.

    Do I need to temporarily switch to one of the themes that come with WordPress?

    #1437007

    I needed to fix this before it impacted my practice anymore than it already has. So I used the method that I had stumbled on with blog posts and did that for both blog posts and for pages.

    I really need to try and figure out what is causing this to happen. Any help would be appreciated.

    #1437038

    Hi,

    Thanks for the updates. The page you linked to looks fine on my end without being logged in, could you link to a page where we can see the actual problem please? If you have a screenshot highlighing what you are seeing on your end, then that might be helpful too.

    Best regards,
    Rikard

    #1437078

    A page that is currently doing this is: https://gatehealing.com/counseling-austin-tx/parenting-family-counseling/

    I have a screenshot, but I think it is rather complicated to get it to y’all. Let me know if the link above does not show it. I won’t fix it till we can figure this out. My fear is that this issue will spread to my entire site again.

    ***Also, there are 2 threads on this — I created a new one without thinking. Can you and Ismael let me know which one to continue with? I can do both, but it seems like double work for y’all—this is what I wrote yesterday at 9:39pm:***
    Here’s the other post that I just created (I wasn’t thinking of just coming back here): https://kriesi.at/support/topic/all-subpages-are-just-a-white-page-and-text-blue-links/

    Thanks y’all
    Jon

    #1437081

    see private box

    #1437091

    Hi,

    Thanks for that, I’m seeing the same thing on my end. It looks like the browser is blocking resources from cloudflare, see example in private. Are you using a CDN? If so, then please try turning it off to see what happens then.

    Best regards,
    Rikard

    #1437097

    That link just shows a bunch of what looks like gibberish code to me.

    My CDN is CloudFlare. It is connected to WPFC in the CDN tab where it is a setting that they make it very easy to link (FWIW in regards to minificaiton, in the pr process of connecting WPFC to CF to it automatically disables minfications–I think on the CF side … it also disables Rocket Loader, which I know is on the CF side). Should I try disconnecting CF from WPFC? Or just shut-off CF? Or both?

    Thanks, I know this is tedious.

    J

    #1437109

    Well dang. I accidentally fixed it my changing a widget, saving that, then clearing the WPFC caches.

    That might give a little more info that could help diagnose the issue.

    J

    #1437118

    Hi,

    Thanks for the update. The problem page is displaying fine on my end now, so what you did seems to have worked?

    Best regards,
    Rikard

    #1437125

    Well, that’s the problem…towards the beginning of this thread, when I first addressed the problem, I stumbled into “fixing” it by bulk editing/saving all posts and quickly canceling the bulk save. Which did fix it, but it recurred.

    This time, I stumbled into the “fix” again by saving a widget change. I don’t know why this fixed it again. But since it seemed resolved before but came back stronger the second time, I’m not confident that an accidental resolution is going to stick.

    #1437134

    Hi,

    Thanks for the update. We need to see the actual problem in order to help you out further, is it still happening somewhere?

    Best regards,
    Rikard

    #1437181

    Fortunately and unfortunately, no. I’m going to have to go through all the pages each week in Chrome to see if it has recurred.

    The first time, I remember that I was updating some blog post featured images, and adding some images to the body (including uploading and compressing new images in the media library). This most recent time I was also adding new images and compressing them in the media library, then adding sliders to the top of pages, including dropping in the code to get a button in the box under the main caption for the Easy Slider image (I did change some of the ALB layouts as well). The only other thing I can think of was this recent time I added the code y’all provided to enfold child > Editor > Functions.php (the code was to get rid of the curved arrow overlay that shows up on linked arrows).

    I’ll let y’all know if it shows up again. I’ll be continuing to edit and move somethings around.

    #1437219

    Hi,

    Thanks for the update, we’ll keep this thread open for you.

    Best regards,
    Rikard

    #1438778

    It happened again. I’d attach a screenshot if this form would let me.

    I had been getting a Plugin for SMTP downloaded and set up. Then updated the Contact Page with a Contact Form. When I opened a different browser (chrome) that I wasn’t using, the home page was fine, as were other random pages, but the Counseling Services page was a white background with only text, blue hyperlinks, and a slightly deformed logo.

    I used the fix that I stumbled on before: Select All pages > Bulk Action: Edit > Apply > Update, then quickly hit Cancel.

    Am I missing a screenshot uploader?

    #1438811

    It is definitely when I save changes to a page. When I do, then I go to a browser that is not the same as the one I am using to edit, Pages, Blog Categories, and Blog Posts all have random things that are just the white background, hyperlinks, and slightly distorted logo.

    #1438814

    It is fixed for now, but I think I can re-create it . . . not sure. I’ll watch this thread closely tonight and when y’all are ready, I can try to reproduce it, find out what pages/posts/categories are impacted, and then post those here. I don’t want to leave it broken for long as I have ads running and people are going to the site (plus I don’t want Google to see it).

    #1438816

    I think I have identified and specific progression to recreate the issue:
    Editing WP dashboard in FireFox. Testing in Google Chrome.
    1) Edit something in Enfold Child Options (I edited recaptcha….enabled it, saved, then tested it, then it autosaves)
    2) Go to a page and edit/update. I updated the Contact page, specifically editing the Contact Form, and activating Recaptcha v2.
    3) Go to a different browser and go to the home page. For me, it has consistently been the Counseling Services page that has the error, and the Feeling Stressed vs Being Stressed blog post.

    Jon

    #1438884

    Hi,

    Thanks for the update. Please try adding this to functions.php in your child theme:

    /**
     * Filter to skip css file generation.
     * You can add logic to skip for certain pages/posts only.
     * 
     * @since 4.8.6.1
     * @param boolean $create
     * @return boolean					true | false or anything else to skip generation of css file
     */
    function custom_avf_post_css_create_file( $create )
    {
    	return false;
    }
    
    add_filter( 'avf_post_css_create_file', 'custom_avf_post_css_create_file', 10, 1 );

    Also make sure to clear all caches after you have added the code, and toggle the file compression options and option to delete old CSS and JS files under Enfold->Performance as well.

    Best regards,
    Rikard

    #1438886
    This reply has been marked as private.
    #1438901

    Hi,

    Please see private.

    Best regards,
    Rikard

    #1438915

    Thx!

    #1438930

    Even with the code in enfold child functions.php, the issue occurs. Since we are discussing reCaptcha in another thread, and saving things in Enfold Options seems to be part of the problem (though not in isolation), I did this to test the code in functions.php (I had cleared everything after putting in the code):
    1) Went to Google and got my v3 API keys
    2) Entered the keys and Saved
    3) Tested the keys, and it auto-saved
    4) Opened my Contact page, opened the form, changed Security to reCaptcha v3
    5) Saved form changes
    6) Updated the page

    From there, I went to my Chrome browser, made sure to clear all browsing data first then went to my site…homepage was fine. Then clicked Counseling Services from the main menu and the white screen with hyperlinks and a slightly deformed logo appeared. I closed the Chrome browser window, cleared browsing data and closed Chrome.

    Then I went back to my Dashboard in Firefox and cleared all of the caches in the WPFC (from the top menu, there is a drop-down with 2 items to clear).

    Then I retested in Chrome. Now it worked.

    SO, is there a way for this thing to clear all caches automatically after saving Enfold Child Options settings? I’ll ask the WPFC folks if there is a way it can auto-delete caches after each of these changes as well.

    Jon

    #1438977

    Hi,

    Thanks for the update. There’s no functionality in the theme for automatically clearing caches in third party plugins unfortunately, you will have to do that manually unless the plugin developers has a method to offer you.

    Best regards,
    Rikard

    #1439015

    I just checked, and the settings are properly configured to clear all caches, but I’m not sure if that will also delete minified JS/CSS (which is one of the 2 dropdowns when you hover over the WPFC tool on the top toolbar.

    #1439058

    Hi,

    Thanks for the update. Maybe the plugin developers could clear that up for you?

    Best regards,
    Rikard

    #1439115

    I have a message out for them about it not auto deleting as it should, but there is still the question of why this is happening in the first place; yes, their plugin fixes the error, but the error still happens, and it must involve saving something in Enfold Theme Options. But I am going to disable WPFC and see what happens.

    UPDATE: The issue does not happen when I delete WPFC. Which is interesting. I have updated my support thread with them.

    J

Viewing 30 posts - 1 through 30 (of 33 total)
  • You must be logged in to reply to this topic.