Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #776915

    Having an issue with a 404 error message within Google Search Console with regards to the Twitter and LinkedIn links on the Team Member profiles. For testing and troubleshooting purposes, I have tried to use both http:// and https:// versions of the URL provided by LinkedIn and Twitter. Is anyone else having the same issue? Below is a an example of how it appears within the Search Console:

    https://website.com/folder/fred-flintstone/https:/www.linkedin.com/in/fredflintstone

    I have tried to delete the team member block and recreate but still causes same issue. At first, thought it was only LinkedIn, but now also affects twitter. I also should add that the actual links work properly from the team members’ profile block, but just receiving the error within Search Console.

    Thanks

    #776951

    Hi lstoudenmire!

    Can you try re-save the permalinks?
    It seems a bit strange as an issue and never been reported before, but it is wired.

    Best regards,
    Basilis

    #776958

    I thought strange, as well. Will give it a try and see what happens. Thanks for the quick response!

    #777610

    Hi,

    Great, let us know how you get on with it.

    Best regards,
    Rikard

    #816868

    Hi!

    I am having the same issue, but with my own social links. My site is new – less than 30 days old, and in the past week Google has indexed it and come up with a bunch of errors, all centered around URLs with similar syntax to this:

    http://www.mysite.com/places/www.instagram.com/myusername
    http://www.mysite.com/blog/www.facebook.com/myusername

    I am not sure how the full URLs (like above) became embedded into my site to begin with. The links to my social media profiles work fine on the pages so the User Experience should be okay but I don’t want Google to penalize me in search.

    I have changed a few permalinks (i.e. I took the sample posts and edited them to use as my new posts so changed the permalinks to be more descriptive of those posts). Was that a mistake?

    I also did re-save the permalinks and I think I did it correctly, but nothing changed.

    Thank you!

    #817258

    Just to report back. I tried everything suggested and was unable to make the errors go away. Not the ideal situation, but I just did away with the social icons from the team members block.

    #817431

    After looking at Search Console again today, found the 404 errors again for the ones that I though I had fixed. Thought I had fixed the problem by not using the social media links on the team member block but instead on the team members profile page. I now suspect that it is directly related to the actual social media icon. Will try to create a basic text link to see if problem persist.

    Below is the link as it appears in Search Console as an example:

    %%sitefolder%%/%%sitefolder%%/%%sitefolder%%/https:/www.linkedin.com/in/%%USERNAME%%

    “Googlebot couldn’t crawl this URL because it points to a non-existent page. Generally, 404s don’t harm your site’s performance in search, but you can use them to help improve the user experience.

    #817437

    Hi lstoudenmire,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #817438

    Hi wanderglow,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #817479

    Thanks! Just provided it

    #817878

    Hi wanderglow,

    The links are working now. For some reason for Twitter you just need the account name, others – need to specify the protocol.

    Best regards,
    Victoria

    #817879

    Haven’t had the opportunity to create new account for you however, in my case , it wasn’t a function of the icon links working. They always worked. My issue was dealing with the 404 error within Google search console.

    #818204

    Hi lstoudenmire,

    When you looks at the link, you can see that it’s generated wrong. It is the same issue, could you share a team page with me here in private?

    Best regards,
    Victoria

    #818286

    See private content message. Thanks.

    #818300

    Hi,
    This is a strange issue, as you can see google is indexing two combined urls, your site and the linkedin url. I’m not sure why this would be happening but perhaps you could remove the trailing slash from your URLs.
    add this to your .htaccess file below the RewriteEngine On line:

    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)/$ /$1 [L,R=301]

    Or you can look for a plugin.

    Best regards,
    Mike

    #818530

    I am still experiencing this issue too – as Mike has correctly identified….for some reason Google is combining the two URLs though the links work fine on the site itself. Will uploading a site map to Google help this issue? I am not sure what a plugin would do – a plugin to direct Google to go to the actual URL vs combining two for some reason? Thank you!

    #818819

    Hi lstoudenmire,

    We need htpassword credentials as well.

    Best regards,
    Victoria

    #818821

    Hi wanderglow,

    You should regenerate your sitemap. Those we links incorrectly generated from what you put in socials links in theme options and should not be a part of your sitemap.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #833141

    Hello,

    I’m experiencing this problem as well with my social media icons. For example, clicking on my LinkedIn button goes to:

    http://www.brilliantl.com/www.linkedin.com/in/brilliantl

    which yields

    “Not Found

    The requested URL /www.linkedin.com/in/brilliantl was not found on this server.”

    I couldn’t discern from the thread how to solve this problem – any direction?

    Thanks,

    L

    #835337

    Hi BrilliantL,

    Sorry for the late reply. Did you check your social network links under Enfold->Social Profiles? Try to use the full URL there, like so:

    http://linkedin.com/page/

    If that doesn’t work then please open a new thread and include admin login details in private so that we can have a closer look.

    Best regards,
    Rikard

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.