Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #763146

    Hi,
    I am using a single page theme and have created a second page for news articles.
    I have read some other threads on how to do this and I have installed Zen-Menu-Logic.
    This plugin works exactly the way I want it to for the footer menu only but not on my header menu.
    I need this to work for the header menu as well.
    The additional menu is called: In The News
    In this extra menu I use the full URL for each anchor on my single page layout, for example: http://mywebsite.com/#about
    Do you have any suggestions?

    Thank you

    #763261

    Hey orangedragin,
    I took a look at your site and believe you were asking to add your news page to your top menu, so I did this though Menus > Manage Locations. I hope this helps, I don’t know about the third-party plugin Zen-Menu-Logic, or it’s advantages, but maybe you’ll find some tips here: https://wordpress.org/support/plugin/zen-menu-logic

    Best regards,
    Mike

    #763269

    Mike,

    I appreciate your help. I was able to do what you just did before I posted here. What I don’t understand is when the domain name is added to the hashtag anchor the menu links no longer change colors when they are hovered over or selected on the main single page. For that reason I was trying to create a separate menu that only used the format “http://mywebsite.com/#about” on the “In The News” page which currently changes colors when hovered over. Now, on the main single page the About, Video, Testimonies, and Contact start out white (instead of gold). The “In The News” link starts out gold and changes to white when hovered over and selected. That is what I need to happen for the first four links.

    I’m not sure why the separate “In The News” page menu works properly but not the main page.
    Does that make sense? The footer menus acts exactly the way I want them to. I’m not sure what I’m missing.

    http://www.hatmada.us
    Thanks,
    Ryan

    • This reply was modified 8 months, 4 weeks ago by  orangedragin.
    #763312

    Hi,
    OK, I think I got it right now :) First I disabled the Zen-Menu-Logic plugin, then I choose your menu with the full urls, this is needed because if your on the news page “#about” will not take you to home/#about it will look for news/#about. Hope that makes sense. Then I when to Enfold Theme Options > Advanced Styling > and choose Main Menu from “Select an element to customize” and made one for white menu & one for gold hover menu. Hope this helps :)
    postimage

    Best regards,
    Mike

    #763325

    I have been in the general styling section playing with the colors in different tabs but didn’t try anything in the advanced styling. Thank you for going above and beyond and fixing this for me. Obviously, I made this more difficult than it really should have been. Your quick response and help was a huge relief and sincerely appreciated.

    Thank you,
    Ryan

    #763329

    Hi,
    Your welcome and Thank you for using Enfold.

    Best regards,
    Mike

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Single page and extra page – header menu doesn't work with Zen-Menu-Logic’ is closed to new replies.