Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #983830

    Hi,

    – I updated my site from ENFOLD 4.2.3 to 4.4.1.
    – I have not changed anything at all at this site and nothing in my files or CSS styles.
    – I have a lot of own CSS styles in the custom.css file.
    – I do not use a child theme, I work in the parent theme for my own reasons, don’t worry, I do not make automatic theme updates :-)

    But since this update 4.4.1 a lot of my own CSS styles suddenly don’t take effect any more:
    I have to add !important after these styles like for example this:

    .widget_nav_menu li{
    	border: 1px solid #ffffff !important;
    }

    So I have to correct now a lot of my own CSS styles in the custom.css file :-(

    Looking at my source code, the custom.css link is at the end of all other CSS files – but has it then priority?

    View post on imgur.com

    What has happend in this theme update, so that this is not working properly any more?
    I searched the forum concerning this, and found issues concerning “dynamic CSS”, but I haven’t understood this.

    Isn’t there a possibility to keep my CSS styles in the custom.css file as they were before the theme update 4.4.1, without adding !important and searching my whole site, where they don’t take effect?

    Thanks.

    P.S.: my site is not online yet.

    #983872

    Hey Gitte,

    Likely the order in which the css files are called and taking precedence. !important declaration is to simply ensure that it runs regardless of the order in which the css is called.

    Best regards,
    Jordan Shannon

    #984287

    Thanks, but that was not my question.

    Please see my post above:

    – no child theme, I work with the custom.css in ENFOLD’s folder “css”
    – since updating to v4.4.1 lots of my styles in custom.css of ENFOLD (NO CHILD-THEME!) does not take effect, only when I add !important or #top in front of it
    – why? I cannot search my whole site where it works and where not and where I need to put !important in front of it and where not, because it works like a charme with ENFOLD v.4.2.3 and without any changes (!!!!!) in v4.4.1 there are these troubles.

    Can it have somethingto do with the new “performance” thing of compression and merging of CSS?
    Because when I set in the theme settings at “performance” the CSS file merging and compression to “enabled”, then the custom.css of ENFOLD has obviously no longer priority. As soon as I disable this setting, my styles at the custom.css take effect.

    And your solution please for enabling the file compression AND priority of the styles in the custom.css of ENFOLD?
    Sounds for me like a bug, because the custom.css should have priority, because there I add those styles, that should override normal ENFOLD CSS styles with my own – no matter if I enable or disable the file compression & merging in the theme settings.

    #985692

    Hi,

    Sorry for the delayed reply we have asked our team to look deeper into it and see if they can come up with an update :)

    Best regards,
    Basilis

    #986886

    Okay, thanks, let me know please if you have got further informations.

    #987080

    Hi,

    I rechecked the loading sequence – the content enfold/css/custom.css is merged at the end of the compressed file.

    Using the CSS code you provided above works for me without !important in both situations.

    We would like to help you but without having access to the site it is impossible to say what could be the reason why it does not work for you. Might be that e.g. a plugin overwrites it by having a more detailed selector – but this is just a guess.

    Do not forget to clear all server cache and browser cache (several times) after saving changes.

    Best regards,
    Günter

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.