Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1150954

    I have a custom post type (events) which I had to use this filter to get the Advanced Layout Builder to appear –

    add_filter('avf_builder_boxes', 'add_builder_to_posttype');
    function add_builder_to_posttype($metabox)
    	foreach($metabox as &$meta)
    		if($meta['id'] == 'avia_builder' || $meta['id'] == 'layout')
    			$meta['page'][] = 'event';
    	return $metabox;

    When I add a Whitespace widget on an event I get an error on the front end:

    Admin notice for:
    Separator / Whitespace

    This element was disabled in your theme settings. You can activate it here:
    Performance Settings

    In the performance settings, setting ‘Disabling of template builder elements’ to ‘Always load all elements’ fixes the problem. Obviously, I’d prefer not to have it set that way. Is there some other filter I can add to put my event post type into the Whitespace’s good graces? :)


    Hey pippylu,
    Sorry for the late reply, please try this solution

    Best regards,


    Thank you – this worked for me –

    I went to Performance > “Disabling of template builder elements” and switched back to “Load only used elements (recommended)”
    and then in the next section down I set
    “Scan Widgets for Theme Shortcodes” = “Scan widgets”
    and the page no longer errors.


    Thank you for sharing your solution, and thanks for using Enfold.
    We will close this now. For any other questions or issues, feel free to start new threads in the Enfold forum and we will gladly try to help you :)

    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘Separator / Whitespace Broken on Custom Post Type’ is closed to new replies.