Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #744318

    Hello enfold team,

    I launched a new website using the enfold theme a few days ago. This morning, I launched a crawl with screamingfrog SEO Spider to correct some page title and meta description missing/duplicate issues and I notice something strange.

    Screaming frog also crawled the “?s=” version of my pages. That means it crawls url like:

    mydomain.com/achat-bateau-occasion/semi-rigides/
    and also
    mydomain.com/achat-bateau-occasion/semi-rigides/?s=

    There is this duplicate content issue for all of my pages. This is the first time I see that kind of issue using enfold. Is this normal? Even if the “?s=” pages have a rel=”canonical” linking to my normal page, it might be bad for SEO.

    • This topic was modified 3 years, 7 months ago by  dimitrilpc.
    #746133

    Hey dimitrilpc!

    Thank you for using Enfold.

    You can block urls with the search query. This thread might help.

    // https://kriesi.at/support/topic/gwt-problems-indexing-enfold-soft-404-with-search-activated-s/#post-707487

    Regards,
    Ismael

    #746307

    Hi Ismael,

    I added the following lines to my robots.txt file:
    Disallow: /search
    Disallow: /*?s=

    I guess my problem is solved now. Thank you for the help :)

    Best regards,
    Dimitri

    #746770

    Hi Dimitri,

    Glad you got it working, please let us know if you should need any further help on the topic.

    Best regards,
    Rikard

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.