Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #1080228

    On my website I’ve been using the RSS widget to display a couple of feeds within the body of the site. Everything was working perfectly, but I had to move the site to a new server, and this is the only thing that is no longer working. I’ve tried everything I can think of to make the rss widgets work again again. Perhaps someone could help me troubleshoot it.

    The site is … the widget areas are at “The questions podcast” and “Cross Connection Sermons”

    They use to display the 3 most recent posts to the RSS, now they display “An error has occurred, which probably means the feed is down. Try again later.” But I know the feeds are not down.



    Hey debenm,

    Please try our latest updated version.
    We have pushed some updates related to this functionality

    Best regards,



    Thanks for the response. I am currently on the latest version, and it is still showing the issue.




    Sorry for the problems you have.

    Can you create a WP admin account so we can check your backend please?
    You can add the credentials to private content area.

    Best regards,


    Here’s the info



    Enfold 4.5.5

    In file enfold\config-templatebuilder\avia-template-builder\php\shortcode-template.class.php line 343:

    if( ! is_admin() && ! Avia_Builder()->wp_head_done && ( ! ( defined( 'REST_REQUEST' ) && true === REST_REQUEST ) ) )

    Please replace with:

    if( ! is_admin() && ! Avia_Builder()->wp_head_done && ( ! ( defined( 'REST_REQUEST' ) && true === REST_REQUEST ) ) && ! is_feed() && ! is_comment_feed() )

    This should fix the problem with the feeds.

    Best regards,



    Thank you so much for taking the time to work with me on this. I Made the change, but it hasn’t fixed the problem with the feeds.

    Any other thoughts?



    Strange. I added the feeds (see private content below) in my dev environment and the feeds show up.
    Both in sidebar and custom widget areas as you use it.

    Could it be, that your hoster is blocking access somehow ? The RSS widget is core WP.

    Can you try to create a staging site on server with a different IP adress?

    Best regards,


    Yeah I think you are correct that it is something on my server. I just can’t seem to figure out what change I need to make to my server settings.

    Thanks for all your help!


    Hi debenm,

    You need to write to your provider and ask if they are blocking RSS.

    Best regards,


    Thanks Victoria,

    I’m running a virtual server myself. So as far as I can tell I’m not blocking RSS.




    Victoria and Günter,

    I had a friend take a look at the feed problem and he sent me the following…
    In wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php, line 343, it’s checking a lot of different things. Only if all those tests proceed will it show the feed. And this is the one that isn’t getting through for you:

    ! Avia_Builder()->wp_head_done

    I don’t really know what that’s doing. But i seems like they’re internally keeping track of when the wp_head is done loading, and only proceeding if it’s not done yet. For some reason. I did some testing, where I took each thing that line checks, and killed it with die() whenever any of them was the culprit, and this was the one.

    Any thoughts about that? Could it be causing my feed to not work?




    Sorry for the late reply – and thanks for the feedback.

    In I asked you to update enfold\config-templatebuilder\avia-template-builder\php\shortcode-template.class.php line 343 and this added:

    && ! is_feed() && ! is_comment_feed()

    which are core WP functions and check for feeds – and let the program flow continue processing the shortcodes.

    But as I said in

    Using the rss feed on my dev server works as expected – also with a feed to your server.

    Honestly, no idea. Can you try setup a simple staging site on a different server and check ?

    Best regards,

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.