Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #895675

    Each time I try and install Enfold I have issues.

    Again I have tried to install it below, it won’t install via the WP dashboard so I have used ftp.
    I have uploaded the theme folder by folder, it didn’t work. I have then rpeated the upload by the whole theme folder to ensure that any files not uploaded were in place.
    The theme shows in the theme dashboard but when you activate it it doesn’t work – the screen in blank and I lose the dashboard view altogether.
    In order to undo the activation I have to return to the database and put the theme back to the WP default of twentyseventeen and then I can see the dashboard again.
    As this happens every time I try to upload enfold I would like to work with you to find a solution or find out what the missing files may be.
    Below is the login.
    Many thanks


    Hey helban,

    Did you try increasing the memory allocated to PHP on your installation? I would recommend that you have 256mb:

    Best regards,


    Hi Rikard

    Here below is the contents of the wp-includes/default-constant.php file.
    Please advise any limits out lined here that need to be changed, as it appears there is a limit of 256MB on one particular line.
    Thank you

    * Constants for expressing human-readable data sizes in their respective number of bytes.
    * @since 4.4.0
    define( ‘KB_IN_BYTES’, 1024 );
    define( ‘MB_IN_BYTES’, 1024 * KB_IN_BYTES );
    define( ‘GB_IN_BYTES’, 1024 * MB_IN_BYTES );
    define( ‘TB_IN_BYTES’, 1024 * GB_IN_BYTES );

    $current_limit = @ini_get( ‘memory_limit’ );
    $current_limit_int = wp_convert_hr_to_bytes( $current_limit );

    // Define memory limits.
    if ( ! defined( ‘WP_MEMORY_LIMIT’ ) ) {
    if ( false === wp_is_ini_value_changeable( ‘memory_limit’ ) ) {
    define( ‘WP_MEMORY_LIMIT’, $current_limit );
    } elseif ( is_multisite() ) {
    define( ‘WP_MEMORY_LIMIT’, ’64M’ );
    } else {
    define( ‘WP_MEMORY_LIMIT’, ’40M’ );

    if ( ! defined( ‘WP_MAX_MEMORY_LIMIT’ ) ) {
    if ( false === wp_is_ini_value_changeable( ‘memory_limit’ ) ) {
    define( ‘WP_MAX_MEMORY_LIMIT’, $current_limit );
    } elseif ( -1 === $current_limit_int || $current_limit_int > 268435456 /* = 256M */ ) {
    define( ‘WP_MAX_MEMORY_LIMIT’, $current_limit );
    } else {
    define( ‘WP_MAX_MEMORY_LIMIT’, ‘256M’ );

    // Set memory limits.
    $wp_limit_int = wp_convert_hr_to_bytes( WP_MEMORY_LIMIT );
    if ( -1 !== $current_limit_int && ( -1 === $wp_limit_int || $wp_limit_int > $current_limit_int ) ) {
    @ini_set( ‘memory_limit’, WP_MEMORY_LIMIT );

    if ( ! isset($blog_id) )
    $blog_id = 1;

    if ( !defined(‘WP_CONTENT_DIR’) )
    define( ‘WP_CONTENT_DIR’, ABSPATH . ‘wp-content’ ); // no trailing slash, full paths only – WP_CONTENT_URL is defined further down

    // Add define(‘WP_DEBUG’, true); to wp-config.php to enable display of notices during development.
    if ( !defined(‘WP_DEBUG’) )
    define( ‘WP_DEBUG’, false );

    // Add define(‘WP_DEBUG_DISPLAY’, null); to wp-config.php use the globally configured setting for
    // display_errors and not force errors to be displayed. Use false to force display_errors off.
    if ( !defined(‘WP_DEBUG_DISPLAY’) )
    define( ‘WP_DEBUG_DISPLAY’, true );

    // Add define(‘WP_DEBUG_LOG’, true); to enable error logging to wp-content/debug.log.
    if ( !defined(‘WP_DEBUG_LOG’) )
    define(‘WP_DEBUG_LOG’, false);

    if ( !defined(‘WP_CACHE’) )
    define(‘WP_CACHE’, false);


    HI Kriesi
    I have made a new php.ini file with the memory limit at 256M so please disregard the message above.
    Please note however, this hasn’t healed the issue.
    I still can’t install Enfold.
    Just to remind you I have used ftp and done it several times to ensure all files are written across but it still doesn’t work when I activate the them in the WP theme dashboard
    Please could you take a look. Login below.
    Many thanks



    Thanks for the feedback, though your server is throwing a 500 internal server error when I try to log in. Not sure why that is?

    Best regards,


    I think I have put this right. The enfold theme was still showing in the database so I have changed it back to twentyseventeen in the database files. This should ensure you can now login.
    This is now urgent as it has taken me over a week to get to this point where it is still not functioning.
    Many thanks


    Hi Helen,

    Thanks for that, I’m able to log in now. Are we allowed to switch to Enfold to check the problem?

    Best regards,


    Yes please go ahead. Help urgently needed.
    If you need me to make amends to database again I am here.
    Many thanks


    Hi Helen,

    Thanks for that, I get a 500 internal server error when activating Enfold. That is a very general error message and it’s more or less impossible for me to say what is going wrong. Could you check the server logs for any clues? If you don’t have access to them then your hosting provider should be able to send them to you.

    Best regards,


    Hi Kriesi

    I have now installed and uninstalled this them half a dozen times, including deleting the hosting and starting again.
    I have increased the php memory to the max 512M. I have ensured that the php version is 7 (although previously tried on others).
    I have done a manual install via ftp.
    It still doesnt work.
    My provider can’t find any errors, we have however found lots written about on the web with Enfold installation issues and that it is very tricky to get right. I have used this theme before and had similar issues to get it started.
    I am now letting a client down hugely and so would welcome your URGENT help please – if not I will have to use a different theme.
    In order to do this I am including below the WP dashboard access and the ftp.
    If you just switch from Twentyseventeen to Enfold it doesn’t work and I have to take the enfold theme out of the databse.
    Please could you look at the ftp and ensure all files are right.



    Thanks for the feedback, though if this was a general problem with the theme then everyone would have this problem. That is not the case, so it must be something local to your server. A 500 internal server error doesn’t say anything at all unfortunately, just that something went wrong. We would have to look at error logs to be able to see if they could provide any clues. Could you post error logs here or in an external document so that we can have a closer look please?

    Do you have any other hosting provider that you can try out? Are you getting the same error on local install on your own machine? Also, when you have had problems like this before, what exactly did you do to resolve them?

    Best regards,

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.