Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1055363

    Hi
    I installed the Enfold Contact Form into the Contact Us Page for – https://towermotors.net.au/contact-us
    And I need to limit the spam (already tried the Enfold Contact Form anti spam)

    I found the old topic – https://kriesi.at/support/topic/starting-to-receive-spam-enquiries-from-contact-form-on-website/#post-817676

    1/ And I set up the Google reCAPTCHA Site Key and Secret Key
    2/ Embed the code as show in #post-817676 into functions.php (accessed at Appearance > Editor > Child Theme )
    3/ I replaced var publickey = ‘YOUR PUBLIC API KEY’;
    4/ With var publickey = ‘6Lf7w4oUAAAAANpj5uR2YTj8k_hGPcMDFSdygu3y’;

    I left the rest of the script and saved the function.php in the Admin > Appearance > Editor
    I did NOT use the Secret Key!

    However it won’t work!

    I would appreciate someone’s help.

    Cheers Dave

    #1056233

    Hey Dave,

    Here is a thread for you to consider

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1057155

    Firstly I tired to add site & secret keys to Enfold Child Editor function.php. That didn’t show a button at end of the contact form.

    Then I added loaded Enfold Recaptcha Plugin and added site & secret keys to Enfold Child Theme Options.

    When I load my page – https://towermotors.net.au/contact-us/
    and I get the message – ERROR for site owner: Invalid key type and no submit button

    Need help ASAP!
    Nicky Cane

    #1057570

    Hi,
    I took a look at your site and found that you had the Recaptcha function in your functions.php, this is not needed when using the plugin. I removed it for you.
    I believe your error is due to using the wrong reCAPTCHA key, above you state that you are using v3, but the plugin is for v2
    Please create a new key.
    2019-01-22-222236

    Best regards,
    Mike

    #1057662

    Thanks for that.
    I did what you told me and now I get a Google Captcha show up properly. However, the submit button doesn’t show when Google Captcha is checked.
    See Here: https://towermotors.net.au/contact-us/

    Help!
    Please and thank you
    Nicky Cane

    #1057710

    Hi,
    I see that you are getting the error:

    Failed to load resource: the server responded with a status of 404 ()
    https://lh3.googleusercontent.com/a-/s48-c/AAuE7mC9FnMeFkj8hLf6v5P84ynEnq4ZD_X-7zHOOoPO

    which leads to:

    success error

    I see that you are using Enfold v4.0.7 please update.
    I also see that you are missing the PHP “mbregex” module & PHP “mbstring” extension, please ask your webhost to enable:
    (while you are at it, also ask for PHP ZipArchive extension)
    2019-01-23-064200
    If this doesn’t correct the 404’s to googleusercontent, try disabling your plugins to see if one of them is blocking it, perhaps a firewall?

    Best regards,
    Mike

    #1247577
    This reply has been marked as private.
    #1247832

    Hi,
    Thank you for sharing your solution, glad this is working for you, we will submit to the dev team for review. As this thread is over a year old now and not relevant to the current builds, we will close this thread now. Thank you for using Enfold.

    Best regards,
    Mike

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘reCAPTCHA and Enfold Contact Form’ is closed to new replies.