Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1395205

    Hello,
    I have been using reCaptcha for some time and have uploaded the keys for v2 and v3. both are validating just fine. However, when I enable it the following error arrives:

    This contact form is deactivated because you refused to accept Google reCaptcha service which is necessary to validate any messages sent by the form.

    Currently, the reCaptcha is disabled so our contract form works properly.

    Please advise.
    Cheers!

    #1395320

    Hey djsmbd,

    Thank you for the inquiry.

    Does it work correctly after accepting the privacy cookies? If you want to enable the feature without requiring the user to accept the privacy cookies, set the Enfold > Privacy & Cookies > Cookie Handling > Default Cookie Behaviour to the first or second option.

    Best regards,
    Ismael

    #1395400

    Hi Ismael,

    It does not work after accepting cookies. The following error still exists:
    This contact form is deactivated because you refused to accept Google reCaptcha service which is necessary to validate any messages sent by the form.

    #1395527

    Hi,

    Thank you for the update.

    We may need to access the dashboard and check the settings in order to debug the issue further. Please provide the login details in the private field. For the meantime, please try to deactivate the plugins temporarily and check if the issue persists.

    Best regards,
    Ismael

    #1395683

    Sent info in private.
    Google API Keys are created and tested working.

    Here is the error message on the contact page after enabling Google reCaptch v2.

    This contact form is deactivated because you refused to accept Google reCaptcha service which is necessary to validate any messages sent by the form.

    #1395854

    Hi,
    Thanks for the login I found the you didn’t have Privacy and Cookies ▸ Advanced Options ▸ Auto Reload Page enabled, I enabled it for you and now the contact form works when the cookies are accepted.
    Enfold_Support_258.jpeg
    Enfold_Support_260.jpeg
    I set your contact form back to number captcha like you had it, please clear your browser cache and check.

    Best regards,
    Mike

    #1395934

    Hi Mike,

    We enable the reCaptcha and we are still getting the error even after clearing cookies and browsing data.

    Here is the error

    This contact form is deactivated because you refused to accept Google reCaptcha service which is necessary to validate any messages sent by the form.

    The accept cookies notification does not appear. We are using Chrome.

    #1395958

    Hi,
    That is odd, because the screenshots above are from Chrome, I just tested again with Chrome, Firefox, & Edge in Windows and the cookie bar showed on all of them and accepting the cookies reloaded the page and removed the message and showed the reCaptcha, I tested both v2 & v3.
    If you are not seeing the cookie bar then the cookie has already been set in your browser, I tested incognito mode, if you are using Safari it can be hard to clear the cache, often you need to also clear the history to fully purge the cache, following these steps for Safari and note Step 4 where you will Clear the History.
    Or try incognito mode, are you on a Mac?

    Best regards,
    Mike

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.