Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #779978

    Hi there,

    I’m using a masonry blog and set it to display random but it doesn’t appear to be random. Should it show the results in random on each load?
    Thank you

    #780323

    Hey 3mil-pedro,

    Could you post a link to the page in question so that we can take a closer look please?

    Best regards,
    Rikard

    #780377

    Hi Rikard,
    Yes sure, no problem.

    #780795

    Hi,

    I can confirm it doesn’t seem to be working, please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    Login credentials include:

    • The URL to the login screen.
    • A valid username (with full administration capabilities).
    • As well as a password for that username.
    • permission to deactivate plugins if necessary.

    Best regards,
    Nikko

    #781142

    Hi Nikko,
    The details are below, also you can deactivate plugins in required.

    #782203

    Hi guys,

    Any suggestions on this?

    Thank you

    #783312

    Hi,

    Sorry for the late response, I have checked your site and it seems it doesn’t change even if are not using random. Can you update Enfold to latest version (4.0.5) currently you are using 3.8.4. You can refer to this post for more information: http://kriesi.at/archives/the-complete-guide-to-updating-enfold
    Also don’t forget to backup first. Let us know if this helps.

    Best regards,
    Nikko

    #784368

    Hi Nikko,

    Thank you for the advice, We’ve updated to the latest version but the order is still having no affect.
    Thank you

    #785487

    Hi,

    I also find it confusing since it doesn’t show any errors also but I could not reproduce the same issue on my end. Can you try to deactivate all plugins and check if it fixes the issue, if yes, try to activate the plugins one by one to know what plugin is causing it.

    Best regards,
    Nikko

    #798881

    Same issue here. I’ve deactivated ALL plugins, emptied server and browser cache, reset permissions across the site. Still the random sort order does not work. It worked prior to the last Enfold update though ;-)

    #799258

    Hi,

    Are you using Enfold 4.0.7?

    Best regards,
    Nikko

    #799557

    Yes:
    “Theme Updates
    No Updates available. You are running the latest version! (4.0.7)”

    I’ve also applied the follow code block and css as suggested here: https://kriesi.at/support/topic/1-column-masonry/
    This all worked until 4.0.7.
    Site details & SFTP ScreenPrint below in private for use on top right layout of the home page.

    • This reply was modified 6 years, 9 months ago by welswebmaster. Reason: additional info
    #800092

    Hi,

    I used all your page’s content and used it on my end, but random works fine on my end. So something must cause it especially on your end. Are you using any caching? if yes deactivate it and ask your host if they are using caching on your server. Try to deactivate all plugin and remove any customizations you’ve done so far (child theme, custom code, etc.).

    Also there might be some corrupted files, so please delete all theme files completely via FTP, before installing a fresh copy from your themeforest account. Here is a short tutorial on how to install the theme via FTP, in case you are not sure how that works:

    Best regards,
    Andy

    #804109

    Unfavorable results still = random sort order still not working.
    You asked me to…

    • I’ve pushed the production site to staging.
    • All plugins have been deactivated.
    • FTP installed latest theme (4.0.7) version.

    New staging site credentials & screenshots (see private)

    #804396

    Hi,

    The wp-admin login does work but ftp/sftp doesn’t seem to work, I tried it using filezilla.

    Best regards,
    Nikko

    #804541

    Hi Nikko – I just tried the SFTP creds and they worked.

    Status:      	Connecting to 104.196.47.138:2222...
    Status:      	Connected to 104.196.47.138
    Status:      	Retrieving directory listing...
    Status:      	Listing directory /
    Status:      	Directory listing of "/" successful

    Make sure you have the port set to 2222. I’ve pasted them in the private content box below for you to try again.

    #805480

    Hi,

    It’s working now, can you also disable the caching plugin (flush out cache first)? so we can isolate the issue without having the cache causing any issues.

    Best regards,
    Nikko

    #805567

    Nikko –

    • Per WP Engine, the staging sites do NOT have caching turned on. https://wpengine.com/support/staging/
      There is no server side caching in place on staging sites, so ensure anything that could conflict with the cache is tested Live as well
    • See Private Content below for the two pages that Masonry Random Sort has been configured for your troubleshooting needs:
    #807353

    Hi,

    It’s a settings in the server. Please refer to this link.

    // https://wpexplorer-themes.com/total/docs/random-order-wpengine/

    Related thread: https://kriesi.at/support/topic/random-post-sorting-not-working/#post-712722

    Best regards,
    Ismael

    #807443

    Ismael,
    Brilliant! Thank you! Wish you would have been the rep from the start since this turned out to be a really quick fix!

    WP ENGINE CUSTOMERS: If your Masonry Random Sort setting is not working…

    Recap of Solution: If your web site is hosted by WPEngine, change the ALLOW ORDER BY RAND() to “Enabled” on your site’s Dashboard > WP Engine > General Settings tab (scroll half way down).

    #807746

    Hi,
    Great to hear it’s solved, I for one will be saving this solution in my bag of tricks :)

    Best regards,
    Mike

Viewing 21 posts - 1 through 21 (of 21 total)
  • You must be logged in to reply to this topic.