Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
  • #662365

    I use W3 CDN cloudfront, somehow the quick CSS doesn’t works, but when I disable the plugin it works.
    I have emptied all cache.. purge.. nothing works..
    Please help..


    Hey dewasurya,

    thats default behavior with a plugin like cloudfront. You need to disable it to be able to see your changes.

    Best regards,


    Hey Andy,

    Thanks.. The changes is not just for test or playing around. We need to apply it formally.
    So there is nothing we can do at all to apply the changes in “quick css”?? The website is very slow without CDN, then to make our website faster we need to sacrifice the ability to edit the css? that sounds make sense?



    Quick CSS is stored in a .css file in /wp-content/uploads/dynamic_avia/, just make sure that folder is getting sync (or upload it manually) in the CDN.

    Best regards,


    Hi Josue,

    Thank you for your reply. Yes it sync, but it doesn’t appear live or even i wait for 24 hours.
    But then we disabled it and re-enabled it after some times then it works..
    So that is the way we solve the issue, even manually but at least we have something.. Hope this help others who need it.

    Best regards,



    Can you post a link to the dynamic stylesheet in the CDN?

    Best regards,


    Ok It’s on private content..



    Try adding this at the very end of your theme / child theme functions.php file:

    function change_dynamiccss() {
       wp_dequeue_style( 'avia-dynamic' );
       wp_enqueue_style( 'avia-cdn-dynamic', 'https://d3a83k1p4ldgk8.cloudfront.net/wp-content/uploads/dynamic_avia/villa_bugis.css', array(), '2', 'all' );
    add_action( 'wp_enqueue_scripts', 'change_dynamiccss', 100 );

    That will dequeue the default dynamic stylesheet and include the CDN one (you’ll have to change it if the CDN url changes).



    Hi Josue,

    Thank you.. Just saw your email as it came to my spam box.
    I have put it on the functions.php but unfortunately it seems not working..

    The cdn address changed to http://cdn.villabugis.com. I have changed that too, but still not working..



    Please use the CDN address based on the characters and let us know if it works like that.
    It might be an issue with the mapping you are doing.

    Thanks a lot

    Best regards,


    Hi Basilis,

    Thank you. But it looks the same.. If you like to check please login to our website.



    I checked your site and the dynamic stylesheet is being included as expected:

     	<link rel='stylesheet' id='avia-cdn-dynamic-css'  href='https://d3a83k1p4ldgk8.cloudfront.net/wp-content/uploads/dynamic_avia/villa_bugis.css?ver=2' type='text/css' media='all' />

    Best regards,


    Hi Josue,

    Correct, but the CSS change is not applied, it seems that the file in CDN is not synced?



    If that’s the case that’s something you’d need to sort on the plugin or cloudfront panel (sync local dynamic CSS with CDN one).

    Best regards,


    Hi.. Sorry to disturb again.

    I have excluded custom css to be used in cdn.
    All works well, but from the last update, all changes in quick css are not working again.
    I have disabled the W3totalcache, but still no change.. Could you please help?



    Could you try updating the theme to the latest version (4.0.2) to see if that helps please? http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,


    Hi Rikard,

    Thank you for your reply.
    I have updated the theme.
    Very strange that the css update only works for certain pages. Not all page.
    We have all page with the same structure css class or id.
    Please see this as example:

    this page has black background transparent on the sliding testimonials.
    But this page http://villabugis.com/our-villas/villa-nakula-1-bedroom not..
    I don’t understand what is different with css file loaded on both page. the source shows the same..



    Sorry My fault, i took the wrong css.. It works now..
    But to see the result I alwasy have to clear my browser cache which is not happen before..
    Usually I just purge my cache on cdn then O’ss see the update on the browser, but now I have to do both cdn and browser cache



    Glad it’s working now. Whenever you make css changes please deactivate caching plugin and CDN that way it will be easy for you to preview changes in the browser.

    Best regards,

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.