Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #26672

    I created a page where the permalink ends with the name of the page (this is selected in “Permalinks”). It is written in small caps (…/rhetorik/).

    When I then go to this page it won’t be found.

    When I change the first letter of the URL manually into upper case it works (…/Rhetorik/ instead of …/rhetorik/)

    Allt he links run to the version with the lower case version

    Daughter pages also use the lc-version (…/rhetorik/vortrag) – here every thing works correctly

    I already deleted the page and created a new one with the same result. Same problem with other pages.

    When I add a link to the page (e. g. ../vortrag/) it doesn’t find the page, because it obviously searches for …/Rhetorik/vortrag instead of the correct version …/rhetorik/vortrag/


    Hi mmoesslang,

    I’ve never run across something like that but you can try the troubleshooting tips in the codex for permalinks here: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems




    Hi Devin,

    That didn’t help, sorry. I asked a friend who is also using Enfold and he had the same problem on a different site. He is using a lot of other themes, too and had never this problem before with those themes. Only with enfold. So it must be an enfold thing. But it doesn’t always happen what doesn’t make it easy to find a logic behind that.

    Some of my sides work with the lower case in the URL, others not. The links (e. g. in menu) are generated with small caps but some mother-pages can only be reached with the first letter in upper case.

    htaccess is automatically made like Permalink should and is writeable with 644.

    One detail that might cause the problem: in the preferences of Permalink is selected that the links are generated with the post’s name (Beitragsname). And this is how the example looks like: http://businesspraesentation.de/Beispielbeitrag/ (with an upper case B). This might be a translation mistake when translated into German because in German language all nouns are written with the first letter as upper case. I am not experienced enough to know what would happen if I select another option and whether the problem would be solved. What do you think?

    Manche Mutterseiten-Links funktionieren nicht. Erst wenn der erste Buchstabe großgeschrieben wird funktioniert er. Beispiel: /koerpersprache/ funktioniert nur als /Koerpersprache/ obwohl dies genauso wie die anderen Seiten angelegt wurden (/praesentation/). Htaccess ist nach Permalink vorgaben angelegt und mit 644 beschreibbar.




    I can’t reproduce this bug on my test servers. Please create me a wordpress admin account and send me the login data and more details (links to pages which work and link to pages which don’t work) to: (Email address hidden if logged out) – I’ll look into it.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘problems with upper case in URLs’ is closed to new replies.