Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
  • #898612

    I just installed the latest version of Enfold from themeforest and it broke my installation. From my Apache logs:

    [Wed Jan 17 10:36:03 2018] [error] [client] PHP Fatal error: Can't use function return value in write context in /www/zest/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-parser.class.php on line 2556

    This might be why Enfold sent out an update notification but the theme itself doesn’t show an update from within WordPress. I wouldn’t recommend others upgrade manually just yet unless they’re prepared to restore the theme files from a backup.


    Thank you sir. This is typical of Kriesi nowadays.


    Yikes glad I didn’t start any ftping. Hate to say it but lots of themes are having issues these days!! It’s the same thing with others I use. PROBLEMS and I fear it will get worse once Gutenberg hits the screen!


    Interesting. No issues with my updates via FTP. I do not advise ever updating ANY theme via the dashboard.

    Gutenberg has nothing to do with themes.


    Updated test website to Enfold 4.2.1 and see no issues. But I’ll wait a few days due to this thread, and since Kriesi mentions the following:

    2018 Jan 18th – Version 4.2.1
    Start of a series of smaller updates, each one with some extensive changes to the php structure which we want to monitor a few days before releasing further updates.


    My problem is very similar to that reported by jpollackphoto

    … wp-content / themes / enfold / config-templatebuilder / avia-template-builder / php / shortcode-parser.class.php on line 2556 help me urgently.


    @jpollackphoto I bet your PHP version is very old and unsupported these days. The error you get is typically pre PHP 5.6. WordPress recommends PHP 7.2. You should at least have 7.0 installed.


    Why hasn’t any of the team addressed this? This is a MAJOR issue. Several sites are down now because of this issue.





    To look into the issue, we need to FTP and WP admin logins, but please create new thread. If you post logins credentials here in private content field, they will be visible to creator of this thread as well.

    I cannot reproduce the issue on my local installation however i do too think issue is PHP version related. If your case is urgent, please try upgrading PHP version if it is older than 7.0.

    Best regards,


    @kahil It is simply not the duty of a theme developer to address the laziness of users. You are using an outdated version of PHP that has been retired a long time ago. Just log in to your providers customer control panel and switch to at least PHP 7.0. This will address the issue in this thread.


    Well that was a rude response. Couldn’t craft a response that was mature and considers the many scenarios and setups other users may have? You do realize that some novice users might not know how to update it or even be able to discern that the PHP version is the issue? That every host has a different process? That some hosts don’t keep their phone versions updated? That some people have automatic updates turned on and may bot know this will kill their site and affect their businesses? No need to degrade others.

    When updating a plug-in or theme will literally kill the website unless a specific change is made beforehand, it really helps to give uers a heads up. Other developers seem able to include such update notices. I was able to fix that for my clients by updating the php version. The devs knew they were using a new version of the shortcode handler which requires the use of a newer version of PHP. I find it hard to believe no one there thought there wouldn’t be any issues. If they aren’t doing tests on different setups and aren’t putting in fail-safes, then they need to tighten the screws. Notices of potential update issues is literally the least any established dev can do.


    @kahil my answer wasn’t meant to be rude. Sorry if I offended you. But as I can read from your answer my hint solved your issue. You are welcome.


    You didn’t help, I fixed it on my own. Don’t be so quick to pat yourself on your back.


    @yigit – That is clearly the problem, but the underlying issue is that there was no warning that a new feature was added that requires 7.0 or higher for PHP. Yes, it’s a good idea to keep the PHP version updated, but it’s safe to say that many wouldn’t know how to do that and some hosts don’t have a way for users to manually do so. Combine that with the fact that many hosts for WordPress sites have automatic updates for WP, plugins and themes…this can and has shown itself to be an unexpected issue…a major one at that since it is taking down sites completely.

    The devs knowing that they were updating something in the theme which specifically requires php 7+, they should have included either a check on that which would have loaded a legacy failsafe, or at least included a warning the same way other plugin/theme devs do.

    If the devs can, they should halt the update rollout and make the previous version available for download in some manner…themeforest if they allow a rollback. Then take the time to fully test out this version. Like it or not, Enfold did work on older versions of PHP, so it isn’t unreasonable to assume some users still have an older setup.


    @kahil I dont pat on my back. I just help people to solve the issue and many are thank full. You just yell ‘MATURE issue’ instead of sharing your knowledge. Have a nice day.


    …and queue the ego trip. If this wasn’t an example of a “Bye Felicia” moment, I don’t know what is. Try giving advice without first demeaning people.


    For those still suffering from this issue… If your host doesn’t allow you to update the PHP version, contact them asking them to do so. If your host, for whatever odd reason, doesn’t run a newer version of PHP, ask them to roll back the site to a backup. If you aren’t running backups, then try to find the prior version and re-install Enfold.

    Until the devs add a warning like we see in other themes/plugins, or until they rollout a fix which will not kill your site…those are your only options sadly.


    Ditto on the dev responsibility for disclosure. Experienced users mostly will be running php7 or higher just for the security and performance factors alone. But there are times where we cannot for various reasons. It IS NOT the purchasers job to GUESS what will work and what will not work. Remember devs, if we don’t buy or extend support poof goes your paychecks. We pay the bills – PLAIN AND SIMPLE business.

    How about you disclose the UPCOMING update in the forums along with some pertinent information BEFORE releasing it for Themeforest distribution? This may help some folks out who otherwise may have issues.



    We are really sorry for the inconvenience. This surely was a mistake however the reason behind this mistake is, we were not able to reproduce the issue. Until now i was able to find one FTP and WP logins of a website that had this issue and we were able to fix it.

    Could you please try replacing public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-parser.class.php file with this one – via FTP and check if that helps?

    This may not be the final solution but we will definitely take more precautions to avoid similar issues from happening again in future. If this does not work for you, please start a new thread and attach FTP and WP admin logins so we can take a deeper look.

    Also, let us please stay kind to one and other :)

    Best regards,


    Yigit – I just had the same issue on several installs and your fix worked perfectly.

    Thank you




    @freshwebsitesla Thanks for the feedback! Glad it worked :)

    Best regards,


    Would it be safe to assume that this fix was NOT included in todays’s 4.2.2 update?



    What is on changelog should be fix – else it will be pushed through this week.
    There is an update with 15 new fixes coming out from our dev team.

    Thank you very much

    Best regards,

Viewing 24 posts - 1 through 24 (of 24 total)

The topic ‘Problem with latest version’ is closed to new replies.