Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #174742


    I think I probably just found a new bug in v2.3.

    We have both English and Chinese running on the site, English being the default language. To get to the Chinese version, the permalinks setting requires “?lang=zh-hans” added to the end of a URL. By accident, I tried to access a Chinese page with “?lang=zh” in the tail. Instead of showing me the 404 page, I got to the English version of the page. That’s not it, the logo also got changed to the default Enfold logo and the color of the theme changed to green instead of deep blue which is the color our site uses. I tried to go to another page with “?lang=zh”, sometimes I got an error page but the logo is always the default enfold theme logo and color is always green.

    Can you check if this indeed is a bug or a configuration issue from my side? How can I fix this?

    Thank you,


    Hello yukanl!

    Have you tried changing the Language URL Format? Use the first option “Different languages in directories”.




    I can’t use the “different languages in different directories” option.

    And this problem still exists in Enfold 2.5.

    How can we fix this?




    Afaik this is not a bug but the standard WPML behavior. Just for fun I tested it on the WPML website and if you visit: the website language is set to Chinese and then go to: – suddenly they also redirect you to the English blog. I think this issue is not theme related but that’s how WPML handles the “wrong language parameter” at the moment. You can try to report it as”bug” feature request to the WPML support team.


Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘probably a new bug’ is closed to new replies.