Tagged: , ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #634829

    We are using the Enfold theme and in our Google Webmaster Tools account, Google has crawled and thrown back 403 crawl errors on the following directory:


    I know that it’s a good thing to allow Google to crawl css, js, images, etc files inside the framework folders but I think we don’t want to allow them to crawl php files since we shut that down at the server level. Is this a matter of disallowing that php directory inside our robots.txt file? However there are additional css and js images inside that php directory.

    I also notice that the following was also crawled by Google and is throwing back a 403 crawl error:


    And it throws this fatal error in the browser:

    Fatal error: Call to undefined function do_action() in /home/…/public_html/wp-content/themes/enfold/framework/avia_framework.php on line 28

    What is the best practice on not allowing Google to crawl these files and for that matter any website visitors too?

    Is this something we can also close off from our .htaccess file?

    • This topic was modified 8 years ago by leangroup.

    Hey Mike,

    Thank you for using Enfold.

    You should allow the framework > php folder but ignore or disallow other folders inside via robot.txt. It is true that the directory contains js and css files but they are not use for the frontend rendering of the site. Only allow scripts and stylesheets that contribute to the frontend so that crawlers can render the page properly.

    Best regards,


    can you show a sample of how to do this? the code to put in htaccess please?



    This article should show you exactly how this can be done in the robot.txt file.

    // https://www.wpbeginner.com/wp-tutorials/how-to-optimize-your-wordpress-robots-txt-for-seo/
    // https://yoast.com/ultimate-guide-robots-txt/

    Best regards,


    Thank you. I do know about robot.txt and such, but was looking for a folder path on which to disallow for enfold and avia – make sense?
    Thanks for getting back to me so quickly. Take care.



    Have you tried disallowing folders inside the /wp-content/themes/enfold/framework/php/ directory as suggested above? You can disallow most of the folders and files in that folder. All files and folders that have nothing to do with the front end can be disabled or disallowed in the robot.txt file.


    Allow: /
    Disallow: /wp-admin/
    Disallow: /wp-content/plugins/
    Disallow: /wp-content/themes/enfold/framework/php/auto-updates
    Disallow: /wp-content/themes/enfold/framework/php/avia_shortcodes
    Disallow: /wp-content/themes/enfold/framework/php/avia_shortcodes
    Disallow: /wp-content/themes/enfold/framework/php/legacy
    Disallow: /wp-content/themes/enfold/config-templatebuilder/avia-template-builder
    Disallow: /feed/
    Disallow: */feed/

    Best regards,


    As usual, you guys are the best! Thank you.


    Hey Madison,

    I’m glad you were able to be help, of you need anything else, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.