Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #787762

    Recently i’ve inserted some css code to modify my post title. Now, i’d like to show the related post element (with the magazine element of the Advanced Editor) but the related posts titles use the same css code of the post titles so they are big, bold and green (in my case), instead of being small and black as usual. Can you please send me some css code to solve this problem. I’d like to have “normal” titles for related posts and custom title for articles.

    Then an other question. Even if I’ve activated the off set, the article of the page is also in the suggested articles. How can i fix that?



    Hey viaggiareverde,

    Let us edit your code so that it calls only the main-title.

    Please use this instead:

    .single-post .entry-title.main-title  {
        font-size: 30px !important;
        font-weight: bold;
        text-transform: none !important;
    /* COLORE */
    .single-post .entry-title.main-title a {
        color: #036103 !important;
        text-transform: uppercase !important;

    Best regards,


    Thank you. It works, now the related post title is normal as usual.
    What can i do to remove the duplicate article? At the moment (using the magazine element with the tags) it show me also the same post that it’s above that element, so it “suggest” the article just read.


    Hi viaggiareverde,

    That’s strange. By default, related-posts.php should exclude the current post. 
    'post__not_in' => array($this_id))
    Can you try this solution?

    If that doesn’t work, may we have temporary access into your Dashboard so we can take a closer look?

    Best regards,


    I think it sould, but maybe i have this problem because i’m using the advanced layout builder for posts (cause i need it). Infact i’m using the magazine element like a “related post” element. I can understand that my use is not exactly what the magazine element has been built for, but it seems the most appropriate solution for showing related post.

    For the solution you suggest, i don’t understand what i have to do (where to go to do this changes and so on), so can you please explain it a little more? Or tell me what you need




    In your magazine element, can you try setting the Offset option to prevent showing duplicates?  http://screencast.com/t/FRA0HMqcIxsn

    Best regards,


    It’s already set in this way


    Please tell me if you need more information to solve this problem. Thanks



    The solution for you to try requires you to put the code in functions.php. You can access it through Appearance > Editor.  Can you try it please?

    If it doesn’t work, may we have temporary access into your Dashboard so we can take a closer look? Thank you.

    Best regards,


    i’ve tried to put that code in the fuction.php but the magazine element still show me the same article i’m reading. I give you access so you can take a look ( i left the code in the function.php, at the top, so you can see it easily). can you tell me how can i give you temporary access?


    See the privat content



    Please remove the previous filter then use this instead.

    add_filter('avf_magazine_entries_query','avf_magazine_entries_query_mod', 10, 2);
    function avf_magazine_entries_query_mod($query, $params)
        if(is_singular('post')) {
            $query['post__not_in'] = array(avia_get_the_ID());
        return $query;



    Thank you! It works perfectly.

    Best regards


    We’re glad that the problem is fixed now!

    Feel free to let us know here in the forums if we can help you with anything else.

    For your information, you can take a look at Enfold documentation here – http://kriesi.at/documentation/enfold/

    And if there are features that you wish Enfold had, you can request them and vote the requested ones here – https://kriesi.at/support/enfold-feature-requests/

    Thank you for using Enfold.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Post title and related posts titles’ is closed to new replies.