Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #723128

    I was wondering if it is possible to have the secondary menu displayed in the same area/container as the main/primary menu instead of in the bar directly above the main/primary menu? I need the secondary menu to be displayed above the main/primary menu, but I would like the logo area to span the height of both menus. With the secondary menu in the top bar area, it is displayed slightly above the logo. If anything isn’t clear, just let me know. Thanks!


    Hey NicomIT!

    Can you please post the link to your website and a screenshot showing the changes you would like to make?
    You can upload your screenshots on or Dropbox public folder and post the links here



    Sure thing, below is the URL. You can see the secondary menu I have now with a border around it. I also included a link to a mock-up showing how we would like to position the secondary menu.

    • This reply was modified 7 years, 7 months ago by NicomIT.


    Please try adding this code to the Quick CSS section under Enfold > General Styling or to your child themes style.css file:

    #top #header_main > .container .main_menu ul:first-child > li > a {
        height: 30px;
        line-height: 30px;
        position: relative;
        top: 75px;
    #header_meta .container {
        top: 30px;

    Please make sure that > sign is not converted to – in Quick CSS field.

    Best regards,


    Thanks Yigit. That worked great. Just one thing, is there a way to remove the space created by the top bar the secondary menu normally would be positioned in that is directly above the logo and main menu? The CSS you provided moved the secondary menu where I need it, but there is a gap above all three of the elements in the header where the secondary menu and additional contact info would normally be displayed.

    I can’t set #header_meta .container to display: none, because the secondary menu is still technically in that div and it also disappears when I do that.



    Please add this css code.

    #header_meta .container, #header_meta {
        min-height: 0;
        height: 0;

    I tried to access the private page but the password is not working.

    Best regards,


    Thanks Ismael. That helped. However, I still have a gap at the top of the header that I can’t seem to get rid of. Also, whenever I try to add some custom CSS to style the secondary menu, a duplicate of it shows up at the top of the page above the logo. You should be able to see that on the website now. Sorry about the password, that should work now.



    I can’t see any gap in your header. Can you provide us a screenshot showing the issue please? use or dropbox.

    Go to Enfold->Header->Extra Elements->Header Secondary Menu
    and choose “No secondary Menu”.

    Best regards,


    Sure thing. Here’s a screenshot showing the duplicate menu that is showing up:

    I placed a green outline around the entire area that is displaying. The duplicate menu is on the left side and is hard to see because of the dark text.

    This is what I’m trying to make the header look like:

    • This reply was modified 7 years, 7 months ago by NicomIT.


    Please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    Login credentials include:

    • The URL to the login screen.
    • A valid username (with full administration capabilities).
    • As well as a password for that username.
    • permission to deactivate plugins if necessary.

    Best regards,


    The info requested is below and yes, you can disable plugins if needed.



    remove this part using this code inside Quick CSS field:

    .top-links-social {
    display: none;

    Best regards,


    Thanks Andy. That did the trick.



    Glad we could help!
    We really appreciate it if you rate our theme on themeforest
    To know more about enfold features please check –
    Thank you for using Enfold :)

    Best regards,

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Position of Secondary Menu’ is closed to new replies.