Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #168719


    After upgrading to 2.3, I get some strange problem in the portfolio view. When hovering over an image, the whole image is shown (goes over the title). I only get this in Chrome, not in IE where “the whole image” is shown all the time. Chrome though displays a more correct proportion (or at least the proportion I use to have before upgrading), and IE shows more of a square format.

    A little difficult to explain, so please have a look at:
    Username: test
    Password: test



    Hello agarkitekter!

    Please add following code to Quick CSS

    .grid-image img { height: 191px; }



    Hi Yigit!

    That works, but the images still acts a bit strange. It’s most easily seen at this portfolio:

    The first image is 400×300, and I have only added it as a post thumbnail (I want to view the whole image when I click on the ajax preview, and in the portfolio I want to see a scaled down version). The ajax preview image looks fine (even though I through this form got help fixing that by adding this custom css: “.page-id-26 .portfolio-preview-image { width: 36%; }”), but the portfolio image gets the wrong proportions, the face looks a bit wide. You see it clearly if you click on BECKMAN, TOMAS and compare the two images.

    I though maybe it had someting to do with the downscaling, so instead I created a image with 191px i height and added it as the post thumbnail, and the 400×300 as a ajax preview image. That didn’t help at all though, now even the portfolio thumbnail image gets blurry.




    The way images work with WordPress is that you upload the largest possible file size in the proportions that the output will use. The theme/Wordpress then create thumbnails of that image for use in various functions. With this theme you can actually pick which thumbnail gets output in the portfolio elements pop up window by selecting custom image size for the image size parameter.

    The site has a login so i can’t see what you have right now but hopefully the above helps.

    Best regards,



    Username and password is “test”

    I have done some changes to grid.css that changes the width of the page, as you can se the width is wider than 1210px. So that’s what makes the images a bit streched out. It’s not much but still a bit irritating. I guess you can’t help me since it’s due to other changes with the theme? I may have to go to codeable where I got the help with “widening” the page.

    My portfolio setting is “set image setting automatically”, and I’ve tried some other settings. Some of them sharpens the image quality, but I get other errors like white space between the image and the title. I guess it also have to do with the custom changes.



    Try changing them to 301 by 214. In functions.php look for:
    $avia_config['imgSize']['portfolio_small'] = array('width'=>260, 'height'=>185 ); // images for portfolio 4 columns

    Since you have a bigger width/area you can increase the size and then re-generate all the thumbnails with :


    I think I get what that does, but I can’t get it to work. I have re-generated all images, and also tried with adding new images after changing in functions.php. Do the WP media settings affect this in any way? Cause I have the settings 80×80 (small), 0x0 (medium, must be something wrong here?) and 1030×1030 (large).



    The regenerated thumbnails are 301 by 214 px now. I think Devin’s fix worked. Please remove browser cache then reload the page. The portfolio page looks great. The Media settings doesn’t affect the portfolio thumbnails.

    Best regards,



    The quality is fine now, but there is still something wrong with the proportions. I have removed the cache and even installed a fresh installation of Firefox, but it looks the same. Please have a look at this screenshot: Image

    The greyscale portfolio image to the left is what I see, and the right image in color have I pasted in (with the correct proportions).




    .grid-image img {
    height: 191px;

    Its stretching the images now instead of helping them :)


    Ah, I see! :)

    Great, it works now! Thank you very much, really appreciated!

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Portfolio problem after 2.3 (Chrome)’ is closed to new replies.