Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #207721

    Hey guys
    Just upgraded to the latest version and found an issue with the Portfolio permalink structure.

    Hovering over any Portfolio item used to give me the pre-defined URL structure which was defined as:
    ‘/ (Purchase code hidden if logged out) /’ followed by the name of the painting (the portfolio page title)

    However, now that’s gone when you hover over any Portfolio item. My pre-defined URL has gone and been replaced with:
    ‘/portfolio-item/’ followed by the name of the painting

    And here’s the big problem: All widgets featuring Portfolio items now default to these new, changed URL permalink instead of the actual ones I defined. So now all my Portfolio items return a 404 because that new URL does not exist.

    So, this exists and is correct: (Purchase code hidden if logged out) /callisto/
    But this doesn’t and is incorrect: – but this is what it now links to in my footer and in the widget areas. PAGE NOT FOUND! Aaaagahhhhhhhhgghhhhh…

    I also noticed that the box in the Theme Settings that allowed you to define the Portfolio default permalink slug has disappeared. Is this why the portfolio is now defaulting to ‘portfolio-item’? I had mine set to ‘ (Purchase code hidden if logged out) ‘.

    Please, please, please – I need this resolving ASAP as people may die… is where you find my Portfolio page.
    Caches flushed and right click enabled for you.



    OK so I have a fix but I would still like to know what has gone on please guys?

    I changed my Permalink settings (on the Permalinks page) in the Portfolio Entry Settings box and of course it works but I would like to know where that box went in the Theme options panel and why this has caused a problem on the update.

    Would really appreciate it guys; trying my hardest to make everything as good as I can get and I’m almost there…


    FYI – this is what I have just done, but never had to do this before…

    • This reply was modified 3 years, 9 months ago by  Swarez.


    The avia_flush_rewrites function is not required anymore. The avia_flush_rewrites code forced wp to rewrite the rules when the user saved the settings, the custom rewrite rules cause too much trouble especially with WPML. Dude created some new code which registers new permalink options on the Settings > Permalinks page. The user can only change the permalink structure on the wordpress settings.



    Thanks guys

    That explains the issue perfectly well; such a shame I got crawled by Google whilst this was going on! Ouch…


    • This reply was modified 3 years, 9 months ago by  Swarez.


    Also see (Purchase code hidden if logged out) -wpml/ for more information.


Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Portfolio permailnk change error on latest version **URGENT**’ is closed to new replies.