Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #356335

    I have posted about this before I believe, and I have also posted in WordPress forums. This is a theme specific problem- I run Enfold on 2 sites, two different designs, layout, and hosting providers, and the problem persists on both clients. If I disable Enfold and use any other theme, this problem goes away. I have also tested on multiple hosting platform- my site used to be on a BlueHost VPS and since it was having this problem I migrated it to a Vesta CP CentOS dedicated server of which I have explicit control, and the problem persists.

    When I upload a PNG file, of ANY file size, the file seems to load for 4-5 minutes before erroring out. I then leave the upload media window, and save the post as a draft. Then I go to upload the image again, and the image did successfully upload the first time:

    When I first upload, it sits like this for a few minutes: http://cl.ly/image/220g2h2m0J0B
    It eventually times out: http://cl.ly/image/36041k2t3L0z
    Then I save post or page as draft and go back into media manager and the image is there.

    I have had this problem for a long time- 6 + months. This problem also affects JPEG images, though far less frequently. I have monitored the server logs, and there is nothing that points to a problem with the server.

    I do not expect you to provide a solution to this, but I thought I would try more as it makes uploading files a real slow painful process- almost worth switching to another theme just to upload then switching back.

    Thanks

    #356504

    Hi Imburr!

    Thank you for using Enfold.

    Can you please provide a link to the actual website? A few users reported this issue and most of the time it has something to do with the server configuration or the WPML Media plugin. Make sure that all plugins are updated. If possible, please deactivate all plugins then test it again.

    Best regards,
    Ismael

    #356526

    I have done lots of testing, and I have tried disabling all plugins. Everything is up to date as well. The website is virginiaseo.org, and I can get you login credentials if you wish. I could even get your SSH credentials if that would help, or print out my config for ya.

    Chris

    #357925

    Hi Chris,

    Please create us a WordPress administrator account, post it here as a private reply.

    Regards,
    Josue

    #357995
    This reply has been marked as private.
    #358064

    Hey!

    I tried reproducing the issue, here’s my results:

    Via Media > Add new:
    http://screencast.com/t/MzRwKzuAId.

    Via media library popup:
    http://screencast.com/t/BzjVQtELudu

    Regards,
    Josue

    #358103

    Sorry, try to upload it as a featured image on a blog post, which is where the problem is. Also it happens when you Add Media outside of your advanced layout editor or image shortcode, but that is less often.

    #358112

    Hey!

    Same results – http://screencast.com/t/Ry9l35Gyg, have you checked if it happens to you in another computer/network?

    Regards,
    Josue

    #358118
    This reply has been marked as private.
    #358200

    It’s very strange, maybe the server isn’t capable of resizing all the Enfold image sizes at once and it times out, remove this lines from the theme functions.php and try re-uploading it:

    $avia_config['imgSize']['widget'] 			 	= array('width'=>36,  'height'=>36);						// small preview pics eg sidebar news
    $avia_config['imgSize']['square'] 		 	    = array('width'=>180, 'height'=>180);		                 // small image for blogs
    $avia_config['imgSize']['featured'] 		 	= array('width'=>1500, 'height'=>430 );						// images for fullsize pages and fullsize slider
    $avia_config['imgSize']['featured_large'] 		= array('width'=>1500, 'height'=>630 );						// images for fullsize pages and fullsize slider
    $avia_config['imgSize']['extra_large'] 		 	= array('width'=>1500, 'height'=>1500 , 'crop' => false);	// images for fullscrren slider
    $avia_config['imgSize']['portfolio'] 		 	= array('width'=>495, 'height'=>400 );						// images for portfolio entries (2,3 column)
    $avia_config['imgSize']['portfolio_small'] 		= array('width'=>260, 'height'=>185 );						// images for portfolio 4 columns
    $avia_config['imgSize']['gallery'] 		 		= array('width'=>845, 'height'=>684 );						// images for portfolio entries (2,3 column)
    $avia_config['imgSize']['magazine'] 		 	= array('width'=>710, 'height'=>375 );						// images for magazines
    $avia_config['imgSize']['masonry'] 		 		= array('width'=>705, 'height'=>705 , 'crop' => false);		// images for fullscreen masonry
    $avia_config['imgSize']['entry_with_sidebar'] 	= array('width'=>845, 'height'=>321);		            	// big images for blog and page entries
    $avia_config['imgSize']['entry_without_sidebar']= array('width'=>1210, 'height'=>423 );						// images for fullsize pages and fullsize slider
    

    Regards,
    Josue

    #371454

    I just saw this, sorry for the delay. I will try this and update, thanks.

    #371661

    Hi!

    Please try and let us know so we can mark the thread as resolved or assist you further :)

    Cheers!
    Yigit

    #374960

    So far, so good. It worked on the last two posts without error, though it still takes a long time to process small PNG files. Will update again once I have more tries, but for now this looks fixed. Thanks!

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘PNG Upload Issue’ is closed to new replies.