Viewing 30 posts - 61 through 90 (of 103 total)
  • Author
    Posts
  • #1070189

    Hi,
    I took your post to mean that instead of getting a 404 page, the user should get a search results page using the url as the search term, which is quite interesting. I tried to research this but didn’t find any plugins or functions that does this.
    It seems like all we would need to do is (Purchase code hidden if logged out) .php”>convert the URL into a Query String It would take a lot more work to make this work, but I did find a article from someone that tried to do this and it turned into a mess for their site: (Purchase code hidden if logged out) “>Good Idea Gone Wrong: Custom 404 Page with Search Results so now I’m not sure if it is a good idea, but either way, it would be more than we can do here.

    Best regards,
    Mike

    #1070305

    Hello Mike !
    Thanks for your answer…
    I believe that in my case, including in the url the name and phone number linked to the article, it may be good to use the url, also as the title of the post ..
    But if this is not possible for now … using only the default setting of Enfold, I have the option to leave the url unchanged or modify it with the page tutelage set as 404 … At this moment, after having read the link you suggested I do not know what is best to do in my case …
    Do you have other tips?
    thank you

    Sincerly,
    Sacha

    #1070692

    Hi,
    I would create a custom 404 page using the ALB and show a grid of your most popular pages, and a heading that suggests to choose from our most popular pages below.

    Best regards,
    Mike

    #1070867

    Hi Mike,
    I think it’s what I did …
    I have doubts about the url,
    you can see if this (link in private) is what you mean by “and show a grid of your most popular pages”
    Thanks for your help!

    #1070963

    Hi,
    Perhaps add some images or icons to the links, are they the name of cities? Also perhaps a full-width search bar in the middle, like this:
    2019-02-24-092125
    To add a search bar, add this code to the end of your functions.php file in Appearance > Editor:

    add_shortcode('avia_search', 'get_search_form');

    then add a code block with the custom class “search-bar
    2019-02-24-093026
    and inside the code block add this shortcode:

    [avia_search]

    then add this css to your Quick CSS:

    #top .search-bar #searchform>div {
    width: 100% !important;
    max-width: 100% !important;
    }
    #top .search-bar input[type='text']#s {
    font-size: 32px;
    padding: 10px 60px 10px 20px; 
    }
    #top .search-bar #searchsubmit.button {
    width: 60px !important; 
    height: 60px !important;
    }

    It’s just a thought.

    Best regards,
    Mike

    #1072646

    Hello Mike ! Thank you, you are always so kind,
    Yes, they are the city name.
    I tried to improve a little, but I did not put the search, already present in the footer.
    but I omitted the images with links to go to the main pages.
    What do you think, in your opinion can it be better? or are there any other recommendations for 404 questions?

    – In the meantime I found another problem ..
    a vulnerability that I should try to eliminate – but not just so is the right way. Google detects this “jQ (Email address hidden if logged out) ” as a penalizing vulnerability. I did some research but I did not find any reliable sources. What can you suggest?
    Thank you !!
    best regards,

    – I take advantage of this and ask you about another problem …
    I can not dynamically set the title tags alt images. I have installed the SEO Optimized Images Business plugin for a long time, but I can not make it work as it should.
    – their support seems to be non-existent, even if it had to be included in the purchase.
    – enfold does not seem to give much chance in this regard.
    Can you give me suggestions, or could you give the plugin a check?
    Thanks, Mike.
    Sacha

    #1072838

    Hi,
    I think that your page is a better now.
    I don’t understand why ” Google detects “jQ (Email address hidden if logged out) ” as a penalizing vulnerability” jQuery is on almost every website, where can I see the penalty?
    Also what do you mean by “dynamically set the title tags alt images” the alt tags are set automatically, how would you want it different?

    Best regards,
    Mike

    #1072970

    Hello Mike!

    -Google reads “jQ (Email address hidden if logged out) ” as a penalizing vulnerability. I think we should replace it.

    -Intertaining the words that appear when the mouse hovers over the image, and the words that appear when the image is not loaded. None of these words appears, and I would like them to automatically take the title of the post and its portfolio category, or the name of the page where it is displayed.

    Thank you for your support!

    #1073476

    Hi,
    Are you using the Google Lighthouse tool for optimization? (Purchase code hidden if logged out) -12-4-as-vulnerable/#topic-10620820-replies”>Please see this explanation to see this is what you are talking about.
    If so perhaps this plugin will help: jQuery Updater

    Best regards,
    Mike

    #1073572

    Hi Mike try jQuery Updater to remove the error.
    What do you know about image labels? In the galleries are not the labels and I write them in the caption, in the alternative text and in the description of the images … I pluginabout it …

    What do you suggest?
    Thank you!
    Sincerly,
    Sacha

    #1073625

    Hi,
    I took a look at the page in the Private Content area, and found that your image “titles” are like this “Link a: 3512406586 Anna”
    so I thought that you are adding links to your “titles” or what you might be calling your “image labels”, but links are removed from there. I tried to login to see but WordFence locked me out.

    Please try to add some screenshots of what you are calling “image labels” because I might call it something else. I just want to be clear what we are working on.

    Best regards,
    Mike

    #1073630

    Hi Mike, I’ll send you a new temporary access, because soon the autooptimize staff should start optimization work.
    the page you looked at is in fact the only one in which the title tag works but the alt tag does not work, and it is the only one that uses the “magazine” or rather the image grille. in this page the title tag should not say es: “link to 366 **** 88 Valentina” but only “366 **** 88 Valentina”

    On other pages the title tag does not work, and is not shown on mouseover. while the “alt” tag works
    so the things I would like to do are:
    – From the magazine element, remove the word “Link to ….” and leave only the title of the post as title and tag alt of the image, (but this is a smallness not very important)
    the following is urgent:
    – in the grid element show as title tag of the preview image the title of the post and if possible also of the page, but at least the title of the post definitely. it should be this way “366 **** 88 Valentina + page name”
    – if possible also with code to be implemented or plugins, make the title and tag alt images automatic, always taking “title of the post + title of the page where it is displayed” or at least even the title of the post is acceptable … but not just the title of the page because it would be a seo disaster.
    – more ‘I add that the problem of jQuery Updater, did not work, activating the main menu does not open on the desktop, and’ in transparency illegible on mobile.

    Please Mike, I know you’ve always done your best … I’m very urgent because my pages are sinking into the serp.
    Sincerly,
    Sacha

    #1074677

    Hi,
    I took a look at your magazine element that is showing the text “Link a:” in the title attribute, which shows on thumbnails hover.
    So I couldn’t remove the text “Link a: ” but I was able to replace the entire title attribute with the h3 text that goes with the image.
    When I checked other pages I didn’t see this text “Link a: ” being added to the magazine titles, so I added the script to the top of the page in a “code block” so that it will only work on this one page. We can make it work on more pages that have the same error, but check this page first.

    <script>
    (function($){
      $(document).ready(function(){
      $(".av-magazine-entry").each(function(){
        var captiontext = $(this).find("h3.av-magazine-title").text();
        $(this).find("a").attr("title", captiontext);
    
    });
    });
    })(jQuery);
    </script>

    Please see the page link in the Private Content area.

    Best regards,
    Mike

    #1074704

    Hello Mike !
    You’re the best as always! irreplaceable!
    your script is fine.
    I must also learn how to build these scripts, and yours will serve as an example. maybe, can you tell me a tutorial to understand how they are built?

    I did not find the link in private..
      how do we solve the other pages? I would like that in other pages always take the usual h3 (Article title) + the title of the page where the article is displayed. it’s possible ?

    Best regards,
    Sacha

    #1075328

    Hi,
    Thank you :) I see we are working in someone else’s thread, sorry I thought it was yours.
    the page was /recensioni-escort/ but I guess you found it, and that is why you know it works?
    So when I looked at the other pages they seemed correct and that is why I didn’t add it to your whole site, we can do this but please add some links to pages with the error so I can check.
    We should be careful with these scripts so they don’t break any pages.

    Best regards,
    Mike

    #1075978

    Hello Mike ! well found!
    Yes, the site is mine, just that in these days there is a staff to optimize and is doing a lot of work.
    yes, please, I need the script to work for all pages …
    I do not know if this is possible but what I would like is that the alt and title tags on the mouseover are composed of (article name + page name).
    an esemple in private.

    Thank you so much!
    Sincerly
    Sacha

    #1076203

    Hi,
    I took a look at this and tried to isolate your page title, so that it was not a long string of keywords, I found that your “AddToAny Share Buttons” plugin at the bottom of your page held just the title so I wrote this script to add the article title + page title to your articles:

    function article_titles_attr(){
      ?>
      <script>
    (function($){
      $(document).ready(function(){
      $(".slide-entry").each(function(){
        var space = " ", returnValue = "";
        var pagetitle = $(".a2a_kit").attr("data-a2a-title");
        var captiontext = $(this).find("h3.slide-entry-title").text();
        $(this).find("a").attr("title",captiontext + space + pagetitle );
    
    });
    });
    })(jQuery);
    </script>
    <?php
    }
    add_action('wp_footer', 'article_titles_attr');

    For the magazine titles I added this function, but not all of the pages have a AddToAny Share element, so some of them might not show the page title:

    function magazine_titles_attr(){
      ?>
      <script>
    (function($){
      $(document).ready(function(){
      $(".av-magazine-entry").each(function(){
        var space = " ", returnValue = "";
        var pagetitle = $(".a2a_kit").attr("data-a2a-title");
        var captiontext = $(this).find("h3.av-magazine-title").text();
        $(this).find("a").attr("title",captiontext + space + pagetitle);
    
    });
    });
    })(jQuery);
    </script>
    <?php
    }
    add_action('wp_footer', 'magazine_titles_attr');
    

    Best regards,
    Mike

    #1076256

    Hello Mike ! Good morning !
    Great ! for the titles I worked.
    Only that the same words should also be contained in the “tag alt” of the previews

    more (something I had not thought about), is it possible to have alt and title tags even in the image galleries inside the atricoli portfolio?

      I’m in doubt … “because the titles of the pages appeared as a long series of key words .. in fact it is a malfunction I had noticed … Maybe it is caused by yoast?
    Thank you so much for your help!

    Best regards,
    Sacha

    #1076377

    Hi,
    I added the alt tag by including this code in the function:

    $(this).find("a").attr("alt",captiontext + space + pagetitle);

    It looks like the function is working in the portfolio, perhaps I’m looking in the worng area, please link directly to where it is not working.

    Best regards,
    Mike

    #1076412

    perfect, it works!
    Maybe I had seen badly, I’m always inexperienced …
    Excuse me and thank you very much!
    I will write to you again in the near future because I still need a lot of work …
    Thank you
    Have a beautyfoul day!
    sincerly,
    Sacha

    #1076520

    Hi,
    Glad I could help, have a nice weekend :)

    Best regards,
    Mike

    #1076630

    Many thanks,
    Have a beautyfoul week-end
    Best reguards
    Sacha

    #1077730

    Good morning Mike.
    I would like to insert in the pages of the blog, under the summary of each portfolio article, a customized field that takes the name of the page where the blog is displayed.
    Looking in the guides, I found that Advanced custom field should do just that ..
    I installed it, but in the back end of the portfolio articles the custom fields do not appear … and I am not even if I set it correctly. I tried to create a custom field from the plugin tools but it doesn’t work.
    Can you help me?
    Thank you !
    Sincerly
    Sacha

    #1078070

    Hi,
    Sorry I don’t have much experience with ACF, it sounds like what you want is simple enough, and I found an article that may help: Adding fields to Posts
    But I have not done this before. I know many other members use ACF so perhaps someone with post the solution, or I could ask the rest of the team to try to assist.

    Best regards,
    Mike

    #1078179

    ooh what a bad luck,
    Ok I hope someone can help us,
    I really need to know it but I haven’t found enough guides yet for me …
    I’m waiting for your news!
    Thank you
    Sincerly
    Sahca

    #1078271

    Hi,
    I asked for anyone on the team that knows ACF well to take a look, Thank you for your patience.

    Best regards,
    Mike

    #1079192

    Hello Mike !
    how are you? there is someone to tell you how worck using ACF?
    Best regards,
    Sacha

    #1079314

    Hi,
    Sorry, I asked the team to take a look if they knew ACF, but no one wrote back so I assume they don’t use it either.
    But I have seen other members that have done some incredible things with ACF.
    Perhaps if you create a new thread with a title like “How to add a custom field to a portfolio with ACF?”
    and then explain it in more detail, the other members that do know ACF will see it and reply.
    I don’t think they will see your question here because your title is on a different topic.
    There are a lot of nice people here, and I see them helping on other threads often.

    Best regards,
    Mike

    #1079493

    ok, thanks, I do it
    Best regards,
    Sacha

    #1082057

    Hi Mike ! How are you?

    Please, I have a problem but I don’t know how to search for the topic …
    I put the link in private … looking from the descktop is fine, but on mobile there is a large space between the main menu and the first horizontal photo in black and white color … How can I remove all that space?

    Best regards,
    Sacha

Viewing 30 posts - 61 through 90 (of 103 total)

The topic ‘Picture and text zoom on smartphone’ is closed to new replies.