Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #502911

    Hi,

    the release of PHP 7.0 is near (currently RC2) and Enfold 3.3.2 is not compatible. I have this bug :

    Fatal error: Uncaught Error: Function name must be a string in /Users/xx/www/webimt/wp-content/themes/enfold/framework/php/class-style-generator.php:123 Stack trace: #0 /Users/xx/www/webimt/wp-includes/plugin.php(503): avia_style_generator->create_styles(”) #1 /Users/xx/www/webimt/wp-includes/general-template.php(2270): do_action(‘wp_head’) #2 /Users/xx/www/webimt/wp-content/themes/enfold/header.php(50): wp_head() #3 /Users/xx/www/webimt/wp-includes/template.php(555): require_once(‘/Users/xx/w…’) #4 /Users/xx/www/webimt/wp-includes/template.php(514): load_template(‘/Users/xx/w…’, true) #5 /Users/xx/www/webimt/wp-includes/general-template.php(45): locate_template(Array, true) #6 /Users/xx/www/webimt/wp-content/themes/enfold/template-builder.php(12): get_header() #7 /Users/xx/www/webimt/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php(456): require_once(‘/Users/xx/w…’) #8 /Users/xx/www/webimt/wp-includes/plugin.php in /Users/xx/www/webimt/wp-content/themes/enfold/framework/php/class-style-generator.php on line 123

    As I’m already using PHP 7 in my dev project, I wish Enfold will be soon compatible.

    When will it be compatible with PHP 7.0 ?

    Thanks
    Oli

    #502950

    Hey Oli!

    We do not have any time frames for PHP 7 but I added this to our dev queue and they will take a look when they have time. As it gets closer to maturity we may see some changes in an update for compatibility.

    Regards,
    Elliott

    • This reply was modified 2 years, 3 months ago by  Elliott.
    #529665

    Hey! Since php7 is currently only in beta we are still waiting for a MAMP php package that allows us to test it locally. Once I can get my hands on a package I will update the theme accordingly

    Regards,
    Kriesi

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘PHP 7.0’ is closed to new replies.