Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #203037

    Parallax-effect doesnt work on ipad ..
    The images are static placed. Menas: the site scrolls but the images are just fixed like other content. No effect like on PC.
    Gotta a fix for this little bug?


    Hi docperi!

    Is this with Enfold 2.5? I know Kriesi was working on updating the effect to work on iPads but the last time we had a discussion about it he wasn’t able to add the same effect on iPads quite yet so they would fall back to being fixed for now.



    Nice :-)
    Btw .. chrome has some problems with this effect too. The browser does not display the content like FF and IE and testing in IE 8 i became an error. i know, old Browser but lots of clients use this old shit. See picture …. Got an idea to fix it?

    My error

    • This reply was modified 10 years, 5 months ago by docperi.

    That error looks like the old one when not being up to date with Enfold and using WordPress 3.6+.

    Make sure you are using Enfold version 2.4.4 (which shows as 2.5 in the WordPress admin) and WordPress 3.8.


    Hello Devin,
    i use Worpress 3.8 and i have the newest Enfold installed.

    The System displays:

    Theme Updates
    No Updates available. You are running the latest version! Great!

    Any other idea? thx



    Can you post the link to your website please?



    Hi Josue,
    Still working on it …

    I testet it with the newest ie tester.
    On ie Version 8 the error apears …


    • This reply was modified 10 years, 5 months ago by docperi.


    Did you try to deactivate all third party plugins? Maybe a plugin triggers the js error. You can also try to re-install all theme files – i.e. upload them with ftp and overwrite all old theme files.




    The parallax effect does not work on iOS, and that is fine. However, on iOS, the images appear scaled way up and fill the entire screen. I would be ok if the height stayed minimal to 25% of the browser screen, but as it stands, the website looks broken and buggy on iOS and fine on Chrome, FF, and IE.

    I am using the latest version of WordPress and Enfold. I tried clearing my cache on iPad 2.

    Including link to live site here:


    Hello again,
    I tested on iPhone 4 and works great! No problems. No parallax, but the images display in a nice way, which is great!
    However, It does not work on iPad. The color section parallax images are scaled way up and fill the entire screen.
    Just wanted to mention that.



    I tagged this thread for Devin and Kriesi (they can test it with an IPad).



    Hey guys!

    The parallax is deactivated on mobile devices. when you scroll on a mobile device the page stops rendering (you can try that during a slideshow animation for example) therefore the parallax effect would not be smooth at all. there are ways to accomplish the effect but it requires a library like scrollability ( ) which is basically an 800 line big js file which we would need to include, just for that effect.

    Currently I don really think its worth it to include it…
    I will however take a look at the image proportions on ipads :)

    Best regards,

    • This reply was modified 10 years, 3 months ago by Kriesi.


    Thanks for responding. I understand why the parallax does not work for mobile, and the reasoning. It’s totally fine.

    My problem appears to be a bug specifically related to iPad 2, or possibly iPad in general. iPhone 4 looks as it should, but the iPad 2 has a bug with the parallax color section. The image used in the color section appears very large and scaled up, like 500% more than normal. This causes the browser to be completely filled with a giant scaled up image.

    I just did some more testing and set the color section with the exact settings in the Enfold Demo and I got it to work as it should! Yay! So the problem appears to be how I originally setup the color section options: (see below)

    Bad settings: (caused iPad 2 to crash in Safari)
    * Section Colors: Alternate Content
    * Background Attachment: Parallax
    * Background Image Position: Center Center
    * Background Repeat: No Repeat
    * Section Minimum Height: At Least 50%
    * Section Padding: No Padding
    * Section Top Shadow: Do Not display Shadow

    Good Settings: (got the desired effect I was looking for)
    * Section Colors: Main Content
    * Background Attachment: Fixed
    * Background Image Position: Top Left
    * Background Repeat: Stretch To Fit
    * Section Minimum Height: No Min. Height
    * Section Padding: Large Padding
    * Section Top Shadow: Do Not display Shadow

    Ok, thanks for helping out. It appears the problem is solved with the correct settings. I’m kind of new to this theme, and am learning how it works as I go. Love it, btw! The avia shit is what I have been dreaming of for many years. ;) It’s really nice to use. Thanks for all the great support too.


Viewing 13 posts - 1 through 13 (of 13 total)
  • The topic ‘Parallax-effect doesnt work on ipad ..’ is closed to new replies.