Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #1063414

    On two of my pages, the main page H1 and intro text paragraph (text block elements) have suddenly stopped displaying at the top of the page. However, the elements are still there within the editor. They’ve simply stopped displaying on the live pages. I’ve tried deleting and re-createing them, moving them around, adding other elements to the page, etc. Nothing works. Any idea why this might be happening?

    Here are the pages with the missing header and intro text:

    https://www.guitaranswerguy.com/guitar-care-and-maintenance/
    https://www.guitaranswerguy.com/guitar-product-reviews/

    And here’s an examples of a similar page where the title and intro text is still showing:

    I’ve provided login credentials so you can go in and take a look. As you’ll see, the elements are there (text block elements) at the top of the page in the layout editor, but just aren’t showing on the live pages.

    Thanks in advance.

    #1063888

    Hey Bobby,

    The first two with the problems are archive pages, you can’t edit those with the Layout Builder.

    Best regards,
    Rikard

    #1064155

    Interesting, I didn’t even realize I’d done this to only two of my pages. Thanks for catching that. I’ll see what I can do about switching those.

    EDIT: I took a quick look, and I can’t see any difference between these ‘archive’ pages and the normal pages. I’m trying to switch them to the normal page format, but the solution isn’t obvious to me. Is this a simple setting somewhere that’ll change the page type?

    One other interesting bit of background info: These pages were fine (headers and text showing) for years… until I made a couple slight modifications (yesterday) to my main navigation bar. I deleted a section from one dropdown, and that’s when this all began.

    #1064476

    Hi,

    I’m not sure what’s going on with your installation but it seems a bit strange. For instance, if you are logged in and view the first page in private, then you have an option in the WordPress top bar which reads Edit post, that shouldn’t be there when view an achieve page as far as I’m aware. If you click the link then you are taken to the post in private. I’m really not sure why that is though.

    Best regards,
    Rikard

    #1064589

    Rikard,

    Actually, what happens when you click “edit post” is that you are taken to one of my blog posts–a post completely unrelated to the page. It takes you into edit mode for this post:

    This is another issue I was seeing that is related to this, but didn’t want to confuse you guys by trying to include too much information in my original question.

    So yes, there’s a lot of weird stuff suddenly going on here–and none of it seemed to start happening until a few days ago. Prior to that, these pages were fine, I was able to view and edit those headers (and intro paragraph), etc. Suddenly, things have become very strange.

    The only way you can get into edit mode for the page is by first going to Pages > All Pages > “Guitar Care and Maintenance Articles”

    You’ll see that it’s listed there as a normal page, just like all the others. Not an “archive” page (as far as I can tell).

    #1064884

    Hi,

    Actually, what happens when you click “edit post” is that you are taken to one of my blog posts–a post completely unrelated to the page. It takes you into edit mode for this post:

    https://www.guitaranswerguy.com/favorite-guitar-information-resources/

    Exactly, that’s what I meant. Maybe I didn’t explain myself very well. Anyway, I don’t really have any clues as to why that might be happening. I’ve never seen it happen before to be honest with you. Did you change or install something on the site before this started happening?

    Best regards,
    Rikard

    #1065445

    Do you think that completely deleting the current “../favorite-guitar-information-resources/..” page and then re-creating it (with the same exact URL) might fix the problem? There’s not much content on the page, so I could probably do this in a matter of minutes without much impact on my visitors.

    I’d like to keep that exact URL, as I’m unsure of how a URL change might affect my SEO ranking for that particular page. Otherwise, I could re-create the page with a whole new URL, put redirects in place, update my nav menus, etc. and that would probably do the trick. However, I’d prefer to NOT have to do that.

    I’ve done a few more experiments with this page, and nothing I do to try to affect content changes will actually show up live. I can, however, unpublish the page, and that does indeed remove it from the live site. However, content changes have absolutely no effect. Seems my database has somehow become corrupted.

    #1065795

    Hi,

    Yes, you could try it at least if it doesn’t take you too long. I would suggest that you start off with a new page, then create the layout you want and then publish it. After that you can try to delete the old page, then go back to the new one and change the title and permalink to the old title and permalink. Don’t forget to delete the old page from the bin, otherwise your permalink won’t be the same as before.

    Best regards,
    Rikard

    #1065973

    I’ll give it a try. Thanks for reminding me to empty the bin of the old page. I probably would’ve forgotten about that (because I’ve never actually deleted any pages or posts) and would be wondering why my link wouldn’t change or update.

    One last question: if I hired a developer, do you think they’d be able to dig into the database and find (and correct) the actual problem? Or, is that unlikely? If there’s a chance this can be corrected, I might be willing to spend some money to hire a developer (I’ve worked with him before).

    #1066300

    Hi,

    Thanks for the update, I think the problem you are having is some type of permalink issue or conflict. Those can unfortunately be difficult to find, but if you think that your developer would be able to help you out then I would at least give it a go.

    Did you try my previous recommendations and did you have any luck with it?

    Best regards,
    Rikard

    #1066496

    I’ve not tried it yet, no. I need to ensure I have a few hours free just in case something doesn’t go as planned–so I have time to react accordingly. I’ll probably try it this weekend.

    #1066707

    Okay, I tried that and it did not work. Here’s what I did:

    1. Created a brand new page that matched the existing one.
    2. Gave it a unique permalink
    3. Published the new page
    4. Check the new page live, and confirmed that everything looked good and was functioning normally
    5. Deleted the old page and emptied it from the trash (deleted permanently)
    6. Changed the new page’s permalink to the old one and clicked “update”

    The minute I did #6 the new page began exhibiting all the same symptoms. For good measure, I cleared all caches (site cache and browser cache), but the page was still broken.

    So, I think the only way I’m going to truly solve this issue is to recreate the page, but use a completely different URL, as I’d suspected.

    I guess I’ll have to put 301 redirects in place so anyone linking to the pages will get to the right place. Not happy, and concerned about what this’ll do to my SEO rankings for these two pages (because the issue is happening to two of my pages, not just the one we’ve been talking about).

    #1066825

    Hi,

    Thanks for the update, I think I have found the problem. If you go to the page in private and check the permalinks for the Product Reviews and Care & Maintenance categories, then you will see that they correspond to your archive pages, if you try to add a post or a page with a permalink which is the same then you will run into problems. It doesn’t explain your problems fully, but you can’t use those two permalinks for any posts or pages.

    Best regards,
    Rikard

    #1066994

    I still don’t think I understand how to view what you’re describing. Could you tell me step-by-step how to get to the view you’re describing? My problem is that I don’t really know what “archive page” means. Archives = blog posts? And by “private” do you mean using a browser’s private mode?

    When I go to the link you provided, I simply see my categories (which I’m familiar with). I don’t really understand what I’m looking at beyond that, or how it’s causing a problem.

    I think what you may be saying is that this isn’t actually a database or installation issue (e.g. a ‘bug’ or corruption of some kind), but a normal byproduct of how I’ve named my pages. Is that correct? Is it because I’ve given those pages the same permalink as those used by my categories?

    It’s still odd though, because these pages have functioned normally for years like this. Perhaps something happened with one of Enfold’s major updates. I actually don’t know when this problem began. It may have been months ago and I just never noticed it until recently.

    #1067349

    Hi,

    An archive page is the template which is used when you click into a category for instance, it will list all the posts in that category.

    By private I mean the link I sent to you in the private content box.

    If you go the categories page I linked to again and select to edit one of the categories, then you will see Slug listed there. That is permalink of the category, that is what you can’t use for any images/post/pages etc. That should be done automatically for you though, if you give a post the same permalink as a category then it should change to something like slug-for-post-2 or something similar. That is what is a bit strange about your installation. But please try to check all your permalinks for the pages which are behaving oddly, changing them should work I think.

    Best regards,
    Rikard

    #1067351

    Hi,

    As a side-note to all of this, I just want to stress the fact that (Purchase code hidden if logged out) /” rel=”noopener” target=”_blank”>WordPress updates should be taken seriously, and should always be checked properly on a staging site before being applied to the production site. You might not have caught this problem even if you did update on a staging site first, but it would have given you are greater chance of not introducing it on your production site.

    Best regards,
    Rikard

    #1067483

    Thank you. I do have a staging server available as part of my hosting plan, but I’ve been very lazy and not using it. I’ll make sure I do that going-forward.

    I probably still would’ve missed this one though, even on a staging site. I checked on archive.org, and it appears this might’ve happened back in March or April of 2018. That’s the last time I see those page elements as visible at the top of the “Care and Maintenance” page.

    #1068149

    Hi,

    Thanks for the update and feedback, so the problem was likely introduced earlier then? I would advise you to simply check the permalinks which are giving you problems, and make sure that the categories don’t conflict with any permalinks on posts or pages.

    If you have a staging site then I would strongly advise you to use it :-)

    Best regards,
    Rikard

    #1068408

    Thanks Rickard. I think you can close/lock this thread if you’d like.

    #1068503

    Hi,

    If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 20 posts - 1 through 20 (of 20 total)

The topic ‘Page's Text Elements Disappeared and Will Not Display’ is closed to new replies.