Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1054622

    I’m having issues seeing edits that I have made in my child theme’s CSS. I could be forgetting something simple, but I am pretty sure I’m doing things correctly. I tried changing the font face and color of the H1 text to:

    	font-family: eurostile, sans-serif;
    	font-weight: 400;
    	font-style: normal;
    	color: #f3703a;

    But I’m not seeing any changes. To be sure I was targeting the correct CSS, I added a custom class to the text box on the home page called “content-text” and added the above code to it, but still don’t see the new font and color.
    If I do this:
    color: #f3703a !important;
    I see the new color in the element preview area when editing the page. But not in the browser when I view the page itself.
    The URL/password to view the website is in the private content area. If someone could have a look at this, it would be great. Thanks.

    • This topic was modified 5 years, 3 months ago by NicomIT.

    Just an update on this. This morning the changes to the H1 I made with the custom class appeared randomly. I had added a border under the text to see if that would show up, which it did. However, I just removed it from the CSS and it is still there. So I’m not sure what is going on. This should be pretty straight forward and I have made changes to the child CSS file to customize many websites using Enfold and haven’t run into this before.


    Sorry for the late reply, it sounds like you have the css & js file merging enabled, while making your css edits directly into the child theme style.css.
    The merged files only update then the theme settings are updated, such as clicking the big blue button “save all changes”, saving the style.css file doesn’t update the merged files.
    So you could save the theme settings to force re-building the merged file, if the button is not clickable, try adding a blank space into the Quick CSS field to activate the button.

    For best results, try disabling the merged css & js, and disable any caching plugin, and enter your css into the “Quick CSS” field while you are creating your site. Once you are done you can move all of your css to the style.css and enable your caching & merging.
    I hope this helps explain what is happening.

    Best regards,


    Thanks for the info Mike. It looks like that’s what the issue was. Is merging those files enabled by default in the latest version of the theme now? I didn’t select that option and haven’t run into it before when modifying the child theme CSS. Also, do I need to disable that for the JavaScript file (which I did) or just for the CSS file since it was just the style.css in the child theme that I am working with. Thanks again for the help.


    Since you are working on css, I would recommend disabling only the css merging, but it won’t harm to disable both.
    I believe that if you update from a pre v4.5 version the option is enabled by default, but once you set the option the next update will follow your setting, that is if you have it disabled the next update won’t enable it.
    The theme will always follow your settings for all options, but if a new option is added the dev team tries to make a good choice.
    Unless there is anything else we can assist with on this issue, shall we close this then?

    Best regards,


    Thanks Mike. That’s good to know. I think everything it all good now. Thanks for the help.


    Hi NicomIT,

    Glad that we could help :)
    Thanks for using Enfold and have a great day!

    Best regards,

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Not Seeing Edits to Child CSS’ is closed to new replies.