Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1072698

    Hi guys,

    I am encountering a series of issues on some pages and the error below (found by testing via whynopadlock) is the strongest thing ever. The site has SSL, so there’s no way the call is made to an http image unless the code forces http.

    Line 728 is the closing div for the cookie consent bar. This didn’t happen with the previous enfold version.

    An image with an insecure url of “http://conversionsciences.com/wp-content/themes/enfold/images/layout/preload-dark-big.gif” was loaded on line: 728 of https://conversionsciences.com/event/digital-summit-austin-masterclass/.
    This URL will need to be updated to use a secure URL for your padlock to return.

    Also, there seems to be a block to jQuery when testing past events (new events cannot be tested as they are not being indexed because most of the elements on the page cannot be loaded for this reason):

    Error
    00:20.655
    Uncaught ReferenceError: jQuery is not defined
    https://conversionsciences.com/wp-content/uploads/dynamic_avia/avia-footer-scripts-e0e8de64b3f6058d7e9657e176725835.js:29

    Note: Adding this URL to the Private content area.

    #1072700

    Hi guys,

    I just disabled the Cookie consent and the SSL error goes away. By the same token, I checked the same event pages on the Staging site and this error does not appear.

    Do you think there was a problem with the Enfold version update from Envato? I can always SFTP a copy. I really need to address the SSL issue fast. (But if I disable the GDPR you won’t be able to see what it happening)

    The jQuery issue does happen on both instances: Live and Staging. And this is a new one. Would you like me to give you the credentials for Staging?

    Let me know,

    Best regards,

    Havi

    #1072718

    One more testing update:

    – Disabled the Calendar plugin, installed a different one, set it up and enabled and the same jQuery issue appears.

    Let me know how I can help.

    Thank you!

    Havi

    #1073698

    Hi havi,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #1074558

    Of course, Victoria!

    Adding them below!

    Please, let me know if there is anything I can help with.

    I did change the Calendar Plugin to make sure that wasn’t it, and it wasn’t. The issue happens with both plugins. You can disable the calendar plugin and re-enable The Events Calendar plugin to test what we have on the Live site, if you want. I have also disabled and enabled the rest of the plugins (feel free to do the same – it’s staging and I never move it to production) to no avail.

    Thank you!!!

    Havi

    #1076828

    Hi,
    Sorry for the late reply, I took a look at your staging site and tried to recreate the error.
    I see that your Enfold “Cookie Consent Message” is active, and I disabled your “Events Manager” plugin so that I could enable your “The Events Calendar” plugin but I don’t see the jQuery error or the mixed content error.
    What did I miss in recreating your error?

    Best regards,
    Mike

    #1078863

    Hi Mike!!

    Let’s split this into both issues:
    1- Cookie Consent Message: It works on Staging, calling the image as https but not on the Live site (which is why i Had to disable to cookie consent message) We can coordinate and I can re-enable it so you can see it happening.

    2- The easiest way to visualize the block to jQuery (no matter which Calendar plugin is enabled) is by looking at the footer. The social media icons and links do not display on the calendar pages’ footer. Hope this helps!

    Thank you!!

    Havi

    #1078979

    Hi,
    I see that your social icons are a shortcode in a widget, and we have been having an issue with that. I believe that I have a fix for it but I will need ftp access to try. Please post ftp access in the Private Content area.

    Best regards,
    Mike

    #1079214

    Hi Mike,

    Certainly. I am sharing the SFTP access for the Staging site in the Private Content Area. But later, you will have to provide me with the changes as I need to manually apply them to the Live environment. This site cannot be pushed to Production.

    Also, what would you like me to do regarding the Cookie Consent calling an http file and breaking the SSL? Would you like me to enable it on the Live site so you can see? It may have something to do with the update from ThemeForest as this makes no sense that it would happen on the Live environment and not the Staging site, right?

    Thank you,

    Havi

    #1079303

    Hi,
    Thank you for the FTP access, I renamed your current theme to “enfold-old” then I uploaded the new “enfold” and checked that your site is working correctly, that is your social media icons and links do display in the calendar pages footer so I’m thinking that this is a success. Please also check for yourself.
    You, (or I) can delete the “enfold-old” via ftp, (not the WP theme page) if you wish.
    Should for some reason you wish to roll-back to the old version, it’s easy to do, simply rename the new “enfold” to “enfold-new” via ftp and then rename “enfold-old” to “enfold” then refresh your page.
    To update your live site you can copy the new “enfold” theme folder and try following the same steps, that is rename your current theme to “enfold-old” so that you can “roll back” if it causes problems.
    Another option is to wait for the next update to update your live site, I saw a post from the dev team yesterday were they said the next update will be out soon. The update will contain more fixes than what I just uploaded to your staging site.

    As for “the Cookie Consent calling an http file and breaking the SSL”, please enable it so I can see this, or give me access to the live site so I can enable the Cookie Consent to see. It is odd that this is not happening on the staging site.

    Best regards,
    Mike

    #1079313

    Hi Mike!

    You are right!

    It works!!

    I’ll test the rest of the functions… so this is the new version of Enfold? I was thinking that maybe something happened on the automatic update.

    I just enabled the Cookie consent message and the SSL warning has disappeared – checked with Firefox because when I access the site on Chrome or Safari (even after clearing cache and cookies) I cannot see the GDPR message. This is playing tricks on me! (I also had to change the background to white and the font to black because the CSS to make the link text white was not working – and it’s the same you see on the staging site)

    Maybe I should wait until the new release comes out. What do you think?

    Thank you!

    Havi

    #1079321

    Hi,
    This was only a bug fix version, and it’s not the full version. Some people needed a fix for the shortcodes right away so the dev team was trying to help. But if it’s not an emergency I would recommend waiting for the full update.

    Best regards,
    Mike

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.