Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1323975

    Please take a look at https://mommymakeovercenterofny.com/.

    On resolutions under 786px, the slider nav controls are now missing.

    As i yesterday, I edited our child header.php to match 4.8.6.3 which is running on the site. I do remember always having controls before and have “minimal” selected in the controls.

    #1324039

    Hi Ralph,

    Please try the following in Quick CSS under Enfold->General Styling:

    @media only screen and (max-width: 767px) {
    .responsive #top .avia-slideshow-controls a {
      display: inline-block !important;
    }
    }

    Best regards,
    Rikard

    #1324429

    Hi Rikard, thanks for the code but it does not seem to work. I have tried it on 2 separate sites and no luck.

    FWIW, on the site in my first post I am running 4.8.6.3 using a child theme and have header.php from 4.8.6.3 modified with some customizations. On another site, https://swedesboroday.com/, I just updated to 4.8.6.5, replaced layout.css with the corrected one and have no header.php in my child theme (no overrides necessary). Same result on both – no minimal white slider controls any longer on anything below 768px.

    Seems to me this cropped up on 4.8.6.3. Can’t see why the quick CSS entry would not work.

    Any idea how to fix?

    #1324475

    Hi,

    Thanks for the update. Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1324551

    Hi Rikard, as with several of the US-based sites I manage, there is no need whatsoever to to allow non-US based IPs access to the backend. It is my understanding that most of the Kriesi team are located outside the US. Do you have a US-based VPN from which you can connect? Otherwise, Wordfence will immediately block you. I won’t disable WF without client consent and that would take up even more time.

    If you were thinking compression/minifying is at fault, I have gone that route already. None of the sites I manage use the built-in Enfold compression for JS or CSS – a general rule for me. We do use SG Optimizer and I have already deactivated minifying and compression, cleared server cache – and it had no effect on mobile. This was even after adding the quick CSS you sent at first.

    But I did notice something:
    1. https://mommymakeovercenterofny.com/ is using 4.8.6.3 and has a child header based on the 4.8.6.3 header. – no mobile easy slider controls visible.
    2. https://swedesboroday.com/ is using 4.8.6.5 and while the child folder has a custom functions.php file, there is no child header present – no mobile easy slider controls visible. I also added your quick css here.
    3. https://mommymakeovercenterofny.com/ is using 4.8.6.3 and has a child header still present from a version prior to 4.8.6.3 (I did not make any changes yet) – mobile easy slider controls are visible.
    4. https://southerndental.org/ is using 4.8.6.5 and while the child folder has a custom functions.php file, there is no child header present – mobile easy slider controls are visible. Note: we do not us SG Optimizer on this site.

    This is getting a tad complicated – need to find a solution for the mobile easy slider controls. I have several other client sites which must have the slider controls visible for mobile since that is where ~ 90% of web traffic is coming from. The issue only surfaced after updating to 4.8.6.3 and changing any child header to a 4.8.6.3 version. As I noted above, we have a bunch of sites on 4.8.6.3 but have not yet updated the child header and the mobile slider controls ARE there. Stranger yet is the dental site I mentioned, which is on 4.8.6.5 and no SG Optimizer, looks fine.

    I had also deactivated SG Optimizer on https://swedesboroday.com/, cleared server and browser cache and still no controls on mobile easy slider. I think this shows it is not the plugin at issue.

    • This reply was modified 1 week, 5 days ago by  manhattanctr.
    • This reply was modified 1 week, 5 days ago by  manhattanctr.
    • This reply was modified 1 week, 5 days ago by  manhattanctr.
    #1324654

    Hi,

    Thank you for the update.

    The slider navigation is disabled on mobile devices by default. The following css code hides it.

    .responsive #top .avia-slideshow-controls a {
        display: none;
    }
    

    You can override above css rule by adding this code in the Quick CSS field.

    @media only screen and (max-width: 767px) {
        .responsive #top .avia-slideshow-controls a {
           display: block !important;
        }
    }
    

    This is the result when we add the above css code or when we adjust the display property of the navigation directly in the browser.

    Result: https://postimg.cc/47qzdXY5

    Best regards,
    Ismael

    #1324710

    Hi Ismael, thanks for following up. This is very unnerving and it needs to be solved.

    The override css both you and Rikard suggested to use was already entered in the Quick CSS so it should have been there already. Was it there already or not? If not there is a huge problem where quick css is not flowing to the theme. If is was already and you just used developer tools to view the phone screen, we also have a problem – because I do not see what you saw.

    In what Enfold file exactly is the following code you said controls visibility? I am going to remove it and see what we get.
    .responsive #top .avia-slideshow-controls a {
    display: none;
    }

    Who decided it was a good idea to hardcode this in? The user should decide this. A control would have made more sense.

    #1324856

    Hi,

    The css rule is in the enfold/config-templatebuilder/avia-shortcodes/gallery_horizontal/gallery_horizontal.css file, around line 145

    /* Mobile Landscape Size to Tablet Portrait (devices and browsers) */
    	@media only screen and (max-width: 767px) {
    		.responsive #top .avia-slideshow-controls a{display:none;}
    /* more css rules here*/
    }
    

    Are you using a plugin to minify the stylesheets? You may need to disable the option temporarily, or just make sure to hard refresh the page before checking.

    Do you have other css in the Quick CSS field? It is possible that there are invalid css code in that field such as missing curly braces or semicolons, which might be the reason why the changes are not reflecting.

    Best regards,
    Ismael

    #1324909

    Thanks for the info Ismael. The Quick CSS was entered properly. CSS Minification has always been on but no CSS combination. This has been this way for over 2 years – no reason why all of a sudden it should not work – unless your folks changed something which breaks it. But, giving Kriesi the benefit of the doubt, I completely disabled SG Optimizer plugin so nothing whatsover got optimized, flushed server and browser cache – and got the same thing no mobile controls. So it it apparent the Quick CSS does NOT override the css in gallery_horizontal. You might want to have the devs check into this – I have never seen this before in Enfold. If it is an intended dev action, would like to know why. In unintended, hope a fix is worked up – Enfold-invested in way too many sites to lose Quick CSS functionality.

    I removed .responsive #top .avia-slideshow-controls a{display:none;} from gallery_horizontal and the controls are now present. This is why I asked where the code was. Apparently the disabling of mobile controls is something new? Starting with 4.8.6.3?

    #1325195

    Hi,

    Thank you for the info.

    So it it apparent the Quick CSS does NOT override the css in gallery_horizontal.

    This is working correctly on our installation. The slideshow controls display back on mobile view when we add the css in the Quick CSS field, which means that it has overridden the default style. There might be a plugin option in your installation that excludes the content of the Quick CSS field or that prevents it from loading properly.

    Best regards,
    Ismael

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.