Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #946747

    I have a site with a home page built using ALB that starts off with a Special Heading then an Easy Slider.

    If I set Disable Template Builder Elements to “Load only used elements” these first two elements are ‘switched off’ and the following text displayed in two boxes in their place.

    Admin notice for:
    Special Heading
    This element was disabled in your theme settings. You can activate it here:
    Performance Settings
    
    Admin notice for:
    Easy Slider
    This element was disabled in your theme settings. You can activate it here:
    Performance Settings

    Contact Form is not displayed either.

    The way I understand this new function, it is supposed to interrogate the page to see what’s on it, then just load what’s used. But it isn’t working on one site.

    However… it is working on the test site. The setup of the Performance tab is identical on both sites. The only difference is that the test site is standard HTTP whereas the ‘proper’ site – where the elements get disabled – is HTTPS. Could SSL cause this problem? I suggest someone tests this out.

    #947650

    Hey zimbo,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply. Also please point out where we can see and reproduce the problem.

    Best regards,
    Rikard

    #947879

    In private content.

    On the www site, change Enfold > Performance > Disable Template Builder Elements to “Load only used elements”, refresh the home page and the Special Heading and Easy Slider are gone. Change it back to load all elements, refresh, elements re-appear.

    The dev site is currently set to “Load only used elements” and the elements display correctly.

    #947883

    Same problem here with Load only used elements. Two Boxes show with the information that This element was disabled in your theme settings. You can activate it here:
    Performance Settings

    #948538

    Hi zimbo,

    I see all the settings set to “Load only used elements” and merge files and do not see the issue on the front page. Can you please describe the exact steps to reproduce the issue? (I was checking on the dev site).

    Best regards,
    Victoria

    #948653

    @victoria – the dev site on normal HTTP is OK. It is the www site on HTTPS that has the problem but you need to login and change the Performance setting from its current setting of “Always load all elements” to “Load only used elements” then refresh / clear cache the home page. The www site is set to “Always load all elements” because it is a ‘live’ site – so please alter the Performance setting back as quickly as you can after viewing the problem.

    You can see the problem here.

    #949372

    Hi,

    There are two Enfold folder in the live site. Please remove the old version to avoid conflict. Let us know if that helps.

    Best regards,
    Ismael

    #949525

    That appears to be the problem. Having deleted the enfold-old directory, the “only used elements” function now works. Thanks.

    #949762

    Similar problem here. When I set enfold to “load only used elements” I get errors:

    “Special Heading
    This element was disabled in your theme settings. You can activate it here:
    Performance Settings”

    I”m using a child theme and my website is https only

    #949801

    • This reply was modified 3 years, 7 months ago by  Steve.
    #949929

    Hi!

    @steve: Make sure that there is only one instance of the Enfold parent theme inside the wp-content > themes folder.

    Regards,
    Ismael

    #949946

    Hi Ismael, yes, there is only one!

    #950143

    @ismael – I’ve just updated another 2 client sites (www and dev versions) to Enfold 4.3 and set both to “Load only used elements”.

    Headline Rotator and Easy Slider are no longer displayed on both. Both sites only have an enfold and enfold-child directory in wp-content\themes (plus twentyfifteen).

    Both sites are HTTP, not HTTPS. I’ve left the dev site home page showing the ‘missing’ elements. Site address in private. I’ve had to switch the www site back to load all elements.

    #950747

    For some reason the dev site is now working. However the www version still has the problem. I’ve created a user for you to login and check this. Site is running 4.3.1.

    This is a live e-commerce site. If you make the change to Disable Template Builder Elements to see the problem PLEASE alter the setting back as soon as possible so that the home page displays correctly.

    #951235

    Hi,

    @zimbo: Did you update the theme manually via FTP? Please check if there are duplicated shortcode files in the config-templatebuilder > aviashortcodes folder. If there is, remove the whole directory and replace it with the current version.

    Best regards,
    Ismael

    #951336

    HI Ismael, I have deleted the theme and replaced with new, so there should be no issues there. I have also checked. It appears to be no duplicated files in config-templatebuilder > aviashortcodes folder.

    #951689

    I updated the theme via Updates, not via FTP. I have checked the directories you reference and there are no duplicated files.

    #951893

    Hi,

    Can you please provide us with FTP details so we can access and try to see what happen?

    Best regards,
    Basilis

    #952102

    In private.

    #953081

    Hi,

    @zimbo: The option is set to “Load only used elements” but I don’t see the issue on the home page. Is this fixed? (see private field)

    Best regards,
    Ismael

    #953358

    @ismael – please review the previous posts in this thread. The site with the problem now is different to my first post. Your suggestion about having 2 enfold directories solved the problem on https://www.americanroadtrips.net. The continuation of this issue is now with another domain, http://www.jacksgallery.co.uk. There are 2 sites, www and dev, of this as well. The www site is set to “Always load all elements”. If you login (details provided earlier) and alter it to “Load only used elements” and refresh the home page you will see that the Headline Rotator and Easy Slider are no longer displayed. This is the problem.

    Please note the request above that this is a live e-commerce site and if you make the change to Disable Template Builder Elements to see the problem PLEASE alter the setting back as soon as possible so that the home page displays correctly.

    (NB. Initially both the www and dev sites displayed this behaviour but for some reason the dev site ‘fixed’ itself. No idea why.)

    #953646

    Thank you for this solution!! It worked perfectly for me!!

    Warmly,

    Havi

    #954199

    Hi,

    Thank u for updating us and letting us know.

    Best regards,
    Basilis

    #956608

    Sorry for the delay but I have been away for most of last week.

    Has someone changed or fixed something on http://www.jacksgallery.co.uk? Because I’ve just altered Disable Template Builder Elements to “Load only used elements” – and now the home page displays correctly. I have not altered anything on that website since my post #953358, 6 days ago (as mentioned, I have been away and not worked on this issue until today).

    What’s changed? Why is this now working?

    #957900

    Hi,

    Did you update the page after the upgrade? Please set the builder to debug mode and then edit the pages with the issue. Below the advance layout builder, you should see the Enfold Shortcode Parser option. Set it to the third option (autorepair) and then update the page to regenerate the shortcode tree.

    // https://kriesi.at/support/topic/debug-builder/

    Best regards,
    Ismael

    #958163

    As I said, I hadn’t changed the home page at all for 6 days since the post on May 8. Simply made the change on May 14 to “Load only used elements” – and the home page then displayed correctly.

    I’ve done what you suggested above and after a page update get the message – “No errors were detected parsing the shortcodes.” Refresh of the home page and it still shows OK.

    I’m not sure how we can progress this anymore as the problem has gone away. I’ve just updated the site to 4.3.2 via manual FTP and everything is OK. I can only assume that, whilst the site doesn’t use a caching plugin, maybe the hosting provider had somehow kept or not deleted some theme files immediately when I updated as this file duplication seems to be what you point at as causing this issue, and that eventually the files did get removed and the problem ‘fixed itself’.

    Happy to try something else if you think it will help but without having the problem manifest itself again or be re-creatable, I think we’re stuck.

    #959558

    Hi,

    Thanks for the update. Let us know if you encounter the issue again. We’ll close this one for now.

    Have a nice day! :)

    Best regards,
    Ismael

Viewing 27 posts - 1 through 27 (of 27 total)

The topic ‘New Disable Template Builder Elements function not working’ is closed to new replies.