Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1272969

    Can you please help me install the correct theme files that will help prevent the error I faced. When I updated PHOP to 7.2, I started getting fatal errors. Some of these are pasted below and of course i have no idea what they mean. My Internet Host has kindly rolled me back to this bvery olkd PHP so my website can start working again biy they said the theme authors need to recticy the modules so that they become complienta with the latest PHP.
    Can you help me please thank you
    Below is what the Internt technician wrote, aftr he had upgraded to PHP 7.2 :

    I have checked your website’s error log and I was able to find the below:

    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] Stack trace:
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #0 /home/sites/explainervideohive.com/public_html/wp-includes/class-wp-hook.php(286): avia_style_generator->create_styles(”)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] PHP Fatal error: Uncaught Error: Function name must be a string in /home/sites/explainervideohive.com/public_html/wp-content/themes/enfold/framework/php/class-style-generator.php:123
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #1 /home/sites/explainervideohive.com/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #2 /home/sites/explainervideohive.com/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #3 /home/sites/explainervideohive.com/public_html/wp-includes/general-template.php(2668): do_action(‘wp_head’)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #4 /home/sites/explainervideohive.com/public_html/wp-content/themes/enfold/header.php(49): wp_head()
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #5 /home/sites/explainervideohive.com/public_html/wp-includes/template.php(704): require_once(‘/home/sites/exp…’)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #6 /home/sites/explainervideohive.com/public_html/wp-includes/template.php(653): load_template(‘/home/sites/exp…’, true)
    explainervideohive.com [Sat Jan 16 17:18:18 2021] [error] #7 /home/sites/explainervideohive.com/pub in /home/sites/explainervideohive.com/public_html/wp-content/themes/enfold/framework/php/class-style-generator.php on line 123

    This seems to me to be an issue with your themes and plugins. I would advise you to re-install them one by one to find which one is causing the issue.

    #1273092

    Has anyone had a chance to look at this for me? Basically, please help me update the theme to a version that is stable with PHP 7.2 as the one I am running now is no longer up to date and safe

    • This reply was modified 3 years, 4 months ago by bvenge.
    #1273124

    Hi bvenge,

    Please confirm that you have a full website backup ready before we can attempt an update.

    Best regards,
    Victoria

    #1273150

    Hi Victoria,
    Many thanks for your response
    yes I have backed up the files
    Please proceed to update the theme to a version that can handle PHP 7.2
    Also please let me know when doen
    many thanks
    Brian

    #1273287

    Hi Victoria,
    Please confirm if you’ve done the update
    It is still saying version 3.3.2

    Thanks in advance
    Brian

    #1273396

    Hi Brian,

    Best regards,
    Victoria

    #1273405
    This reply has been marked as private.
    #1273414
    This reply has been marked as private.
    #1273625
    This reply has been marked as private.
    #1273874

    Hi Brian,

    Thanks for the updates. Please share FTP login details with us as well, so that we can try uploading the new version of the theme there instead.

    Best regards,
    Rikard

    #1273944
    This reply has been marked as private.
    #1274155

    Hi Brian,

    We updated the theme for you, please check.

    Best regards,
    Victoria

    #1274159

    Thank you very much
    I appreciate
    Can I update this to PHP 7.2?

    #1274204

    Hi bvenge,

    Yes, sure :)

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.