Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #808498

    Hello,

    iPhones have an issue with the multi-select. It doesn’t register selecting the first option. A solution is to add an hidden disabled optgroup in front of the real options. Solution seen here: https://stackoverflow.com/a/38718088/2834896

    How can I edit this into the contact form element for Enfold?

    EDIT: This is an issue with time pressure since a client is waiting on a fix. As you can see this is a widespread iOS problem: https://discussions.apple.com/message/31789176#message31789176

    • This topic was modified 10 months, 1 week ago by  dirkvisser. Reason: I would like an update on this problem
    #808881

    Hello,

    I’ve been waiting for response from the support team for quite a while now.. Anyone working on this?

    #809666

    Hi,

    Thank you for using Enfold.

    Please try this code in the functions.php file.

    function ava_custom_script_mod(){
    ?>
    <script>
    (function($){
    	function e() {
    		$('#top select, #top .avia_ajax_form .select').prepend('<optgroup disabled hidden></optgroup>');	
    	}
       	
       	e();
    })(jQuery);
    </script>
    <?php
    }
    add_action('wp_footer', 'ava_custom_script_mod');

    Best regards,
    Ismael

    #809695

    Hello Ismael,

    That worked perfectly, thank you very much!
    Will this fix get into a future update of Enfold or do I have to use this fix whenever I have a client with a multi-select field?

    #810290

    Hi dirkvisser,

    Glad you got it working for you! :)
    We don’t have an answer to that question, but I would suggest using a child theme to not loose this modification.
    If you need further assistance please let us know.

    Best regards,
    Victoria

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.