Viewing 30 posts - 1 through 30 (of 47 total)
  • Author
    Posts
  • #848278

    We are having issues with menus on mobile enfold sites. The menu is not providing the drop down pages.

    Even our own main site is having these problems…

    What are we missing in our setup or how to we correct this problem… I think it is happening on every site we are using Enfold.

    Avery

    #848759

    Hey So Evolve,

    This a known issue, the fix is coming soon. Meanwhile, here is a thread about it with a few temporary fixes
    https://kriesi.at/support/topic/sub-menu-do-not-appear-in-mobile-menu-since-4-1/

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #848821

    I’ve tried each of the temp fixes with zero success. I’m sure you are aware of the severity of this issue as over 65% – 80% of our clients are using mobile devices to search out our clients.

    We could use a ETA on this major issue being fixed so we can map out a permanent solution if required.

    Thanks for your assistance.

    Avery

    #849302

    Hi,

    The release will be published soon, as there are many changes and fixes that Kriesi is working at.
    The solution that Victoria suggested does work for now, as we have implemented for other users also.

    Best regards,
    Basilis

    #849311

    My mobile display is a mess, images not showing, menu’s not working, sizes of images are either too big or too small.
    The last update was a no go.

    #849527

    Hi,

    Try flushing out cache, as it might be causing the issue.

    Best regards,
    Nikko

    #849641

    Nikko,
    Hey, FYI your groups support has always been tops, but this response was the worst! “try flushing your cache” is a quick BS answer to a big problem with the enfold theme.

    Please provide an update as to when this will be fixed. I do believe you have a lot of theme users that are having this MAJOR problem and need to know status for a Fix!!!!!!!!!!!!!!!!!!!!!

    Avery

    #849884

    Hi Avery,

    Please see private.

    Best regards,
    Rikard

    #851203
    This reply has been marked as private.
    #851380

    Hi Avery,

    The process would be the same as updating manually via FTP, you can find instructions here: http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Rikard

    #852693

    This version does offer the submenus but they are showing transparent…
    We were able to remove “Quick CSS” on one project but everything else is showing up Transparent

    What’s the fix

    Avery

    #852715

    This has been “coming soon” for months now. This is like waiting for paint to dry. Disappointed in Enfold. :(

    #852739

    I’m confused… I see a new empty burger menu on my site (three lines below my menu items) that wasn’t there before… how do I make it go away? And now I have no menu whatsoever on my mobile version.
    The file linked in that tread Victoria pointed us to has expired.

    • This reply was modified 6 years, 10 months ago by geckonia.
    #853670

    Hi,

    We are having issues with menus on mobile enfold sites. The menu is not providing the drop down pages.

    Are you referring to the “Services” menu item? The menu contains empty mega menu columns and by “empty”, I mean that the columns do not contain sub menu items. Please note that the new menu script will not render empty mega menu columns. You have to add a sub menu item to it. Do not treat the mega menu columns as actual menu items, only use it to separate group of menu items. We know that this is not how it works before but these changes are necessary to improve the menu.

    Best regards,
    Ismael

    #853808

    Do you have an estimated date for this issue to be fixed please?
    In the meantime, should we be implementing the temporary solutions?

    #854534
    This reply has been marked as private.
    #854865

    Hi So Evolve,

    I totally feel your pain and all of the above is reasonable. The code with the fix is in the repo already, but I don’t have the ETA for when it is released. Please bare with us and sorry for all the inconvenience.

    Best regards,
    Victoria

    #856621
    This reply has been marked as private.
    #857144

    Hi,

    We are still working on that fix and some more stuff that have to be done.
    We appreciate your patience – if you still in huge rush and cant wait we can try send some of the code but as it is not fully tested, we keep our promises low.

    Best regards,
    Basilis

    #857227

    Any updates I just did this update and now I’m sorry I did. We have sub-menus. I need them, Our site is large.

    So what do I do now? Revert? meaning now I can’t even run my online store. This is quite pathetic considering this is like 2017 and MOBILE IS EVERYTHING.

    #857369

    Hi Alisa,

    I replied to your other thread already, let’s keep communicating in that for your problem.

    Best regards,
    Rikard

    #859850
    This reply has been marked as private.
    #859864

    It’s now been another week. With respect, this needs to be fixed soon. The temporary fix quelled my clients for about a week until they found out when you click on the top level of a navigation section, you get a blank page.

    #860004

    Hi @spidercreations,

    Can you create another thread with your details? This way, we can help you better.

    Best regards,
    John Torvik

    #861134
    This reply has been marked as private.
    #861327

    Sorry to be direct but the time has come to say this —

    It is really sad what has happened to Enfold. Has this theme been abandoned? We now see maybe 1 or 2 small updates a year, mainly focused on building demos to sell more themes, but without real enhancements that would add more user functionality. This menu “enhancement” in the update months ago has been a disaster but the fact that users are begging for updates / fixes is not consistent with my years of using Enfold. In the past this would have been addressed in days or weeks, not months.

    What has happened to Enfold? Is Kriesi perhaps ill or has a new baby and cannot work on it like he did before? Something has definitely changed.

    #862647

    Hi,

    Thank god – Kriesi is not ill.
    A Baby on the other hand would be more than welcome, right? :D
    Before summer kriesi released a big update, with reconstructing all the menu, rebuild all the header with new hooks and filters and created some nice new features like the tabs.

    There are many new bugs have been worked to be solved, there are a lot of new updates ( yesterday on facebook group, we have announced the new shortcode regarding an audio player ).

    We understand that you are eager to see new stuff and we respect that a lot. Kriesi and the rest of the development team are working to push new things every time, but as you have understand we have a good release cycle and mostly a cycle that is as bug-safe as possible.

    Yes you are right, the menu is a bug issue but we have provided an alternative really quick for everyone.

    I have forward your feedback also to Kriesi, it is always inspirational to have a motivation!

    Best regards,
    Basilis

    #865941

    FYI
    All support needed to say on this thread was;

    Go to Enfold Theme:
    1) Main Menu
    2) Burger/Mobile Menu Tab
    3) Menu Icon Submenu items
    4) Select “Always display submenu items”

    At least my clients would not have been losing traffic from mobile visitors during this long Enfold Theme Fix…

    I had to dig through everyone else’s treads/support tickets to get the above answer for a temp solution for our client’s mobile version of the enfold theme!

    Sorry guys, you have been a 10 on the support of the enfold theme but with this one, I’ll give you a 1…

    Hoping for a real quality update… with the longterm fix!

    Avery

    • This reply was modified 6 years, 9 months ago by So Evolve.
    #866389

    What So Evolve listed is fine, but in our case we want the burger menu to expand the sub menu items on hover. Steps as follows:

    1) Main Menu
    2) Burger/Mobile Menu Tab
    3) Menu Icon Submenu items
    4) Display submenu items on hover (we are using the flyout menu classic)

    On a mobile phone hover is more like ‘tap’. The burger menu is so touchy that when we try to expand the sub menu items it navigates to the parent item that was ‘tapped’ and the menu collapses. We certainly can’t expect a mobile visitor to tap on the far right to avoid selecting the menu item. What do we do? On our site the parent items are actual links (not #) and we are NOT using mega menu. Just a simple menu tree.

    We are up-to-date on the latest version of Enfold. I have not downloaded and applied any .js as suggested in previous posts. The ‘herky-jerky-ness’ of the mobile menu leads me to believe this is a .js issue. Any suggestions?

    #866919

    Hi,

    @GWS: We can reproduce the issue with the “submenu hover” settings. Please edit the js > avia.js , look for this code around line 1857:

    		//toogle hide/show for submenu items
    		$('.html_av-submenu-display-hover').on( 'mouseenter touchstart', '.av-width-submenu', function (e)
    		{
          $(this).children("ul.sub-menu").slideDown('fast');
    		});
    
    		$('.html_av-submenu-display-hover').on( 'mouseleave touchstart', '.av-width-submenu', function (e)
    		{
          $(this).children("ul.sub-menu").slideUp('fast');
    		});
    

    Add the stop function to keep the submenu container from sliding up and down.

    		//toogle hide/show for submenu items
    		$('.html_av-submenu-display-hover').on( 'mouseenter touchstart', '.av-width-submenu', function (e)
    		{
          $(this).children("ul.sub-menu").stop().slideDown('fast');
    		});
    
    		$('.html_av-submenu-display-hover').on( 'mouseleave touchstart', '.av-width-submenu', function (e)
    		{
          $(this).children("ul.sub-menu").stop().slideUp('fast');
    		});

    And then look for this line, right below the first one.

    $('.html_av-submenu-display-click').on( 'click', '.av-width-submenu > a', function (e)
    

    Replace it with:

    $('.html_av-submenu-display-click, .html_av-submenu-display-hover').on( 'click', '.av-width-submenu > a', function (e)
    

    This fix should disable the parent menu items’ link. Remove browser cache or hard refresh before checking the page.

    Best regards,
    Ismael

Viewing 30 posts - 1 through 30 (of 47 total)
  • The topic ‘Mobile Menu – Not Showing Drop Down (sub pages)’ is closed to new replies.