Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #837524

    Hi, when I move an Enfold site from localhost to a live server I always find that many images are missing and show a question mark in their place. I can usually resolve this by clicking edit, which shows the images and re-saving but often images are missing from Layersliders which is always awkward and annoying.

    Can you please share with me the best way to ensure that all image paths move from localhost to server addresses?

    The annoying thing is that on the server when I look at an image in the media library it does show the full server URL and not localhost but the image is usually missing. If you could tell me the best way as suggested by you to avoid this I would be grateful.

    Thanks,
    John

    #837874

    Hey johnmac1967,

    I’m not sure what could be causing that, it could be almost anything. What are you using to transfer the site? Maybe you could look for an alternative?

    Best regards,
    Rikard

    #837965

    Thanks for the reply. I simply zip the site, upload it to the server and unzip. Go to phpMyAdmin and import the DB. Change site URL in wp-options and then add in the DB info to the wp_config file.

    I do it this way for all WordPress sites and only Enfold has the missing image problem. Even using Velvet Blues URL replacement pluggin doesn’t work fully. All images set within text blocks are missing every time. Often images in Layersliders are missing too.

    I’m using Mamp on the Mac when working locally.

    Thanks again for your help.

    #839681

    Hi,

    Go to phpMyAdmin and import the DB. Change site URL in wp-options and then add in the DB info to the wp_config file.

    That process is not going to change the attachments’ or images’ url. The database has to be imported properly with a plugin so that you don’t have to manually change the attachment or image url. Please try the following plugin.

    // https://wordpress.org/plugins/wp-migrate-db/

    Best regards,
    Ismael

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.