Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1154230

    Hello team,

    I would like to insert a button (image) in the menu. In general we have a transparent menu that turns white when scrolling.
    This means that I need two images with different colors. In the back-end I inserted the following code in the menu:

    <img src="image.png" width="30" height="30" />

    This is displayed correctly in the menu. How can I now call up the other image source so that the other image is loaded when scrolling?

    Thanks in advance-
    kind regards!

    • This topic was modified 1 week, 4 days ago by  marketingnr1.
    #1154460

    Hey marketingnr1,

    If you add the image as a background-image of a div instead than you can switch the image via css after the site scrolls.

    Best regards,
    Jordan Shannon

    #1154617

    Hey Jordan,

    thanks for your info, do you have any css code for me, i do not really know what you mean.

    Kind regards.

    #1154800

    Hi,

    Please provide a link to the site/page in question so we can look into this further.

    Best regards,
    Jordan Shannon

    #1154887

    Hey Jordan,

    yes of course, thanks for helping in advance!

    It’s about the login male icon in the menu. When scrolling the icon should turn grey.
    The file is the last picture in the media.

    Kind regards

    • This reply was modified 1 week, 2 days ago by  marketingnr1.
    #1154966

    Hi marketingnr1,

    Here is the code you can put in Enfold > General Styling > Quick Css,  if it does not work, put into themes/enfold/css/custom.css

    
    .header-scrolled #menu-item-8257 .avia-menu-text img {
        filter: grayscale(1);
        -webkit-filter: grayscale(1);
    }
    

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1155027

    Hey Victoria,

    it does not work.

    Kind regards

    #1155116

    Hi,

    Did you add the code to the very top of quick css so it runs first. Also, clear the cache a few times over so it runs first.

    Best regards,
    Jordan Shannon

    #1155427

    Hello,

    yes, now the code is in the custom css. I cleared the cache several times.

    Kind regards and thanks in advance

    #1155582

    Hi marketingnr1,

    Can you disable caching and minification for now?

    Best regards,
    Victoria

    #1155759

    Hello,

    i disabled caching and minification, it also does not work..:(

    #1156604

    Hi,

    Thank you for the update.

    Did you remove the button (image)? We are able to access the dashboard using the account above, but it doesn’t have admin rights, so we can’t edit the settings or the css code. Please set the account’s user role accordingly. We will check the thread again after.

    Best regards,
    Ismael

    #1156712

    Hello team,

    now the admin permissions are changed.

    Kind regards and thanks in advance!

    #1157664

    Hi,
    Sorry for the late reply, I was able to login, and I see your two icon images in the media library, but I’m not sure which menu item this should be for on the homepage, or if it’s for a different page, please advise.

    Best regards,
    Mike

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.