Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #820867

    I have noticed that whenever I use a media element from the theme builder, like an image slider, the images elements are output with http rather than https. This only happens when using the theme builder. Everything else on the site is setup for SSL correctly and works as it should. But when I add a new page or product that uses a media element from the builder, save the draft or publish, I then have to go and do a search/replace in the database to fix the mixed content issues.

    Not sure what the easiest fix would be, but logically it would be to either have the theme reference what is set in the site options for the site URL, or to have an option in the Enfold settings to toggle on an SSL mode for all elements.

    #821213

    Hey Kahil,

    You could use a plugin

    http://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #821336

    I am using a plugin. The point is that I shouldn’t have to. Other themes handle SSL ok. Loading up yet another plugin just adds to the site load. The theme should be able to respect SSL when it comes to media and scripts.

    Telling people to go use a third party plugin to fix a bug in your own product doesn’t help.

    Again… When it comes to an SSL site, media elements from the page builder are pointed to using http rather than https. Same goes for all the scripts and CSS loaded in the header and footer. This is a simple fix on the developer’s part. Just has to tell everything to load with respect to what is in the site settings for the frontend URL.

    #821347

    Hmm this is very strange. I’d say it’s not a theme issue as I run ssl on my site and everything works fine.
    All .js and .css files are https and all images are loaded over https without any issues at all.
    No plug in needed either.

    There are ways to force all pages and resources to load over https.

    It’d be interesting to “inspect” your pages to see what erros are thrown up

    TJ

    #821356

    It is definitely a theme thing. If I add media like an image using the built in WordPress method, I get https. If I use the theme builder to load up something like an image slider, the images are output with http.

    I also noticed that all of the CSS and scripts for the theme were being output in the header with http. So for me to ensure that all elements load with https and I get the green padlock icon, I have to use yet another plugin to force the https….or do a database search and replace regularly.

    • This reply was modified 6 years, 9 months ago by Kahil.
    #821709

    Hi Kahil,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.