Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #968705

    Hi,

    Help fix this bug please

    Media Elements > Masonry Gallery: Flexible Masonry – when viewing a image title displayed, Perfect Grid and Perfect Automatic Masonry – when viewing a image title not displayed.

    See Private Content for details.

    Thanks in advance.

    #970472

    Hey sckye,

    Can you please put just one masonry on the page and see if the issue remains?

    Best regards,
    Victoria

    #970481

    You’re welcome.

    See Private Content for details.

    #971107

    Hi sckye,

    Thank you for doing that, I thought there was JavaScript conflict, but the reason is different.

    Best regards,
    Victoria

    • This reply was modified 3 years ago by  Victoria.
    #971148

    And this must be fixed. It is necessary to make all the titles displayed, as it was before.

    In version 4.2 titles displayed in Flexible Masonry, Perfect Automatic Masonry and Perfect Grid.

    In version 4.4.1 titles no longer displayed in Perfect Automatic Masonry and Perfect Grid.

    Enfold 4.2

    Masonry Gallery > Flexible Masonry (title is displayed)
    Masonry Gallery > Perfect Automatic Masonry (title is displayed)
    Masonry Gallery > Perfect Grid (title is displayed)
    the images were in

    <div class="av-masonry-outerimage-container"><div class="av-masonry-image-container" style="background-image: url(https://site.com/wp-content/uploads/2012/04/2-1-705x458.jpg);"><img src="http://site.com/wp-content/uploads/2012/04/2-1-705x458.jpg" title="Perfect Grid 01" alt="Perfect Grid Image 01"></div></div>

    Enfold 4.4.1

    Masonry Gallery > Flexible Masonry (title is displayed)
    the images were in

    <div class="av-masonry-outerimage-container"><div class="av-masonry-image-container"><img src="http://site.com/wp-content/uploads/2012/04/2-1-705x458.jpg" title="Perfect Grid 01" alt="Perfect Grid Image 01"></div></div>

    Masonry Gallery > Perfect Automatic Masonry (title is not displayed)
    Masonry Gallery > Perfect Grid (title is not displayed)
    the images were in

    <div class="av-masonry-outerimage-container"><div class="av-masonry-image-container" style="background-image: url(https://site.com/wp-content/uploads/2012/04/2-1-705x458.jpg);"></div></div>

    See Private Content for screens.

    #971268

    Hi sckye,

    Thank you for bringing this up.

    I reported this issue to our devs, they’ll work on it whenever they can.

    Best regards,
    Victoria

    #977936

    Hi,

    Thank you for reporting this.

    It should be fixed with the next update.

    Meanwhile you have to update file

    enfold\config-templatebuilder\avia-shortcodes\av-helper-masonry.php

    Please replace the complete file with

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_4_1/av-helper-masonry.php

    Make sure to make a copy of the original file to have a fallback and that you are using Enfold 4.4.1.
    Do not forget to clear browser and server cache after the update.

    If you have problem we can do the update for you.

    Best regards,
    Günter

    #977968

    Hi,

    Replaced file but it didn’t help.

    See Private Content for login credentials.

    #980764

    Hi,

    Sorry for the delay reply – is the issue fixed?

    Best regards,
    Basilis

    #980767

    Unfortunately no. File replacement did not help.

    #983131

    Hi,

    I did loged in, but it seems you have restored the file?
    Any specific reason, something broke?

    Best regards,
    Basilis

    #983139

    Hi,
    No, nothing’s broken. Now in enfold\config-templatebuilder\avia-shortcodes\
    lies the file av-helper-masonry.php that Günter gave me and this new file did not help in solving the problem.

    • This reply was modified 2 years, 11 months ago by  sckye.
    #984494

    Hi,

    Did you just rename the old file? You have to remove it completely or store it on a different place. It will still be recognized as one of the shortcodes even if you rename it to something else.

    Best regards,
    Ismael

    #984607

    Hi,
    Ок. Now there is only a file that gave me Günter, but still nothing works.

    #985067

    Hi,

    You have to set the masonry’s “Element Captions” > “Element Title and Excerpt” settings to display the title, excerpt or both. (see private field)

    Best regards,
    Ismael

    #985088

    Hi,

    No, that’s not the point. It is necessary that image thumbnails are displayed on the page without displaying the title and description, but the title is displayed when viewing the image in the lightbox. And everything worked fine in 4.2 and earlier.

    Clicked on the image – saw the title “Test” and thought that everything worked, but no. Previously, information about the image title was taken from the “Title” field and now from the “Caption” field (Screen 3). And if now I remove the “Test” from the “Caption” field – we go back to the beginning of a topic, to that of started all this.

    Masonry Gallery > Flexible Masonry (image title when you open it in lightbox is displayed)
    Masonry Gallery > Perfect Automatic Masonry (image title when you open it in lightbox is not displayed)
    Masonry Gallery > Perfect Grid (image title when you open it in lightbox is not displayed)

    See screenshots in privat content.

    • This reply was modified 2 years, 11 months ago by  sckye.
    #985803

    Hi,

    I see. Thanks for the info.

    We modified line 366 of the av-helper-masonry.php file.

    $linktitle = 'title="'.esc_attr($description).'"';
    

    Replaced with:

    $linktitle = 'title="'.esc_attr($title).'"';
    

    Best regards,
    Ismael

    #985972

    Hi,

    Thank you very much, everything works fine.

    This bug will be fixed with the next update?

    #986202

    Hi,

    Glad it worked. We’ll forward it to the team. Please open a new thread if you need anything else. :)

    Best regards,
    Ismael

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘Masonry Gallery – Image title is not displayed’ is closed to new replies.