Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1236758

    Hi, I have upgraded to WordPress 5.5 and Enfold on my staging site.
    If I go into Jetpack then performance tab then turn on Lazy Load, the masonry gallery loads pictures on top of each other.

    Page with an example of the issue is in private content. If I turn off lazy load then Masonry Gallery works as before.
    In the release notes for it says something about lazy load… is there a configuration I need to perform?
    In Enfold theme settings I have “Enable Lazy Load” turned on.



    Hi goldengate415,
    deactivate once the new LazyLoad from WordPress 5.5

    Snippet in the child functions:
    add_filter( ‘wp_lazy_loading_enabled’, ‘__return_false’ );


    Hi goldengate415,

    Please follow @NIXHALBES instruction.

    @NIXHALBES thanks for helping out :)

    Best regards,


    Hi Nikko,
    Is this a bug in Enfold that will be corrected in a future release? Current release notes mention compatibility for lazy load so I thought this was addressed.
    I don’t do coding and haven’t modified the child theme in many years, and am concerned that mods become problems in the future. I would rather wait for an update to Enfold and would hope this could be flagged to Gunter.



    Hi Rob,

    Thanks for reporting this.

    Enfold uses the WP lazy load logic added with WP 5.5 adding the HTML attribute Loading=”lazy” to images which is supported by modern browsers without any js.

    As we are aware that there are problems with animations and lazy load we disabled it by default for existing sites and you can activate it for each element (option in developers tab) to check, if nothing is broken.

    We had reports for problems with jetpack, lazy loading and broken layout – as jetpack uses js.
    As far as I know jetpack offers a filter to add classes to images to supress lazyloading for these – but this is currently not part of Enfold.

    We have an open issue for that.

    Best regards,


    Hi Günter!

    Thanks for your response – good to hear from you.

    I have read your response several times and I think I am understanding. Right now under advanced developer options lazy load is turned off for masonry gallery on that page (by default, and I have left it off) but by turning on lazy load in jetpack I am overriding that. For now I will leave it off in Jetpack and wait for future updates from Enfold as you work through the issue. It’s not critical at this time for me as it’s just lazy loading and the site works fine with it turned off. I am glad this issue is on your “radar.”

    OK to close thread.



    Hi Rob,

    Exactly. Jetpack is overriding Enfold. ( and probably also WP, because it handles lazy loading for its own with js which will get in conflict with the html attribute).

    If you have time you can keep jetpack lazy loading disabled and enable Enfold lazy loading for each element and check, if a page works as expected – would mean that at least modern browsers can take advantage of this feature – without any overhead of javascript. Older browsers simply ignore this attribute.

    Best regards,

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.