Viewing 30 posts - 1 through 30 (of 41 total)
  • Author
    Posts
  • #550025

    Hi,

    This is my third site using Enfold, it’s a great theme!

    I set up a fresh WordPress installation and installed your theme yesterday. Everything has gone well until now.

    The new site will be using MailChimp but when I generate a new API key and add it, I get the error below:
    Could not connect to Mailchimp with this API Key. Please try again with a different key
    You might also want to check your internet connection and make sure that mailchimp.com is available

    I created new API keys but this did not resolve the problem. I also tried creating a new MailChimp account with new keys.

    Is there a way for me to diagnose and resolve this problem?

    #550140

    I am having the same issue exactly. It’s worked on other Enfold sites, but it’s not working today.

    #550553

    I still have the problem today as well.

    #550748

    Hi!

    Please update to the latest version of Enfold and let us know if that solves any issue.

    Regards,
    Basilis

    #550755

    “No Updates available. You are running the latest version! (3.4.6)”

    I just purchased and installed this fresh a couple days ago.

    #550758

    I have the same problem. My MailChim connected fine yesterday. I have enfold 3.4.6 installed.

    #550983

    For me the same since today. 3.4.6 installed.

    • This reply was modified 4 years, 1 month ago by  keeslamper.
    #551131

    This is an issue with the WP4.4 release. See below. Unless WP fixes it on their end, I believe Enfold would have to work with Mailchimp to apply their temporary fix.

    https://wordpress.org/plugins/mailchimp-for-wp/changelog/

    Ryan

    #551188

    Hey!

    Thanks a lot for the report.
    We have notified Kriesi about the issue, who will check and notify us for a bug fix or possible solution.
    Thanks a lot for your patience and understanding.

    Cheers!
    Basilis

    #551413

    Hi!

    Kriesi would like to have FTP Access & WordPress logins.
    Please create different posts,add your credentials as PRIVATE DATA and link the post here, so we can help you faster.
    Thanks a lot for your time and patience

    Best regards,
    Basilis

    #551444

    Done

    #551451

    Hello I have the same problem, need help!

    • This reply was modified 4 years, 1 month ago by  littlewar.
    #551777

    Just to make sure…this issue has been narrowed down to being a WordPress 4.4 issue and not an Enfold or Mailchimp issue?

    #551801

    Hey!

    Yes, the fix that needs to be applied, is because of the new WordPress version.

    Best regards,
    Basilis

    #551802

    Does that mean that a fix is now available?

    #551877

    Posting with SFTP details for you. (is this still required?)

    I’ll leave the account open a few days or until your response.

    Thanks!

    #552656

    Has this issue been resolved? I am facing the same problem! http://www,tenstep.com.br/tenstep

    #552667

    Since it has apparently been narrowed down to being a WordPress specific issue, then it is safe to assume the issue is a result of a specific file. Has someone figured out which file that is? Is there a temporary, manual fix? It doesn’t comfort users to just get the response of “it is an issue with WordPress and not our product” if supporting info doesn’t follow. What file or aspect of WordPress itself would have anything to do with the Mailchimp API? Other Mailchimp plugins don’t seem to be having this issue.

    More details about the issue would be appreciated.

    Thanks!

    #552674

    All,

    I’m in the exact situation as you. Visit the Mailchimp WordPress page and you will get your answers there. There are workarounds.

    As much as I would like this fixed asap, I remind myself that multiple companies (WP, Mailchimp and Enfold team) have to come together to fix.

    #552730

    Is there a link to this “Mailchimp WordPress” page that has the workarounds? There is no WordPress page on the Mailchimp website that I can find. The mods here are stating it is an issue specific to WordPress, so that would imply that they know exactly what the issue is if they are certain it has nothing to do with the API used in the theme.

    #552734

    https://wordpress.org/support/plugin/mailchimp-for-wp

    WP is the issue. Mailchimp has a workaround for it’s plugin. Enfold will need to incorporate the workaround into the theme.

    Again, we don’t know how all three are working on this behind the scenes. Gotta wait.

    #552739

    Ok…well, here’s the temp fix. Add it do your functions.php file. Don’t know why no one bothered to share it here sooner versus leaving vague responses… just sayin….

    add_filter( 'http_request_args', function( $args, $url ) {
    	// only act on requests to api.mailchimp.com
    	if( strpos( $url, 'api.mailchimp.com' ) === false ) {
    		return $args;
    	}
    
    	$args['sslverify'] = false;
    	return $args;
    }, 10, 2 );
    #552744

    Pretty sure I pointed this out 3 days ago…just saying. However I do agree with you, when they say “upgrade to the latest version.” That drives me crazy.

    #552751

    Yeah…you’re right. A link to a third-party Mailchimp plugin changelog that doesn’t state the temp fix, let alone link to it at any time. That doesn’t help anyone. One has to go through the support forum on WordPress.com for that third-party plugin to find it. But by all means….let’s all give vague answers rather than directing people to the fix to save them time so they can then test on their own. /smh

    Seriously…had someone who knew the answer here shared the following link days ago…there wouldn’t be so many frantic posts here looking for support and a fix.

    https://wordpress.org/support/topic/error-connecting-to-mailchimp-ssl-certificate-problem?replies=22#post-7757098

    #553147

    Where do I find the functions,php file? Which folder is it in? Where exactly would I add this code within the functions, php file?

    Thanks in advance for your help!

    #553937

    Jagrass, go to your WP admin and then to Appearance > Editor. Select the Theme Functions (functions.php) file on the right side. I added the code to the bottom of this file and it allowed me to connect to Mail Chimp.

    However on some devices, the Submit button doesn’t appear under one touches the screen in the area where the button should show.

    #554088

    Tried to load the code as described, but once done and could not access my site anymore. I would receive a ” Parse error: syntax error, unexpected T_FUNCTION in /home/…/subdomain/wp-content/themes/enfold/functions.php on line 520.

    Once I remove the code via FTP, everthing return to normal. I still have the problem, but my site is ok! Thank god! Not sure what happened, any ideas?

    #554091

    I’m glad you were able to get your site back with the FTP workaround. Been there, done that!!

    Dunno what happened… you put the code at the very very end of the file? We are quickly reaching the limits of my tech knowledge :-)

    PS Did you see they are releasing an update with a new version “very soon” ? Hope it is soon.

    • This reply was modified 4 years, 1 month ago by  nancyT.
    #554714

    Thanks Kahil, that sorted the issue for me!

    #557449

    Hey!

    can you guys confirm that the link from kahil offers a solution for you?

    Best regards,
    Andy

Viewing 30 posts - 1 through 30 (of 41 total)

The topic ‘MailChimp API not connecting’ is closed to new replies.