Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1065594

    I know there are already a number of threads about this issue
    I tried to follow them and so far nothing worked

    my problem is on this page –
    the red ‘read more’ links under the team members names use to open a simple text popup
    but after the latest update, something went wrong and it stopped working

    in the chrome console I see the following error:
    Uncaught TypeError: jQuery(...).magnificPopup is not a function

    I already tried updating the code as mentioned in this thread:
    I also verified that the js files are in the right place (in \wp-content\themes\enfold\js\aviapopup\) and that they have the right permissions
    not sure what else can I do?

    can someone help, please?

    also provided FTP and login details in the private content


    Hey Doron,
    Sorry for the late reply, I took a look at your site and found that you had an old “header.php” in your child theme that was not working correctly with the lightbox, so I renamed it to “header.php.old” and uploaded the new header.php
    Then the lightbox was working, but your popups were not showing because your class in the links were not correct and the css was using the same css for the overlay of the lightbox. I corrected one of the team members for you to see the correct way. I fixed the “Chairman of the Board” with no image, you will see it now opens with a white background. The css for this is in the “code block” element at the bottom of the page, because when I tried to add it to your “Quick CSS” it didn’t work, I believe you have css errors in your “Quick CSS” Please try checking this by pasting all of your css into the WordPress > Customize > Additional CSS and look for the errors (red X)

    Best regards,


    Hi Mike
    Wow! your help is above and beyond! I will fix the quirks in the quick CSS right away! thank you so much! I’ve updated the class in the links and now all the popups are now back to work! yessss!


    Glad to hear, thank you.
    Unless there is anything else we can assist with on this issue, shall we close this then?

    Best regards,


    yes you can definitely close this thread
    thank you very much :)


    Glad we were able to help, we will close this now. Thank you for using Enfold.

    For your information, you can take a look at Enfold documentation here
    For any other questions or issues, feel free to start new threads under Enfold sub forum and we will gladly try to help you :)

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Magnificent Popup bug – …magnificPopup is not a function’ is closed to new replies.