Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1270970

    Hello Team,

    Have recently noticed that Code Block containing Magnific Popup has stopped working.
    Running Enfold 4.7.6.4, WP version 5.6 and PHP version 7.4

    Code Block: <div id="more-info" class="gallery-more-info mfp-hide">

    Enfold Child:

    /* Lightbox styling */
    button.mfp-arrow, .mfp-close{
      background-color: rgba(100,100,100,0.8) !important;
    }
    .avia-popup{
      background: white;
      opacity:1 !important;
    }
    button.mfp-arrow{
        width: 50px;
        height: 70px;
    }
    /* Fixing x button position */
    .mfp-zoom-in .mfp-figure, .mfp-zoom-in .mfp-iframe-holder .mfp-iframe-scaler{
      -webkit-transform: none !important;
      transform: none !important;
    }
    button.mfp-close{
      position:fixed;
      top:30px !important;
      right:30px !important;
    }
    
    /* More info lightbox */
    #more-info {
      max-width: 800px;
      margin: 0 auto;
      padding: 30px;
      background: white;
    }
    #more-info div{
      margin:20px 0;
    }
    #more-info button.mfp-close{
      position: absolute;
      top: 0px !important;
      right: -50px !important;
      background-color:white !important;
    }
    .mfp-inline-holder .mfp-content, .mfp-ajax-holder .mfp-content {
        width: initial;
        max-width: 1024px;
        margin: 60px;
    }

    functions,php:

    function gallery_more_info(){
    ?>
    <script>
    jQuery(window).load(function(){
      jQuery('.gallery-more-info-link').magnificPopup({
        type:'inline',
        midClick: true
      });
    });
    </script>
    <?php
    }
    add_action('wp_footer', 'gallery_more_info');

    Please advise,

    ofekw

    #1270983

    Hey ofekw,

    Please try to install and activate Enable jQuery Migrate Helper plugin, then set the jQuery version to 1.12.4 in the plugin options.

    Best regards,
    Nikko

    #1271001

    Hey Nikko,

    Thanks for your help, this issue is now resolved.

    Much appreciated,

    ofekw

    #1271012

    Hi ofekw,

    We’re glad that we could help :)
    Thanks for using Enfold and have a great day!

    Best regards,
    Nikko

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Magnific Popup stopped’ is closed to new replies.