Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1279274

    Hello Team,

    Have recently noticed that Code Block containing Magnific Popup has stopped working.
    Running Enfold 4.7.6.4, WP version 5.6.1 and PHP version 7.4.14

    Code Block: <div id="more-info" class="gallery-more-info mfp-hide">

    Enfold Child:

    /* Lightbox styling */
    button.mfp-arrow, .mfp-close{
      background-color: rgba(100,100,100,0.8) !important;
    }
    .avia-popup{
      background: white;
      opacity:1 !important;
    }
    button.mfp-arrow{
        width: 50px;
        height: 70px;
    }
    /* Fixing x button position */
    .mfp-zoom-in .mfp-figure, .mfp-zoom-in .mfp-iframe-holder .mfp-iframe-scaler{
      -webkit-transform: none !important;
      transform: none !important;
    }
    button.mfp-close{
      position:fixed;
      top:30px !important;
      right:30px !important;
    }
    
    /* More info lightbox */
    #more-info {
      max-width: 800px;
      margin: 0 auto;
      padding: 30px;
      background: white;
    }
    #more-info div{
      margin:20px 0;
    }
    #more-info button.mfp-close{
      position: absolute;
      top: 0px !important;
      right: -50px !important;
      background-color:white !important;
    }
    .mfp-inline-holder .mfp-content, .mfp-ajax-holder .mfp-content {
        width: initial;
        max-width: 1024px;
        margin: 60px;
    }

    functions,php:

    function gallery_more_info(){
    ?>
    <script>
    jQuery(window).load(function(){
      jQuery('.gallery-more-info-link').magnificPopup({
        type:'inline',
        midClick: true
      });
    });
    </script>
    <?php
    }
    add_action('wp_footer', 'gallery_more_info');

    Have installed jQuery Migrate Helper plugin but that is not helpful either.

    Please advise,

    ofekw

    #1279566

    Hey ofekw,

    Can you disable caching and minification for now?

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #1279607

    Hi Victoria,
    This issue somehow resolved.
    Thanks,
    ofekw

    #1279671

    Hi,

    I’m glad this was resolved. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Magnific Popup stopped’ is closed to new replies.