Tagged: ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #921537

    Hello guys,
    i try to find in this forum a and web out there, a solution for this issue and i cant find one =(

    Im using enfold-child on my multisite and i need translate contents for pt_BR
    i try everything what i find here and nothing happen. Why?

    ex:
    lang directory on child theme is already fine the translations
    child theme already has the info and i try 2 ways, none work, see below.

    #1
    function overwrite_language_file_child_theme() {
    $lang = get_stylesheet_directory().’/lang’;
    return $lang;
    }
    add_filter(‘ava_theme_textdomain_path’, ‘overwrite_language_file_child_theme’);

    #2
    add_action(‘after_setup_theme’, ‘avia_child_lang_setup’);
    function avia_child_lang_setup() {
    remove_action(‘after_setup_theme’, ‘avia_lang_setup’);
    $lang = get_stylesheet_directory() . ‘/lang’;
    load_theme_textdomain(‘avia_framework’, $lang);
    }

    lang directory has 755 chmod permission. When i try to update from wp-admin panel. Loco plugin says bad request or error.

    #922028

    Hey RODRIGO,

    What exactly are you looking to translate and where can we see it? We might need access to the backend of your site to be able to help you out, so please include admin login details in private with your reply.

    Best regards,
    Rikard

    #922283
    This reply has been marked as private.
    #923289

    Hi,
    I tried to do it and I did got the issue.
    Getting on a next step to debug the problem – if you remove the functions and load from the main theme and not child theme, do they work?

    Best regards,
    Basilis

    #924120

    Yes, because i have others sites using enfold folder, not child, and using loco translate i can make all what i want.
    BUT, in this case, if i use child theme, i need of what is in functions to make work, like your posts in this forum recommended.

    So what can we do?

    #926475

    Hi,

    Thank you for the update. Please enable the Appearance > Editor panel so that we can modify the functions.php file. Did you copy the language files inside the child theme’s lang folder?

    Best regards,
    Ismael

    #927799

    sorry but if isnt enable where i can go for do that ?
    Child, already have lag folder and contents

    #928846

    Hi,

    Please add this code in the wp-config.php file.

    define('DISALLOW_FILE_EDIT', false);
    

    If the function already exists, just set it to false.

    Best regards,
    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.