Tagged: ,

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #802096

    Since the last update I am not getting my main blog page to load more posts. The page displays the spinning icon for about 5 seconds, and then stops loading without displaying more posts.

    I researched the forum and found some entries on increasing memory size to 128MB, which I did, but which did not help.

    Please advise…

    #802235

    I am also having this same exact problem.

    • This reply was modified 3 years, 1 month ago by  ACNLatitudes.
    #802380

    Hi @juergenb,

    I’m not sure if you have SSL installed on your site, it seems like it is? Could you try changing the install URL to https under Settings to see if that helps?

    Best regards,
    Rikard

    #802648

    Hi Rikard:

    I don’t understand which “install URL” are you referring to, can you clarify please?

    If you are talking about the WordPress general settings URL called “WordPress Address (URL)” for my site, then I don’t want to change this to https://, I’d like my site to run as it always has under http://. I use SSL only for check-out pages where it is needed.

    Also, the “load more” button worked in previous versions of the theme for the last 3 years…

    #802853

    Hi,

    Yes, that is what I mean. Your backend is using SSL, so why not the front-end? The error you are having looks to be related to SSL, it’s being blocked because it’s requesting access to a file on a different domain. Please see private.

    Best regards,
    Rikard

    #803697

    Hello. I am having the exact same issue as JuergenB. Is enabling SSL for the entire WordPress site the only option for resolving this issue? If I change the url of the page to https:// it loads the masonry blog images fine, but if I leave it as http:// it doesn’t load them. Like JuergenB, I do not want to enable SSL for my entire website. Please advise.

    #803747

    Hi @acnlatitudes,

    I’m not sure if that is the only solution, but since the browser blocks access to that file because of it, then I think it would be a good idea to activate SSL for the entire site. I’m not sure why you would not want to have it for the whole site though?

    Best regards,
    Rikard

    #804084

    Hi @acnlatitudes, Rikard

    It seems not everyone wants to run their entire site on https, just like I don’t. There are many reasons for this I won’t go into. I use SSL only on certain pages.

    I played around with CORS headers and .htaccess configurations to allow cross domain access to the ajax.php file. I would appreciate if you could help us identify a solution that grants cross domain permission to ajax.php on both http and https.

    Can you or someone on your staff research a solution based on this?

    In the meantime, @acnlatitudes, I have the following temporary work-around:

    I have enabled SSL ONLY on my main blog page, using a redirect in my .htacess file.
    Here is a screenshot of this solution, perhaps if works for you as well:
    .htaccess solution for load more button

    Basically, what this does is to redirect anyone accessing my blog page to the SSL version of my blog page. However the rest of my site, including articles and traffic coming from search engines hitting my blog posts directly will be server the http version. Only when going to the blog home page does this kick in.

    The load more button now functions normally.

    • This reply was modified 3 years, 1 month ago by  JuergenB.
    #805352

    Hi,

    If you need to do that, you would need to hire someone help you make it like that.
    Please note – google is NOT supporting that, if you do it, you will be penaltise.

    Thank u

    Best regards,
    Basilis

    #809932

    Wait, so the “load more” only works with an SSL?

    #810135

    Hi Green Beans Creative,

    No, the load more button should work normally without an SSL.

    Best regards,
    John Torvik

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.