Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #172364

    I’ve got 16 layers beautifully transitioning in and out on the preview, but it’s only showing the first 4 on the actual page.

    The 16 layers are broken into groups of 4, and those 4 include an image and 4 pieces of text.

    So the idea is I have Image fade in, text fade in, text fade in, text fade in…then those 4 layers fade out to make room for the next set, which then fade in and out in the same manner, making room for the next step and then the final set.

    This is all working perfectly on the preview, but on the page the first 4 fade in exactly as expected, and fade out exactly as expected, but then nothing, the other layers don’t fade in as they do on the preview.

    This is the link to the page with the layerslider:

    As you can see, it’s showing the first Image-text transitions, but then all fades out and nothing after that!! :)

    Any help would be very much appreciated!! Thanks so much! :)



    Can you create an administrator account and post it here as a private reply?



    This reply has been marked as private.
    This reply has been marked as private.
    This reply has been marked as private.


    You’re talking about the 600 x 300 Text slide? There is a total of 16 layers divided into 4 groups. Please create new slide for each group. Click “Add new slide”. You’ll prevent the other layers from transitioning simultaneously by creating a different slide for each group.

    Watch this video:




    Yes, I’m talking about the 600 x 300 slide…the problem is that I wanted to use subsequent slides for other uses, so that doesn’t work for me – I haven’t added those yet as I wanted to get the first slide working first before spending time on the others in case I had to start over. The first 16 layers I want to automatically transition in and out (like a slideshow…as it has been set up and as it shows in the preview), and the other slides I want the user to be able to flick through manually (as they will be showcasing other services I offer) but in their own time (i.e. not automatically transitioning). I don’t believe that I can have the layerslider automatically transitioning for some of the slides and then switching to manual transition for others, or can I?

    Also, can you explain why it isn’t working on the page? The layerslider is obviously set up to be able to do what I want because it’s working perfectly on the preview, and I’m just using the functionality that is set up as standard. There doesn’t seem to be a logical reason why I need to split these into different slides in order to get it to show on the page. Can you tell me why it’s not working as it’s set up, when it works in preview?




    Hello Claire!

    The full set of documentation for the plugin is available from the LayerSlider plguin slides page. Just click on the Documentation button for a full breakdown of everything that the slides/transitions are capable above. It isn’t something we wrote but is a plugin included into the theme so we don’t have the answer to every question unfortunately.

    My guess however is that there may actually be a conflict with a plugin on the site. So try disabling all active plugins except WooCommerce alone and then log out of WordPress and back in.

    Then give the slideshow another test. Typically however Ismael is correct in how the plugin wants you to build your slideshows and each of those sections *should* be an individual slide. I’m not saying it won’t work, just explaining why it may not or that it may have issues.

    Best regards,


    Hi Devin,

    Thanks for your reply – I’ve tried what you’ve suggested, I’ve actually disabled all the plugins (including woocommerce, just to see if that would make a difference) and tried it again, and the same thing is still happening. I’m confused as to why the functionality exists if it’s not actually supposed to be used, and as to why it works in preview if it doesn’t work on the page. Is it possible to connect with the developer who designed and built it to ask them how it’s supposed to work?

    I can’t find the page you refer to above, can you please provide me with a link to the documentation you mention so that I can have a look at it?




    OK, now I’m getting incredibly frustrated :( I’ve now split the groups out into 5 separate slides, but I’m still only getting the first 4 layers showing. Nothing is showing on any of the other slides that I’ve created, even though (again) they are working on the preview. I’ve disabled all of the plugins so it’s not a plugin conflict that’s causing it. Can someone please help me with this because there doesn’t appear to be any reason whatsoever for these slides not to be working. This was one of the main feature I bought Enfold for, and I’m considering extending to another 5 sites, I don’t want to end up having this much of a struggle to get things to work every time… :(

    Any one out there want to be my hero and tell me how I can fix this?

    Thanks so much,



    Looks like it had to do with the images set for your other slides. The images need to be selected from your uploads and not from external resources.

    So if you look at your second slide, I’ve removed the image and it works fine.


    Hi Devin,

    If you’d looked at the image link in the slide you would have seen that all the images on all the slides are selected from the uploads folder, not from any external resources. I’ve even tried uploading the same image again and it still doesn’t work. Obviously just removing the image from the slider isn’t a solution (the whole point is to have the images on the slides with the text).

    The images on the 3rd and 4th slide are also from the uploads folder, and neither of those work either.

    Can you please provide me with:
    1) A solution for this – as I’ve said above I’m getting incredibly frustrated with trying to make the layerslider work, as it is causing me massive delays in launching this site and it is not instilling confidence in Enfold as I have a number of sites I was looking to expand use of Enfold into. Also the fact that sometimes it’s taking a day or more to get a reply from support (when the responses are not actually providing me with answers and solutions, or moving the situation forward) is very frustrating as I’ve been trying to get this working for a week now and none of the responses I’ve had from support have actually solved the problem or moved me any further forward than I was 7 days ago.
    2) The link to the documentation requested in my post above.

    I am desperate for some help in getting what should be quite a simple 4 slide layerslider with only simple images and basic text to work…I dread to think what would happen if I was trying to use more complicated functionality…and this is not encouraging me to attempt it.

    Please help! :(


    The documentation is *on* the layerslider section of your WordPress install. Click on Help in the top right hand corner next to Screen Options.

    There is something wrong with the image of the women. Not sure if its the image encoding or the file or what but if you include it any slide that slide will not load.

    It could be the same issue with the others but in any instance if I remove the photo the slideshow works. With it, it fails. So you may be able to just re-save it as a png or gif and fix the issue.


    Hi Devin,

    Thanks for the information on the documentation.

    Unfortunately the problem with the layerslider is not an issue with the image.

    If you log back into the site you can see that I’ve tried replacing the woman image with the exact same image that is on slide one, and the same thing happens.

    I’ve also created a layerslider which has the woman image showing first (which works fine), and uses the flower image (that works fine when it’s used on the first slide) on the SECOND slide, and exactly the same thing happens.

    The image is not causing the problem, because the image that you’re saying isn’t a problem creates the same reaction on the site, and the image that you’re saying there is a problem with works fine when it’s used on the first slide.

    It appears that there is a problem with the layerslider, not the images.

    Please advise how to fix this issue ASAP as I’ve been trying to fix this for some time now and none of the solutions I’m being offered are actually fixing the problem.



    At this point I’m out of ideas except for deleting each of the previous versions you’ve made and trying to start from scratch on them. The individual version coming from copies may have all been corrupted or something like that where they have inherited the same error/issue.

    Just as a quick test of this theory I made a “basic fade” slideshow and it seems to work fine with all of the images in.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The topic ‘Layerslider working perfectly in preview…not on page…’ is closed to new replies.